Tidal media is loading slowly, occurs always with MQA and sometimes with non - MQA

Starting about a month ago, I started getting the message stated in the topic title. It occurs on both of my zones and both are connected via ethernet.

Hi @Steven_Bonamo,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this occur if you play directly to one of your remote devices? Does non-TIDAL content exhibit this same behavior?


Describe Your Setup
I have 1 computer running Roon server connected via ethernet to 2 remote Roon “clients” for use with the Roon GUI. I play music through a local computer (AQ red DAC connected) connected to the Roon server (again via ethernet) and also through a laptop connected via wireless to the Roon server running Windows Server 2012 R2 connected to an ultrarendu. In both setups playing music through the Server 2012 R2 PC and ultrarendu and the Win10 PC connected to the AQ Red DAC both hard wired receive the error previously listed. It occurs always with MQA and sporadically with non - MQA files. Locally stored files play fine. This starting occurring after a Roon update, but could be coincidental since there are frequent update, as you know. Bandwidth is high: ~120Mbps download and ~12Mbps upload. I can also stream full HD movies without an issue, so bandwidth is not a problem.

Thanks in advance for your assistance.

Hi @Steven_Bonamo,

Can you elaborate a bit more on your current networking setup? What networking hardware is in use? Are there any switches that your Core is connected to?

If you play to just the internal speakers of the Win10 PC and not the connected DAC do you experience this as well?

We have seen users have a better TIDAL experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?

With the Win10 PC it is hard wired to a wireless router that is connected directly to the modem which connects to the ISP. There is no added switch to this setup. Also, I can play Tidal MQA and non - MQA all day long without a hiccup. The MQA and sometimes non - MQA problem only occurs through the Roon app.

Hi @Steven_Bonamo,

I just tried it and no difference, same problem. I also went ahead and did a bandwidth speed test and it’s virtually identical at ~100Mbps using either DNS configuration. If I had to pin it to 1 thing, I do believe there was a Roon update that correlated to this issue.

Thanks for confirming it also occurs with the internal speakers, @Steven_Bonamo!

Since this used to work and it’s not an issue specific to a certain endpoint, I’d like to try the following:

  • Stop RoonServer
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Just tried your changes and the issue still occurs.

Think I figured it out - A few weeks back I changed 1 Windows core machine Intel gigabit NIC setting: speed and duplex from Auto negotiate to 1000MBPS duplex and apparently that’s causing some issues. Now through 3 MQA songs and no issues.

This is a good tip for other to be careful of manually setting negotiating since this gigabit NIC is likely popular.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.