Tidal media is running slowly... not able to solve

Roon Core Machine

Hardware: IntelNUC 8i7 BEH2, with 2 GB RAM, SSD HD for Roon Rock
image

Networking Gear & Setup Details

My NUC is connected through ethernet cable to one of the DECO units on the 3rd floor. Through mesh wifi it is connected with other DECO unit on the 2nd floor (which acts as main mash node) and my Chord Poly streamer in living room is connected through wifi with DECO unit on the 1st floor
image

  1. WiFi connection with newest mesh TP-Link Deco X20 with huge bandwidth (wiFi 6, dual band, 1800 Mb/s),
  2. Internet with optical fiber network to my house with checked 300Mb/s

Connected Audio Devices

• Living Room: Chord Poly (through RAAT) with Moly Dac connected to amp and speakers
• Sleeping Room: Sonos One (through AirPlay)
My remotes are Iphone 11, Iphone 7, Tablet Huawei AG52

Library Size

• My music is stored on Synology NAS 218+ as well as I am using Tidal,
• I have 4937 tracks on NAS and 1514 tracks on Tidal

Description of Issue

Unfortunately I am continuously having issues with “Tidal media is running slowly. This may indicate a networking or connectivity problem”.
I thought it is a network issue so I:

  1. completely changed my network to the newest mesh TP-Link Deco X20 with huge bandwidth (wiFi 6, dual band, 1800 Mb/s),
  2. Upgraded my optical fiber network provider form 100Mbits to 300Mb/s
    So for sure it is not related to my network speed.
    After I upgraded it happens not so often but still occasionally, somtimes once an hour, sometimes less frequently. Track then stops and moves to the next song that works ok. When I put back the track that stopped and generated problem, second time it works ok and could be played without interruption – so it is not related to any particular song/resolution.
    Please see below screenshot:

image

My signal path is the following:

image

I checked also many threads with similar problems - and I checked it is not computing power as it never gets below 4,5 so it should not ne my dedicated IntelNuc which is Intel i7 with sufficient RAM.
Last time it happened today around 10.00 AM CET.

Please let me know as it is very upsetting. Thank you in advance! Lukasz

What are the dns server settings on your router.

Prefered DNS in DECO mesh network is: 192.168.10.1
I hope it is what you asked for :slight_smile:

What is interesting, problem exist as well when playing from local library. Then a message „Audio media is playing slowly…” appears.

Your system is going to be constantly swapping to disk.
I think adding more RAM is your best bet. As an example the last 2 versions of the raspberry pi have 4gb and 8gb respectively. 4GB is the recommended minimum.

ROCK For Small to Medium-Sized Libraries

We recommend the NUC10i3FNH with 4GB RAM and 64GB M.2 SSD for small to medium-sized libraries. Please note that 4GB RAM sticks and 64GB M.2 SSDs are difficult to find, and there’s little price difference between the 8GB and 128GB upgrades.

1 Like

Today between 12 and 12.30 it happend at least 10 times, almost every song was skipped.
I do have 4gb ram, sorry for claiming 2gb first.

You simply do not have adequate resources to drive the gear in the manner you are trying.

As a minimum I’d throw 8Gb RAM in there. Not even aware how I could get only 4Gb RAM anymore.
How much processing are you doing? none 8gb is good, some? add RAM
You have an i7 processor and are choking out the path to get it data to process.

1 Like

While there appears to have been some Tidal issues today, what @MamaTried says is totally correct.
I would certainly add an additional memory stick to your NUC. While 4GB is the minimum, I would probably go to 8GB as Roon seems to get eber bigger and will require more memory in the future

1 Like

Guys, thank you for your support but i bought Nuc according to Roon specification. So i thought it should be sufficient.
Can anyone from Roon confirm that RAM is the problem?

Lukasz you can find the minimum specifications here, and if you have 4GB that should be enough for a mid sized library

Hi @Lukasz_Marczyk

The RAM needed definitely depends on library size, but yours isn’t too big so I wouldn’t expect 4GB to be a problem.

Can you answer a few questions to help us better understand what might be happening?

  • Does this happen with local content, or only Tidal?
  • If you disable DSP is there any change?
  • Does this happen for all endpoints?
  • If you go to Settings > Services and set Tidal streaming quality to the lowest setting, is there any change?

If I’m not mistaken you are connecting your core to a mesh wi-fi point? This is not recommended and, I would venture, the most likely cause of your problem - the core should be connected to the router (or a switch) via ethernet for best performance. Also set the DNS server for the router to 1.1.1.1.

Hi, thank you for your reply:

  • Does this happen with local content, or onlyTidal?
    LM: both local and TIDAL, there is slightly diffrent messege (once TIDAL, once networking problem) but happens on both
  • If you disable DSP is there any change?
    LM: if i lower upsampling to DSD64 - no change, still error happens, if I switch dsp off, it does happen as well :frowning:
  • Does this happen for all endpoints?
    LM: interruptions happen also to other endpoints, i dont know exactly if the error is the same
  • If you go to Settings > Services and set Tidal streaming quality to the lowest setting, is there any change?
    LM: i still need to check but looking at answer 1 i dont suppose, as there is no problem with outside connection