Tidal media loading slowly error

Hi Guys,

Details are as follows:

  • Windows 10, AMD Ryzen Threadripper PRO 3975WX, 128gb ram

  • Network connection on computer is via ethernet cable with 1GB up and 1Gb down with a 1 ping. Wifi gets 500Mb up and down with a 5 ping.

  • I have zero connection issues with numerous devices connected in the house

I tried out Roon last year and connected my Chord Mojo/Poly combo and TIDAL. I had zero issues and everything played well.

This year I wanted to come back to TIDAL however I am having an awful time trying to get anything to play. I have a new computer and a new internet provider so obviously there is some sort of connection/ network issue but I have no idea what it would be.

When I try to play Tidal I cant get through 15 seconds of a track without it stopping and skipping every song. I constantly get the error message saying, " Tidal Media Loading Slowing. This may indicate a networking or connectivity problem."

When I try to play live music it says, “Unable to play this station. It’s address may be temporarily unavailable.”

This happens on all stations.

If my end point is the computer speakers all plays just fine and there is no issue. It’s only with the Chord Poly that I am experiences these problems. And yes, I have checked all settings in the Chord GoFigure app.

I am assuming there is an easy fix but I have no idea where to start.

Please help!

Thank you

Hi @john_wheeler, can you give some details on your network setup? Router, switches, etc.

I’d also recommend trying to use a different DNS on your router — Often times that can help.

UPDATE: I uninstalled Roon from my laptop, downloaded again, re-installed, and that appears to have fixed the problem. Kind of a pain in @$$ to do, but no issues now.

I am experiencing the same error messages with TIDAL and local files. It is a relatively new issue for me. I’ve tried changing the DNS, but doesn’t seem to be working. My ISP is Google Fiber Gigabit running through Google WiFi mesh which is running through a switch and connected directly to the end-point mesh puck via Ethernet. UL/DL speeds are in the 400 mbps range. I am running Roon on a 2017 13" MacBook Pro and streaming from Roon to a Chord Mojo/Poly.

Add images

Hi @Weaver_Johnson,

You mentioned it’s happening with local files as well — Can you share what error it shows when you’re playing local content?

Does it happen every time you start playback or is it a random issue?

Does the same issue happen for every endpoint?

I also experience this track skipping ‘Tidal media loading slowly’ error daily. I realize that this thread is a bit old, but what caught my attention was the image referencing a Canadian radio station and I wondered if @john_wheeler is located in Canada (I am).

I have had numerous issues with Tidal playback on my iphone where the app just doesn’t respond (e.g., after opening the app and playing a song it buffers continuously, only resolved by killing the app, restarting the app and then the song plays fine). I had contacted Tidal support but they couldn’t offer any solutions, suggesting it was my ISP or mobile provider. The playback issue happens on my home wifi, 5G data, friends’ wifi, and on my iPad. I wondered if Tidal’s servers are the issue.

Back to Roon, my core is on a Mac mini, endpoint is on an RPi DAC HAT, all ethernet connected.