Tidal Media Loading Slowly - still broken

My roon core is a highly spec’d gaming windows 10 PC with 32 GB of RAM. It is way over the min requirements yet I’ve had this tidal media loading slowly problem for a couple years now. I would have thought Roon would have fixed this by now. It is definitely NOT my internet or my PC or Tidal. I can rule all those out because NONE of these have any issues when I experience this problem This is definitely an issue with ROON core software. If I reboot my core PC, the problem magically disappears for awhile. But it always comes back. Really sick of rebooting my core PC 3 times a week just to fix this. Any chance the Roon dev team could actually fix this? Thanks.

Hey @Thomas_Shope,

We’re so sorry to hear this has been going on for so long. We’d love to help figure out what causes this and what steps we can take towards a resolution.

Would you please share some details about your setup and the issue using this article as a guide?

Could you please let us know what DNS is set up on your router? We’ve found streaming services work more reliably with Cloudflare DNS, Quad9 or Google DNS.

Finally, the next time this happens (before rebooting), would you please grab a set of logs, zip them up and upload them to our drive?

Please, include a timestamp in your post (local date and time when the Tidal Media Loading Slowly message appears).

Looking forward to hearing back from you :nerd_face:

Ok, I’ve uploaded my log files. The file name is my email address. My system info is as follows: Window 10 home, Intil Core I7-9700 (8 cores) 32 GB of ram. This machine runs little other than ROON. I have no anti-virus running. My router is a Google Mesh Wifi Router and I have 4 mesh hubs around my house, including one very near this maching running the ROON core. I have zero internet or wifi issues on many other wifi connected devices including devices that stream video. Additionally, I can stream TIDAL without ROON and NEVER have a single hiccup in playback. The problem with TIDAL only happens when playing TIDAL via ROON. My roon server is version 1.8 Build 880. My ROON app is running on an Apple IPAD and is ROON version 1.8 Build 880.

Hey @Thomas_Shope,

I cannot apologize enough for not having replied until today. I have been out of office until yesterday and I just now saw this.

Before moving forward, I wanted to ask if there was any change in the meantime? Any other symptoms?

I did just upgrade to windows 11 but I’d say it’s no better or worse. Still getting the tidal is slow message.

Here’s another clue. Tonight I was attempting to listen via my b&w foundation duo speakers which are roon endpoints. It was so bad tonight that even after rebooting my server I could not get roon to play anything without getting the slow tidal message after 3 seconds into any song. But here’s the kicker, when i moved to my living room system which is also playing roon but via apple airplay I had zero issue playing anything. Played flawlessly through apple airplay (from roon server) but won’t play anything to a true roon endpoint. Delightful. Please fix this.

This is almost always a networking issue - either internal or internet connection (or both). It is highly recommended to have the Roon Core connected via ethernet, so I would strongly suggest you try that as a first step. Also all the usual things like using Cloudflare DNS servers and logging out of Tidal everywhere and re-logging in through Roon.

It might be a network problem but it’s a network problem that’s being caused entirely by the roon service. I know this because no other application in my entire house or any application running on that same machine has any network problems. Additionally Apple airplay works perfectly from that same machine via Roon. Hardwired ethernet connection is not an option unless I have 100 foot cable running through my house. That would be delightful, my wife won’t mind it running down the banister of the stairway through the dining room and into our master bedroom closet. That should be great. I’ll hook it up right away.

Sorry you are still having problems here with Tidal replay.

However it is not a safe/ valid assumption that there is not a network problem when other " lightweight" systems work fine and Roon does not.
Roon is a LOT more bandwidth intensive than say Tidal on its own or even a 4k movie.

I know you say it is not practical to run network cable due to logistics but is there any chance to try a cable for a test to see if it is indeed an issue?
Thank you.


I could potentially run a temporary ethernet cable to check to see if this alleviates the problem. However, I don’t understand why roon should be far more network intensive than streaming video which is has a substantially larger data payload. I also don’t understand why all other streaming devices work perfectly in my home. Sonos works perfectly. Apple TV works perfectly. And not to mention many other connected devices. It’s hard for me to believe roon is the most Network intensive application I run in my entire house. If that is the case I would say it’s very poor software engineering. Why should Roon require massive network bandwidth compared to all other streaming devices? Also, why would Apple airplay work through Roon perfectly while roon endpoints fail to deliver content without glitching? If this were a network problem wouldn’t Apple airplay via Roon also be problematic at the same time?

Just trying to help mate, so you know, keep your tone down. Roon has quite specific network requirements that are not the same as Airplay or streaming video. There is a ton of info on the Roon website about the recommended configurations. There are many other options available to you, and I’m sensing they might be better suited to you. I’m out.

I’d like more info on this aswell,ive had the same problem as you,I can stream 160gb 4k hdr/atmos from real debrid but roon/tidal run slow,there is no way roon is harder to run than a 4k movie

1 Like

Didn’t mean to offend but I think there is a tendency to blame the user or his equipment for this type of problem and all signs currently point to the problem being with roon software. If roon requires a hard wired ethernet connection then they need to advertise it that way. This is a software problem. While it might be true that certain network configuration changes might eliminate the problem, no other software or device in my home has required special configuration to make it work. I’m happy to make any configuration changes suggested by roon support. So far I have not received any suggestions. I can see that users have reported similar issues going back several years. I think this needs to become a priority for the roon dev team.

Seems to me flawless streaming and simple setup should be the most important thing roon delivers. Add new features AFTER you have completely achieved this.

Well, they do mention in the Networking FAQ

For all networks

No matter what your network setup is like, there are important factors to keep in mind to ensure you are getting the best out of your Roon experience:

  • Your Roon Core should always have a wired connection
  • If your library is stored elsewhere on the network, always ensure that both your Core and storage location are using a wired connection. Avoid WiFi between your Core and media storage at all costs.
  • Avoid connecting high resolution/high performance audio devices to Roon via WiFi to ensure optimal performance.
  • A wireless connection from your remote device to your Core is perfectly acceptable and expected in most cases.

Hi again @Thomas_Shope,

Sorry yet again for not having posted on this thread until today. I could explain why (like high volume, holidays and so on) but it’s not an excuse, so I’d much rather leave it at a heartfelt apology.

@Rugby has linked to our documentation that explains that we recommend having a hard wired connection, particularly for your Core. Would that be possible, even temporarily?

Also, I couldn’t find an answer on whether you had a chance to change the DNS on your Router to Cloudfare or Google.

Finally, would you please check and see if there’s any firmware update for your Bluesound speakers?

Can’t wait to hear back so we can see what the next steps can be towards resolving this.

For the record, I have the OP’s issue rather too often but with wired ethernet and Google DNS set. It normally takes a simple server and/or router reset to resolve but for the last 2 weeks Roon hasn’t been playable for the same old reason. No matter how many resets and restarts, the issue persisted. Yesterday, my iPad running remote froze, needing a reset. Problem solved instantly. Go figure.
I must remember to reset everything, not just the signal chain.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.