Tidal MQA stream crackles through ROON but not via Tidal App

I love MQA and the integration with ROON. Unfortunately all MQA files I stream from TIDAL give occasional crackles or static sounds, from one per minute to a burst of a few. It seems to happen randomly in tracks. It is great as a retro-vinyl experience but I could do without. locally stored MQA files play OK. Playback using the Tidal App also works OK, which makes me think it is some setting in ROON.

I play from a dedicated 2011 MacMini server, through MiniDSP with DIRAC into a CHORD Hugo.
internet connection through ethernet capable of a nett 20Mb/sec.

signal%20path


Hello @Dirk_veldhorst,

Thanks for contacting support, I’d be happy to take a look over this issue with you. Can you please confirm for me if you experience the same behavior without the DIRAC? If you temporarily connect the Hugo to your MacMini, do you still experience crackles then?

I would also take a look at the settings you posted a screenshot of, if you enable “Use Maximum Buffer Size” are the crackles reduced/go away? If you do not use 32-bit tracks in your library, can you also try disabling Integer Mode and verify your results then? This KB article has a description of the various Audio Settings explaining what these modes do: https://kb.roonlabs.com/Audio_Setup_Basics

Please let me know your findings when possible.

Thanks,
Noris

Hi @noris
It took some time to follow up on your suggestions.
When I remove the minidsp/Dirac device from the chain I still get the crackles.
I set it to max buffer and also disabled integer mode. Unfortunately still crackling MQA tracks but somewhat less though.


KR
Dirk

Hello @Dirk_veldhorst,

Sorry to hear that the crackles are still present with the settings changes. Can you please try performing the following settings changes and let me know if the same issue occurs on the built-in speakers for your computer?

  • Navigate to Roon Settings -> Audio -> Core Audio Device Setup
  • Press “Load Defaults”
  • Turn on “Exclusive Mode”

This test will help determine if all of your zones are affected or just the Hugo and will be a good data point to have.

Thanks,
Noris

Hello Noris

Thanks for bearing with me. It took again some time to take this new step.
I connected a good pair of headphones to my MacMini 2011. Listening to Core Audio, per your instructions all settings are defaulted and Exclusive Mode is turned on.

Unfortunately I still hear the occasional crackles in all MQA files, every 20 sec or so. It is a nuisance because I really like MQO; better than normal HiRes.

KR
Dirk

Hello @Dirk_veldhorst,

Thanks for letting me know the crackles are still present. I have a few other suggestions here:

  1. Are you Chord drivers up to date on your PC? Is the Chord firmware the newest? I would make sure you are using the newest drivers/firmware from Chord’s Website
  2. If you apply a bit of Headroom Management to your setup, do you still notice the crackles?
  3. Have you tried a different USB cable yet for the Hugo?
  4. Do the pops/clicks happen for any of your other zones or just the Hugo? Even finding is they happen on “System Output” will be a good data point to have.

Please let me know your reply when possible.

Thanks,
Noris

Hi Noris

As indicated the crackles were not only related to the Chord Hugo but also occurred when I used headphones directly connected to the MacMini. I use optical connections BTW, no USB.

The strangest thing has happened in the process of switching from System Output to Core Audio and dis/enabling them: the pops and crackles have disappeared so it seems. Maybe it was an Apple update or sheer luck. I hope for the best!

Thanks anyway for bearing with me.

KR
Dirk

1 Like

Thanks for letting me know the issue has resolved itself @Dirk_veldhorst , if it appears again don’t hesitate to reach out!

– Noris