Tidal MQA stuttering

Hello @dvorak,

I’m sorry to hear about the troubles you’re having with streaming MQA content in Roon. Let me explain some of the technical details of the situation and provide some tips that may improve the experience for you.

While I’m unsure of how Tidal handles their buffering, I can give you some further insight into how the Roon application handles Tidal streaming. The second you click play on a track from Tidal in Roon, Roon will attempt to buffer the track in its entirety as quickly as Tidal’s servers will upload to your computer, and if it’s able to buffer the entire track we will attempt to buffer the next track as well. While MQA content is smaller in size and thus requires less bandwidth than regular 24/96 high resolution content, it’s still not quite as compact as CD quality streaming, because of the increase in the bit depth from 16 bits to 24 bits.

If you’re interested in further troubleshooting, I’d recommend running your Roon Core instance on your Mac temporarily to see if you’re able to successfully stream in that case. Looking at the specs of your QNAP, I don’t see a solid state drive listed to use as your database and cache mount. This can impact the performance of Roon since it is designed to be run with it’s database on a solid state drive. Also, the NAS based Roon Server instances depending on the device may subject to permissions and caching limitations that are not present using the regular Mac/Windows/Linux installers.

We have had a few customers with Tidal streaming issues report success by changing their DNS servers to either a “1.1.1.1” address (CloudFlare DNS) or 8.8.8.8 (Google Public DNS).

-John

Hi John

So I have finally managed to do the experiment you asked: running a Roon Core on a Mac to see if there’s an issue with the NAS’s computational performance. This machine is a quad-core 3.5GHz i7 iMac with 16GB RAM and a Fusion drive (so SSD performance for the recently-used data), and connected via ethernet.

I signed up for a new Roon trial just for this. Installed as a new Core, linked to Tidal. I get exactly the same problem I’ve been reporting earlier: Roon can stream non-MQA masters from Tidal no problem but stutters and skips with MQA content.

On this same machine I also installed Tidal itself and had no problem streaming the same MQA files which were stuttering in Roon.

I then installed a trial of Audirvana+ and linked it to my Tidal account and played the same MQA tracks. Again: no problem.

Note in the screenshot that Audirvana helpfully shows the status of its pre-buffering. My Internet connection is well sufficient to stream MQA but it offers less than 2x the necessary bandwidth. I have a feeling that Roon’s buffering algorithm tries to download two things (different segments of the track, or two copies of the track, or this track and the next track?) at the same time… which would mean that suddenly there’s not enough bandwidth to sustain the part that I actually want to play now.

Could you check with your dev team about that hypothesis please?

Thanks
Terry

Hello @dvorak,

We’re going to discuss this with our dev team and see what might be happening with our buffer here. In the meantime, can you confirm whether this happens streaming to other outputs (like local output on your laptop connected over ethernet) – that will help us confirm this is related to upstream bandwidth and not something in your network or related to Squeezebox?

-John

The inability of Roon to stream Tidal MQA on my network is totally consistent regardless of whether I’m outputting to Squeezebox Touch, direct to DAC over USB, to an iPad or iPhone as an endpoint, or using the iMac’s built-in speakers.

Just in case anybody’s still inclined to wonder if my local network is contributing to the problem…

The playback of local files from Roon on my NAS work perfectly at all times, with Roon’s own UI confirming bit-perfect transport through the steps along the way. My DirectStream DAC shows incoming sample rate and bit depth, so I can confirm what’s happening at the final step of the transport chain. I have zero problems with high bandwidth local transport:

  1. 1x DoP and 24/192 PCM via Ethernet to SqueezeBox Touch (USB to DAC)
  2. DXD (32-bit 352.8kHz PCM) via Wi-Fi to Roon iPad endpoint (USB to DAC)

I have the much the same hardware and exactly the same issue. Everything is roses until I try to listen to MQA via Roon - and each of my endpoints is connected via ethernet. If I want to listen to MQA now, I use Tidal desktop app and usb to whichever dac I’m using. Thanks for bringing this up and following through on it - I’ll be watching to see the outcome!

How fast is your internet connection, Mark? As per speedtest.net etc

Just tested from my iPhone at 94.5 mbps. Usually faster when I test from my computer.

I found a thread in PS Audio site suggesting that the DSD and DSD Jr settings in Roon need be be on docoder only. That does seem to have helped.

With your internet speed I think it’s very unlikely you’re having the same problem I’m having. If you play Tidal MQA using Roon on a computer’s built in speakers, or on your iPhone’s built in speaker, does it play reliably without stuttering?

I imagine your answer will be “yes”, whereas for me that doesn’t work either. It’s got nothing to do with the NAS or the DAC in my case because it’s still a problem when I take both of them out of the picture.

Hello @dvorak,

I just wanted to chime in and let you know we’re still working on this. Obviously, Tidal buffering strategies are something that effects a large portion of our user base, so any changes need to be very carefully considered. I will be sure to let you know when I have further information to share on the behavior here.

-John

1 Like

Have you been able to determine whether my hypothesis is on the right track? Is your code trying to download two things at once?

I believe that this is plenty fast enough and I also believe that it is not internet speed that is the problem. I have a 400MB download speed and this also happens to me with MQA and HiFi.

The only way I can get Tidal to work though is to have no type of activity on my network going on at all. That means that no one is surfing on their phone or tablet. No streaming of Netflix, Hulu or You Tube. No network backups of any devices or PCs. Nothing.

The moment any of these activities start, then Tidal will studder in Roon and will not function. Tried the DNS settings. This seems to help a little but in the end will not work.

Roon will always work with local files and the Tidal Desktop app will always work, just not through Roon.

–MD

@john
At the same time if I play Tidal MQA with Roon with stuttering I can play Tidal MQA with Tidal desktop app without stuttering. And at the same time Tidal MQA with Audirvana Plus has stuttering, too.
In my case it only happens if I use a mobile internet or a 2.4 GHz WiFi, but it never happens if I use a 5.2 GHz WiFi. I use Windows 10 Surface Book.

If I run Roon core on my Windows PC the experience is horrible with Tidal MQA. Non-Stop shuddering and sometime 10-15 second gaps with nothing (20-26x processing speed). The PC has a Intel I7 with 16 gigs of ram and a 250 gig SSD running Windows 10. If I run the core on my 2014 MacBook Pro with a Intel I5 and 8 gigs of ram with a 120 flash drive Roon runs nearly flawless (18-25x processing speed). I have 500/500 Fios internet and run them both hardwire. I’d prefer to run this on my PC because I built it for entertainment, but there’s something seriously wrong with the Roon Windows app.

I could not get acceptable results running Roon on a Dell XPS15 i7, 32 GB RAM, 1TB SSD connected by ethernet. I bought a Roon Nucleus and it runs perfectly.

Do you have a link?

A link to what?

I would start a new thread as support may miss an addition to a two year old one.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating

I am a new Roon and Tidal user, just signing up yesterday to Tidal.

I saw your conversation and thought I would relay my recent experience. I had exactly the same problems discussed in this thread.

Playing any MQA file from the stream, the music sounded fantastic for about a minute, then it began to stutter. It felt to me like a cache was filling up.


Verizon FIOS->Unifi switches->Mac mini (2020) for the Core-> three endpoints (two 2010 mini Mac) and one 2020 MacPro. All computers WIRED.


My first experience with Tidal was stuttering BOTH in the Roon app and the Tidal app (on Mac mini). I did not believe it was a network problem as I have a fast system (FIOS gigabit service from Verizon and a great Unifi network in the house - all computers wired).

I found, in the Tidal app, a window for sound output. In this window I set “use exclusive mode” to ON, “force volume” to ON and “pass through MQA” to OFF. The stuttering from the Tidal app stopped but was still present in Roon.

In Roon, I had grouped my three play areas together. When I ungrouped the endpoints and played each one separately, the Roon stuttering went away.

I have been playing for about the last 4 hours with NO problems. Perhaps, what I did had no effect and things would have gotten better with time. I don’t know but that is what I did. Maybe it might help someone.

1 Like