Tidal MQA to xDSD works, Tidal+Roon MQA does not

(Nicolaas Verheem) #1

Core Machine (Operating system/System info/Roon build number)

iMac with newest Roon Core.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Apple Airport Extreme to iPhone

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Apple lightning to USB to iFi XDSD OR Project S2

Description Of Issue

Hi! I love the little iFi xDSD for portable headphone listening. But I found something weird. When I listen to MQA tracks straight from Tidal App on my iPhoneX (with Apple lightning to USB camera kit), I get a purple light on xDSD(i.e. MQA hardware decode/render), and all is good. E.g. Cat Stevens “Where does the children play” in 192/24 Master sounds great! But when I listen to the same track, by using Roon on my iPad to send stream from Tidal (via Core) to the same iPhone, with same cables etc., I get a green light on xDSD (i.e. no MQA, just PCM). I would have been tempted to conclude Roon or it’s settings are to blame, but if I repeat the exact same experiment with my Project S2 instead of xDSD, I get MQA on S2 in both cases, i.e. Tidal App straight, and Tidal via Roon both shows MQA. So it’s not Roon or it’s settings, per se, but the combo with xDSD. Weird, since the xDSD works straight from Tidal app?

I double checked all settings in Roon to make sure the MQA data is passed through all the way (ie not decoded by Core or iPhone app), but still no go. What’s also interesting is the Project S2 seems to “hunt” a little bit before settling on MQA @ 192kHz, almost like it’s negotiating capabilities or syncing to a higher and higher bitstream one by one. But in the end it shows MQA 192kHz.

I tried all combos of PCM vs DSD vs DSD over PCM, Initial etc., and obviously disabled Core MQA support. What perplexes me is the asymmetry: Both Tidal App and Tidal+Roon works on Project S2, whereas Tidal App works, but Tidal+Roon doesn’t on xDSD.

Any ideas ?

Thanks much
Nicol

(John) #2

Hello @Nicolaas_Verheem,

Have you tried setting the “MQA capabilities” in the Device Setup screen to “Renderer Only” when the xDSD is connected?

-John

1 Like
(Nicolaas Verheem) #4

Hi John

Thanks for the reply. I’m 99% sure that was one of the first settings I fiddled with, but I’ll double check again since I went back and forth so many times…

Ideally, I would like the xDSD to do both MQA decode and render. Also not sure how Pro-ject S2 could be working if this is the issue…

Cheers
Nicol

(John) #5

Hello @Nicolaas_Verheem,

To the best of my knowledge, the iFi xDSD is an MQA Renderer device. The xDSD will not “Render” MQA unless the MQA Core Decode has been done off-device.

-John

(Nicolaas Verheem) #6

Thanks again. I tried again on all different settings, including renderer only, both, and no MQA support same result.

BTW Project S2 shows MQB from Tidal, not MQA, so it seems Tidal app is doing first unfold as expected.

I raised a ticket with iFi too, and will update if I hear anything.

Cheers
Nicolaas

(Peter Lie) #7

MQB means it received a MQA Core signal, sent by Roon after doing the first unfold to MQA Core. As John said you need to set the iFi to Renderer Only.

Post the signal path.

(Nicolaas Verheem) #8

I was in a rush so couldn’t do comprehensive tests, but I found the problem this morning - John’s answer led me to it. The xDSD can’t handle full MQA, it’s only a renderer. Of course the iFi website/manual doesn’t say that in so many words…

Furthermore the Roon “Advanced” device settings, combined with “normal” device settings was confuscating me some: On the device settings I tried (1) no MQA support, (2) decode+render, (3) decode only, (4) render only, yet none of them worked. IMHO those 4 should have covered all bases, with the iPhoneX app doing what needs dunnin to have a working MQA signal path. That assumption was wrong. I never turned ON the Core MQA decoder in advanced settings. Doing that fixed it, I get my purple MQA light on xDSD.

The whole thing is still confusing me a bit. If Roon Core on my iMac wasn’t decoding 1st fold MQA all along (ie it was passing the whole stream bit perfect to iPhone), why was Project S2 showing MQB not MQA ? Who was doing first unfold. Was Roon iPhone app doing first unfold ?

I’ll take some pics and capture signal path the weekend, can’t reach my Core now :slight_smile: