Tidal mystery - tracks missing today [Solved]

I’m new to Roon and Tidal
but yesterday had no problem playing tracks from a George Harrison CD, Brianwashed, but today the same tracks are not playing. (Just one is) Whats happening?

Experienced the same thing about 30 minutes ago, most Tidal tracks would not play in Roon but they did in the Tidal app. But now it seems to have been fixed for me.
I suggest moving this post to the Support category in order for it to be noticed by the dev team.

Many thanks - appreciate the response. It seems to be a temporary glitch as all ok today.

Thanks Stephen and chikolad,
I’m going to mark this solved because it doesnt require dev attention at this time. Please post again if the problem recurs as it can be of assistance to know how often such glitches are occurring.

1 Like

Jip having the same. Listened to an album of Lenka today via roon. Tonight when I wanted to play the album again it only showed track 4. After trying a few things I can see all the other tracks now except track 4. Very strange.