TIDAL not recognised after nucleus software update

Hi, I just updated software on my Roon Nucleus and I no longer have access to TIDAL. I tried to add the service again, but Roon no longer recognises my Tidal account password. I get an error message - ‘there was an unexpected error. Please check your account details. (Missing Method). ‘
Can anyone help me trouble shoot this problem ?

First step is to reboot everything.

I got that, but entering the Tidal credentials in Roon worked (with some difficulty). Got some error message too. Persevere!

I can log in to TIDAL after the nucleus software update, but i can’t play music of TIDAL.
I always can see “Error loading page” , It’s annoying me very very. How do i solve this?

I got a missing method error when I try top löog in after update on Ipad.

Same problem, coming home after one week holiday break, tidal is not working anymore. Got in touch with tidal, done several setups, tried two hrs with support from internet provider, still not working.
Finally i get a free trial from Qobuz, it works. Strange, where will i find a good support to get tidal running?
Any ideas?

Hi, same here. I got the same message (Missing Method) since last update on my Qnap NAS (Version 1.7 (build 528) stable). Tried rebooting of course & changing password.
Tidal is rock-solid when streamed through my 5 sonos Speaker-Setups simultaneously.
Also via the Tidal app on iPhone and iPad.
I usually use Roon to stream to my Sonos Systems or via LAN to my Devialet 220pro.
Any Input would be great. It’s been a month now. Using Sonos App as my companion :cry:
How did you manage?

I futzed with things until it worked…

Don’t remember exactly. But in Roon, I basically removed the subscription and then added it back again, and that took care of it.
The reason I’m a little hesitant on the details is that I had some trouble on the Tidal side, when logging into Tidal from Roon. But clicking here and there solved it.

Note that my Roon Core is a Nucleus, not a NAS. Could be different.