Tidal not working with Roon [Solved - PiHole + DNS Change]

Core Machine (Operating system/System info/Roon build number)

Win10 Roon core1.7(b571) latest

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus RT-AC86U Ethernet connect to Win10 on a Nuc8i3BEH

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

RopieeXL on Raspberry 4, ifi XDSD on USB port

Description Of Issue

Tidal not working on Roon when choose the Tidal TAB, I can see the playlists, but it shows ‘This playlist is empty’ when you click the playlist. Nothing shows In Your Favorites, Failed to load artists, albums, tracks:(

But if I click Overview TAB in Roon, it shows my Recent Activity from Tidal and the songs can be played well. But the albums played or added activity is for a few days ago, not most recently, no more update since it stop working.

The tidal app on my computer or phones work well in my home internet.

Tried to clean cache and logout, restart, login, anything I can do for a lot of times but got no luck.

Please help! Thanks a lot!

Hi @yi_han,

Welcome to the forum! Can you please use these instructions to send me a copy of your Roon logs?

Are you seeing any other problematic symptoms in your setup? Are you audio devices still visible under Roon Settings -> Audio?

I found the reason, that’s because the pihole. I dont know what’s wrong with it but I saw another post in roon support forum gave the solution. I did the same which is changed the DNS server to for Win10, the roon core machine. All works now. But the Win10 Computer will not have pihole functional.
Thanks for the reply!

1 Like

Hi @yi_han,

Thanks for letting us know the root cause of the issue and glad you fixed it!

Something must be off in the pihole configuration. I’ve been using that without any problems. I’m pretty much using their default configuration.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.