Tidal playback issue - 1st day on trial

Hello - looks like I’ve hit the wall early. Just signed up for the trial. Loaded latest core on my MBPro, remote on my iPad, playback through CA CXNv2 and I get the seemingly common “This track is not currently available through Tidal” and 'Too many errors…"

Internet radio plays just fine on Roon end point.

Tidal App (not Roon) plays fine via Chromecast to the CXN.

MBP on wifi, Orbi mesh router through to the ISP modem. No performance issues anywhere on the network.

Not a great start to my trial!! Would appreciate any help you can give me please.


So you say but what do you get on a Speedtest.net connection? What are your dns servers set to?

It’s not recommended to run a core on WiFi as data transmission to and from streaming services and endpoints will slow things more than you might expect.

Is 62 mbps down, 18 up enough? I don’t have a choice on running ethernet. Running everything else on Wifi. Tidal works fine through C cast to CXN, Spotify, streaming video - all through wifi. No issues at all.

I have AT&T U-Verse 50/12 and it works great with Roon. I would NEVER try using WIFI for Roon core.

I would try running with the mbp on an Ethernet connection to determine if it’s the issue with the WiFi. Roon recommends not running a core on WiFi.

Does it play ok to the Mac internal outputs without using a connected WiFi zone?

WiFi can work, but Roon and Orbi don’t always play nicely. There are settings in Orbi that you can change that may help, but if you can try a wired connection and everything works properly it would confirm there’s nothing awry elsewhere.

I think there is always a way to run ethernet. You might have to get creative. We ran mine outside the house.

Thanks - its pretty stable. I’ll have a google for Roon and Orbi.

Thanks - unfortunately I don’t have Ethernet ports on my MAC, and I don’t want to have a USB C port converter hanging out of the MBP along with the wire. It all seems odd. Streaming on every other app and device is just fine. Nice and Stable. I guess Roon is a little…quirky. Very advanced obviously (before everyone jumps down my neck) but more bandwidth hungry than all my video streaming devices.

Lots of problems with Orbi. The only way I could get it was to add a switch between my Orbi and the device running Roon. Orbi support could never answer why you could not plug directly into the main Orbi unit or one of its satellites.

Roon is not quirky. Roon moves a large amount of data back and forth from your router to your core device and back to your router and on to your DAC and sound system. WIFI is just not adaquate in most cases. If you want to use Roon, you may need to do some things differently. Adapt your thinking and system to Roon, not the other way around.

1 Like

Thank you. It’s pretty frustrating. Do you mean a network switch?? Blimey!

FWIW, I use a Mac Mini operating wirelessly over an Orbi mesh network. I had issues, but it turned out to be caused by my streamer, not by the network or the Mac.

Like Jim has said roon passes all played traffic thru the core and WiFi in and out again with RAAT protocols that roon uses to the endponts is heavier use than just a tidal or digital stream alone.

This is especially more so if your system is still importing music or favorites etc from tidal or a nas or other WiFi connected source while you are also trying to play something over the same WiFi connection.

Thanks for you help - I do appreciate it. (I say that sincerely)

I know Roon is well loved, and very sophisticated, and network stuff is complex, and interoperability is very, very complex, but all of the streaming apps, boxes and devices that i have all do the same thing. Lots of data flowing around. I stream video to my MBP and then video Airplay to the Apple TV, or even do similar things outside of the Apple ecosystem. None of them throw up errors like this because they have been written to work without users having to adapt their way of thinking. Wifi is adequate in all my other cases. So in this case, Roon must be a little quirky.

I’ve read that Orbi needs a specific network setting, but I can’t use that as I need them to run in AP mode - bridging isn’t possible with the ISP i have and the modem they have provided. This hasn’t been an issue for anything else.

Thanks for even more help. Much appreciated. I really appreciate everyones input - very supportive and all very nice. Thanks

I’ll wait a little while and see if things catch up with themselves.

Thanks for that. Roon recognises the CXN and happily plays the (lower quality) streaming radio - works nicely.

Its just Tidal that it doesn’t like. I’ll keep trying to dig and appreciate the response

So, as someone who spent the better part of last week trying to resolve a Tidal playback issue in a setup not too dissimilar to yours, here is are some suggestions.

First of all, streaming Tidal on Roon really does pound your network much more than native apps. I have 300Mbps speed at home and yet was still having issues, and the Tidal app was performing just fine.

Second, if you haven’t already, you should read the Knowledge Base article on Networking Best Practices.

After that:

  • power cycle everything in your system, including your modem and the Orbi, the MBP and the CXN
  • if you haven’t already, change your network DNS settings to Google or Cloudflare, or something like those, rather than your ISP one
  • as suggested, see if you can stream Tidal via Roon to your MBP and play through the internal speakers, rather than through the CXN
  • try moving your Orbi satellites to someplace closer to your CXN and see if that helps

That should be a good start. Hopefully, these reveal something useful. From my experience, it can be a pain, but it is worth the time invested so that you can enjoy the trial period.

Sorry, I repeated what I already posted.

Having the core hardwired is crucial. Depending on which router you have is also important.
WiFi just does not transfer as fast as being hardwired and then there is Roon sucking up bandwith.

Depending on which router Roon adds to the degraded traffic.

This is Speedtest.net with Roon turned on, streaming and hardwired. (Service is 200 down and 20 up)

This is Speedtest.net with Roon turned off (Not Streaming).

I can consistently get these results turning Roon on and off streaming.

This is with a Netgear AC1700 router. Not a very good router.
If your internet speed is lower than this, then you would still get the same performance hit when you have Roon running and if you are using Wi-Fi there will be another additional hit. This also does not take into account any other network activity on your network going on.

Here is another speedtest with a Ubiquity router and it does not matter if Roon is running or not. Same network, just swapped out the router.