TIDAL playback issues via Roon

(Vladimir See) #1

Core Machine (Operating system/System info/Roon build number)

Windows 10 / Roon Version 1.6 (build 416) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TP-Link Archer C9. Connection via Ethernet cables

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry Pi + Hifiberry Dac+Pro used as ROON Bridge via RCA cable connected to AV Receiver

Description Of Issue

I have used ROON + TIDAL without any problems in my old PC. I recently had to change/upgrade my
computer/PC since my old PC broke down. I have reinstalled TIDAL and ROON
on this new PC I am using. I can still login to TIDAL via ROON and I can see TIDAL’s playlist recommendation but when I try to open, there are no songs available. I tried searching various artists and albums and none appear except for those in my existing library. On the other hand, I can search and play things normally on TIDAL app and directly on its website player though. Hope you can help me out. Thanks

(Dylan Caudill) #3

Hi @Vladimir_See,

Is there any difference in how this new PC is connected to the network compared to the old PC?

Have you tried logging out of TIDAL and logging back in from within the Roon app?

(Vladimir See) #4

@dylan

Thanks for your reply. There is no difference in how this new pc and old pc are connected to the home network. I have also tried logging in and out of TIDAL several times within the Roon App in PC which is also my CORE. I still get the same errors unfortunately.

(Dylan Caudill) #5

Hi @Vladimir_See,

Is the Core connected directly to the router via Ethernet?

If you temporarily disable any antivirus or firewall running on the Core machine is there any change?

(Vladimir See) #6

Hi @dylan

Actually the CORE is connected via a powerline adapter. Its like an ethernet connection that goes through the house’s power lines. I also had this same network setup connected on my old pc when ROON + TIDAL was working without issues.

I have tried disabling the antivirus and firewalls (currently using Norton) on the Core but TIDAL still would not work properly with ROON.

Vlad

(Dylan Caudill) #7

Hi @Vladimir_See,

As we note in our networking guide, we’ve seen similar reports in the past where these types of adapters are may not be reliable and have caused some networking issues. If you temporarily take the powerline adapter out of the equation is there any change?

(Vladimir See) #8

Hi @dylan

I just tried a direct connection with my CORE/PC via ethernet to my modem but TIDAL still did not properly function with ROON. Same problem persists.

Vlad

(Dylan Caudill) #9

Thanks for giving that a try, @Vladimir_See!

Moving forward, I would like to try the following:

  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs
(Vladimir See) #10

@dylan

I finally figured out what was causing the errors. I forgot I had 2 accounts and was signing in to my inactive/faulty account. When I remembered my other active/working TIDAL account I signed in there and things are working fine now. Apologies for the trouble and thanks for helping me out.

Vlad

1 Like
(system) closed #11

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.