Tidal Playback not working

I just started using Roon and I’m having an issue. I’m using my laptop as the core and streaming to a Bluesound Node 2 from Tidal. When I play a track it plays for 10-20 seconds (each track is a different length) and then moves to the next track. I can’t see any “scan settings”. I’ve tried different albums and playlists in Tidal and the same thing happens. Any help? Thanks.

Hello @Adam_Davids,

How is your Core and Node 2 connected here? If they are on WiFi can you try connecting both via Ethernet (even temporarily) and let me know if that results in any change in behavior? We have also seen users have a better TIDAL experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?


I rebooted my computer running the Roon Core and rebooted the Node2. So far no issues, so maybe that worked. I should’ve tried that first, duh. Thanks, I’ll let you know if I have anymore issues.

1 Like