Tidal playlists syncing seems stuck in 'Syncing Library now'

Core Machine (Operating system/System info/Roon build number)

ROCK on Intel Nuc - latest

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ubuquiti Amplifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

On all devices

Description Of Issue

Yesterday I added some additional songs on a playlist I have on Tidal (way over 300 entries), but on Roon it got stuck on 50 entries. The settings screen shows ‘Syncing Library now’ for almost a day.

Anyone knows if this can be resolved (before I added these songs, my playlist in Roon had a lot more entries)?

Restart Roon server. The logic here is if the changes are lost you aren’t going to make matters worse but restarting the server software may just prompt it to complete what it started.

1 Like

Thanks. That was the first thing I tried, but no changes whatsoever.

Try logging in and out of Tidal in roon.

Thanks. Also tried that one too. I just tried it again, but still stuck.

Last one from me the you will have to wait for REAL support

Thanks again, I renamed the Cache folder to Cache_old. The new Cache was created and was exactly the same as the one I had.

Actually, they both (the old and the new Cache folders) have an empty tidal database, no idea what should be inside.

Do I need to tag someone to contact support?

No you are in the support area but flagging @support won’t hurt.

Did you reboot after deleting the cache?

Sorry for the trouble here, @razzi!

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

In the meantime, I’m hoping you can clarify what DNS your network is using — Is there any change if you switch to Google DNS/Cloudflare DNS? Most frequently these types of errors stem from ISP provided DNS solutions not working well with Linux devices, so that could definitely help.

Thanks. I’ve updated ROCK to use google DNS (by using the static IP option). Now the ‘Syncing library now’ spinner is gone and I can manually do a sync.

But the playlist isn’t updating, so it’s still at 50 tracks instead of the 355 Tidal shows me,

yes, like described in the steps

I’m glad to hear that things are syncing now, @razzi!

Besides this playlist you mentioned is everything else syncing?

If you create a new playlist in TIDAL and sync does it show up?

I just created a new playlist with one song and it shows up

Thanks for confirming that, @razzi. Can you share a screenshot of the playlist in TIDAL vs Roon so we can take a look at the specific files that aren’t syncing over?


And by magic, they synced! Until a couple of hours ago only the 50 first songs were synced

That’s great news, @razzi! It looks like there were some syncing issues that was helped by the DNS change and it might have taken some time to fully update the playlists. If you see any issues return please let us know, but it sounds like things should be good to go from here!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.