Tidal Premium account doesn't play on Roon core running on QNAP NAS [Resolved - ffmpeg issue]

Core Machine

Roon Server Version: 1.8 (build 790) stable
QPKG-Version : 2021-02-01
ffmpeg version : 3.3.6

Network Details

not related to my issue

Audio Devices

Tried PS Audio Direct Stream DAC, Sonore MicroRendu and Samsung Note9 cell phone. same issue.

Description of Issue


I tired Tidal hi-fi trial with exactly the above described settings of Roon server and audio renderer and Tidal played flawlessly. Then I subscribed to Tidal premium (not Hi-Fi because i spend small amount of time on Tidal only when i need to check on music that I don’t have in my own library). however I have issue playing all Tidal albums all the time.

the issue is that after i press play button, the progress bar stays at 0:00. And there is no sound. i attach a screen shot where you can see also the signal path. it’s a bit strange to me that the AAC file is being played at 24bit. looks like hi-res format AAC! probably something is wrong here?

btw, Tidal app plays its albums in AAC format on my samsung phone without issue. I tried to play the same albums from Roon app on the same phone to output to the phone and the same issue occured. signal path is almost identical except my phone replaces PS audio DAC.

let me know if I can provide any additional useful information for troubleshooting.

thanks Sam

Did you provide a user supplied version of ffmpeg? Version 3.3.6 sounds a little bit old to me.

The version provided on the page linked in above thread is release 4.4 (or newer).

Thanks BlackJack,
no I’m still using the system default version of ffmpeg. I will try to download and apply the new version. several questions:
There are quite a few choices for downloading. should i pick a git msater instead of release 4.4? my NAS is running on Intel CPU. should i choose ffmpeg-git-i686.tar.xz and md5, or amd64 (first one) is also fine?
after i download tar and md5 i just unzip tar.xz as instructed then copy them to the shared folder right? I know little about Linux command and I’m not quite following the Q&A page.
i couldn’t find the folder “ffmpeg_For_RoonServer” in my roon database shared folder. should i just create a new folder, name it then copy the 2 files in?

From the download site:

Note: it’s highly recommended to use git master builds, because bug fixes and other improvements are added daily.

I don’t know more than that about it, but are willing to trust this statement. But I don’t monitor the site to catch-up on new builds daily. After providing a version and all is working well inside Roon, I leave things happily as they are. But should there arouse issues at some time in the future, an update of the codec pack might be needed.

The 32-bit (i686) version might also work, but I would definitely use the 64-bit (amd64) version.

This example is for Linux, for other OSs you have to figure out how to do it - or just use it as downloaded if you’re able to unpack the archives error free.

If you un-zip the .xz file you get a .tar archive. You need to un-tar that too, to get at the included files. 7-Zip (for Windows) can do both steps. I don’t really know about other OSs.

Click on the button (“System default”) in the RoonServer app on your NAS, that will create the folder for you.

What 2 files? The only file needed is called ffmpeg.

Many thanks BlackJack and I really appreciate your patience and time to answer my questions one by one!
With your help, I have replaced the ffmpeg file and the issue is gone!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.