Tidal & Qobuz just won't stick in Roon 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Verizon Fios Gigabit feeding Nucleus via ethernet. {This Fios Gigabit connection has no other devices on it except the Nucleus}.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Expert 440-Pro as endpoint via ethernet. It is on a private IP address.

Description Of Issue

Tidal OR Qobuz just won’t stick in Roon Build 571. Remote tablet iPad also on Build 571.

This has rendered my playback experience to a complete halt. PLEASE-PLEASE HELP !!


Can you please be a bit more specific as to what your symptoms are?
Do you have to re-login to TIDAL/Qobuz each time your Nucleus is booted?
Do you get errors when trying to start playback?

Is there any change in behavior if you perform a reboot of your Nucleus via the Web UI?

  1. Not only do I have to login to Tidal/Qobuz each time Nucleus is booted, rather almost after playing a track or an alternate track and switching albums, I am told that either I have logged-out of Tidal or Qobuz. Once again, when I login, it syncs but just doesn’t stay that way. It just logs out on its own.

  2. I have tried Reboot of Nucleus using WebUI but no good. I have Restart Roon Server Software but issues persists.

  3. I mostly listen to streaming services via Roon; i.e. Tidal & Qobuz. But listening to tracks on albums or switching albums has rendered impossible to provide a continuous playback. There’s always some logged out behaviour every time.

  4. My Nucleus Serial # is 94C691115A9D if this info helps.

Can you enable diagnostics to see whats going on ?

I mean, this sort of constantly being logged out, Qobuz doesn’t even remember my credentials, same thing happening on Tidal … whats going on with you guys ?

Can we get someone from Roon to look into this quickly ? Its a disgrace that I can’t even listen to music anymore … Thanks to Roon & their build 571 update that has rendered complete Login failures of Tidal / Qobuz.

Please !!! do something …


Thanks for sending me that additional information. I’ve enabled diagnostics mode for your Nucleus and what this action does is automatically upload a log set to our servers. I’m looking through the report, and I’m seeing quite a few Name Resolution Errors in them.

I would first check your Nucleus Web UI to make sure that you have valid DNS servers setup there and then if the issue is still ongoing after checking the WebUI DNS, I suggest you change your router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS.

Can you please give this a try and let me know if it helps?

Hi @noris,

As per your kind recommendations, I tried the following.

( 1 ) It is a whole lot stable BUT I still sometimes get logged out of either Tidal or Qobuz.

( 2 ) Also, when streaming a TIDAL album, I select another album from QOBUZ, once again - it would not immediately play. Its either unable to find it, or logs out, or just stops.

What are my next steps ?? [ Please use diagnostics as units are left ON. ]


I can’t say for sure that the second Ethernet isn’t interfering here, but since the issue is networking-related, I propose we perform the following test to simplify your setup and see if this helps with the issues:

  • Disconnect the Devialet and connect it to the router or to a switch
  • Disable the Ethernet 2 Interface
  • Set Interface 1 to DHCP
  • Verify how your router DNS servers are configured and set Cloudflare/Quad9 there as DNS instead

Once you confirm that this setup works, then you can begin to add complexity to see when exactly the issue starts.

Hi @noris,

As suggested, I’ve setup as follows:




I’ve barely tested this setup for 20 minutes and

  • All my Albums loaded like a breeze
  • streaming from TIDAL is perfect & instantaneous
  • streaming from QOBUZ is perfect & instantaneous
  • switching from a TIDAL album track to an album on QOBUZ and vice-versa is smooth
  • so far no issues related to playback

I will test for a day and will need your kind support to advise me how to get back on a DIRECT { router-to-Nucleus-to-Endpoint } hookup that I earlier had as its by far the most transparent playback.

1 Like

After the recent Roon update to build 571 for both my Nucleus & iPad tablet, I am constantly having my Tidal & Qobuz services logged-out. This is happening every now & then, leading me unable to stream my saved album on Roon from either services.

I have tried to go to services from Roon menu, “disable the service”, then “enable the service”, doing a manual Sync but still, mostly unable to stream albums in a continuous process. Almost after every track or the album, the services “Login Failure” occurs.

My nucleus details are below.

This never used to happen earlier to this update. It was a seamless experience from both Tidal & Qobuz services via Roon.

Please help !

You disable/enable the services. Try logging out of the service and then log back in.

Did all what you suggested. No luck. Issues keep re-apprearing back thus very annoying.

Yup! same here … very annoying as everything was good earlier & never had issues like these ever.


Just to confirm, this is happening while Roon is actively in use?

Can you give us some details on your network setup?


Yes, while Roon is active, I am constantly getting logged out of my streaming services (Tidal & Qobuz). Hence, Roon is unable to locate my albums.

I use a dedicated for Audio Verizon Fios gigabit connection and the Verizon router feeds my Nucleus directly via Ethernet and this is the ONLY device my Verizon Fios feeds, hence a totally dedicated connection solely for Audio.

My Nucleus feeds my Devialet endpoint via Ethernet using a private IP address that you guys earlier recommended.


Thanks for the details on this. I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi @dylan,

Thank you so much for looking into my issues. However, my issues kept repeating constantly and I created another post https://community.roonlabs.com/t/tidal-qobuz-just-wont-stick-in-roon-571/111922

Please go thru this hyperlink to note my issues after @noris has been attending to me and has seen the diagnostics.

I do want to get back to my earlier system setup, i.e. DIRECT HOOKUP { Router-to-Nucleus via Ethernet } - - > { Nucleus-to-Devialet Expert 440-Pro Endpoint via Ethernet }.

Please note that my Nucleus is the version-1 having [1 x Ethernet port] + [2 x USB 3.0 ports] + [1 x HDMI port].
( A ) I was using Router-to-Nucleus via Ethernet port.
( B ) Nucleus-to-Devialet Endpoint via USB 3.0 port {using Ethernet to USB adapter}.

Endpoint Devialet was doing playback as RAAT.

Kindly let me know how I can re-instate this DIRECT setup once again (as I do not wish to use the switch). Nucleus to Endpoint was a “Private Connection”.

Thank you !


I wanted to check in with you here, how is the system performing by having the connection through the switch, has the system still been stable so far?

Hi @noris,

Thank you so much for getting back to me. I am really very grateful for your very kind support.

Indeed - the system has been stable and is running without any sort of issues. However, I intend to put back the system once again on a DIRECT hookup, i.e. { Router - - > Nucleus - - > Devialet Endpoint } on ethernet. Please note that as Nucleus has only 1 x Ethernet port, and I required 2 Ethernet ports for this Direct connection, I was using an Apple USB-to-Ethernet Adapter to create the 2nd Ethernet port.

I don’t know if this Apple USB-to-Ethernet Adapter could be the culprit for the issues that were arising.

Please guide me the steps for getting back from this SWITCH to DIRECT hookup.

Thank you once again for all your kind help.


I have been using my Nucleus with Devialet Endpoint thru a Netgear Switch and it works okay without any issues.

I want to revert back to a DIRECT Nucleus-to-End Devialet connection and discard the switch. This, Nucleus-to-Endpoint will be a Private connection.

If I were to setup one of my Nucleus’s USB Ports using USB-to-Ethernet Adapter as a 2nd Ethernet port, and hookup my endpoint using Private IP addresses, will it work ?

For example:

Nucleus 2nd Ethernet

Endpoint Devialet Ethernet

Looking forward to hear from you.


Thanks for your patience here, I had to reach out to our hardware team for this one and was awaiting feedback before responding.

We have confirmed that this configuration still works in the QA lab, but there is a discrepancy between the settings that you have and the settings we used to confirm.

This is what the Ethernet 2 settings should look like:

And here is the Devialet Config settings:
Devialet IP - Configurator

Once you get these settings in place, we also suggest performing a reboot of Roon Server via the Nucleus WebUI: