Tidal + Roon Library = Nightmare

I have been trying to sort out my Roon library this evening, and frankly, the way in which Roon/Tidal are working together is nothing short of a nightmare.

I had FIVE “partial” albums (of a single album), and I deleted them. Roon re-adds some of them back in of its own accord. This isn’t an isolated case with the one album (struggled with Hot Fuss by The Killers and Silence In The Snow by Trivium, to name just two of the albums).

To “commit” changes made to Tidal library entries, I have to restart Roon. Clicking the “Add To Library” button is ridiculously hit and miss: sometimes it adds the album, sometimes it doesn’t add the album, sometimes it adds part of the album.

I truly hope your next release handles Tidal integration better. :frowning:

Hi Rob,
there is clearly something wrong with your set up/system as this behaviour is not by design. Tagging @support for you so they can help. In the meantime, please supply more details of your system. Follow the guide here:

Hi Anthony,

Thank you. :slight_smile:

Only 2 weeks ago, I had to reinstall Windows 10 and restore my Roon library. Before that, the “Add To Library” button was hit and miss. It was only yesterday that I found the ability to “group versions” of the same album together (as I have my own versions that I use at home, as well as favourited in Tidal when I am out and about).

I am using the latest build of Roon on Windows 10 Release 1903. All parts of Roon are installed on the same laptop: 32Gb RAM, Intel i7-4980HQ CPU, and 4xSSD in RAID0 configuration. I have cable internet with 200Mbit/s download and 10Mbit/s upload.

Have you attempted to merge these into single album? Select the affected albums and click Edit > Merge Albums.

Hi Martin,

I did, yes. That didn’t work last night.

Everything seems to be working better today, but still not perfect. I am trying to delete Tidal “albums” that are one track, and I get the error shown in the picture.

I spoke too soon… it decided to “rescan” and put 60 “albums” back in that I just deleted from Tidal. Roon is doing them in tiny batches of updates (between 1 and 4 files at a time), but sequentially.

I suggest you provide details of your setup, as suggested by @Anthony_B, and wait for @Support to get in touch.

1 Like

I have lost count of how many times I have deleted both versions of the Andrew Lloyd Webber album and the The Answer album… :’(

I’ve moved this thread over to the Support category… Someone from the team will be along soon.


Hi @Framgeld,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Using the Andrew Lloyd Webber and The Answer albums as an example, do you see these in your TIDAL favorites in the TIDAL app?

The TIDAL albums in your Roon library are synced with what appears in your TIDAL favorites. If these albums are removed from your TIDAL favorites, they won’t appear in Roon. When you delete these albums, it should be removing them from your TIDAL favorites list, but it sounds like there might be something going on here that is preventing that from happening and then they’re being synced back over.

Can you try removing these albums from your TIDAL favorites from the TIDAL app directly and then sync TIDAL in Roon and let us know if these albums are gone?

Hi Dylan,

I will get that information together shortly. I managed to get rid of the aforementioned albums by re-attempting the delete then closing Roon until they eventually disappeared. The example I can demonstrate now is Europe’s “1982-2000” greatest hits album.

I deleted the album from Roon. Roon then decided to resync itself, which has resulted in the “album” being added back, but only as a single track:

Below is the same album on Tidal (with none of the tracks marked as added):

Hi @dylan,

My setup:

  • All parts of Roon installed on MSI GT80 Titan 2QE laptop (4th generation Haswell chipset): 32Gb RAM, 4xSSD in RAID0, Intel i7-4980HQ CPU. Runs Windows 10 Home Edition v1903.
  • Virgin Media cable internet (Superhub 3 running in “modem only” mode) => Netgear WNDR3700 router => ethernet cable => laptop. DNS is set to automatic (i.e. not using Google DNS or similar).
  • Audio 1: laptop => USB connection to Chord Hugo TT DAC
  • Audio 2: laptop => Airplay to Yamaha RX-A830
  • Library is combination of FLAC and Tidal. I make Roon prioritise Tidal over local FLAC. Approximately 8000 FLAC files. FLAC files stored on an old Netgear NAS drive (not sure of model). FLAC files in the local library work flawless though.

The issue occurs even when music is not playing (I thought it may have been contention issue but it does not appear to be the case).

If you need further information, please let me know.


Hi @Framgeld,

Moving forward, I’d like to enable diagnostics on your account. First I was hoping that you could reproduce this issue and make a note of the following:

  1. The time you delete an album
  2. The name of the album
  3. The time you sync TIDAL
  4. The time you notice the album return

Respond with the above information and we will enable diagnostics.

1 Like

Hi @dylan,

It doesn’t do it to the album I immediately delete, and there is no discernible pattern. However, the following may help.

Album view was showing as me having 2151 albums.

20:29:30 Deleted album “Thrice - To Be Everywhere Is To Be Nowhere”, non-MQA version.
TIDAL synced itself
20:30:30 Album count went from 2150 to 2156 on its own, then shortly after went to 2153.

Some notes:

  • The three albums Roon has added, I have no idea what they are.
  • Roon has been open all day, and until restarted Roon and deleted the album, the album count was a steady 2151.
  • Pretty much 1 minute after deletion, Roon has added “something” to my library, and I have no idea what it is. However, it wasn’t related to to my FLAC files, as I watched it complete that process and nothing has changed there.

Hi @Framgeld,

If you sort by Date Added in albums can you see what album was added?

Hi @dylan,

I had a look at the albums sorted by date added… nothing in the list looks out of place. I still cannot see what was added. It is likely that the album it added was an older (and deleted) album, and the date it is using is the date that it was originally added to my library.

What do the diagnostics say?

Hi @dylan,

23:04/23:05 this evening, Roon re-added the following items, all by the band Halestorm:

  • Apocalyptic (Singles and EPs)
  • I Am The Fire (Singles and EPs)
  • ReAnimate 2.0: The Covers [non-MQA version] (Singles and EPs)

I deleted them using Roon in the 5-10 minutes previous.

Hi @Framgeld,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your Core machine.

1 Like

Hi @dylan,

Sent logs via private message.


Thanks, @Framgeld. I’ll be sure to pass those along to the team and I’ll reach out once I’ve received their feedback.

1 Like