Tidal skips tracks on macOS, no issues on Windows same network

No EEE. It’s completely different.

Thanks for the clarification and the screenshot… my settings are identical.

Got it. Settings are here: Network > Ethernet > Advanced > Hardware
Automatic does not use EEE.

My only difference is the MAC address is set to configure Automatically. Would it be better to do it Manually?

… all my other settings on that page are identical to above, only just greyed out.

just following up on ged’s suggestion. No real indication that that’s the cause of your woes.

With the Christmas break coming up I think your mac will be a 2022 investigation now. Good luck.

Yes, I think it will be awhile before Roon support gets to this thread. Thanks for your responses, Ged and BC… much appreciated! Best wishes to you and your families for an enjoyable Christmas break!

Hey @Sergej_Jakovenko, can you try setting the IPv6 mode to Link-local and let me know if things improve? Thanks!

Hi Kevin, Thanks for your suggestion… I set the IPv6 to Link-local and restarted the computer, but no changes. Tidal streaming started skipping tracks immediately when I tried to Play now on a 16/44 album, same result selecting Play from here. Individual tracks will play fine one at a time. Please let me know what to try next, thanks!

Thanks for giving that a shot. From what you’ve shared so far, and after enabling diagnostics and scanning logs, this is definitely a networking issue. A few other suggestions come to mind:

  • Do you have the firewall enabled on your mac (or any antivirus software)? Try turning it off from Settings > Security & Privacy > Firewall
  • You’ve already tried setting your DNS to 1.1.1.1 (Cloudflare), can you try 8.8.8.8 (Google)?
  • Have a different router you can try?
  • Factory reset the airport extreme
  • Try a different Ethernet cable

Thanks for the additional suggestions! I tried Google 8.8.8.8, different ethernet cables and turning off the firewall, no difference in performance. To note, I do have Roon added to Allow incoming connections when the firewall is active.

I set up a brand-new test network using a different router, an Airport Express 1392, ethernet to the 5-port switch, then ethernet to the Mac mini. The same Tidal streaming issues persist: whole albums will not Play now, sometimes if they do, tracks will skip to next one after about 20-30 seconds. Single tracks will play fine. Search results are often slow and bogged down.

Next, I switched my core authorization over to the HP Z2 running Windows 10 on the exact same test network chain. Tidal streaming performance was flawless: whole albums Play now starts instantly, no skipping tracks, all the way up to 44/192 MQA. Search results, with tracks playing, are instant and snappy.

If this is definitely a network issue, please give me some insight as to why Roon on the Windows machine is perfect, versus such poor performance on my Mac machines on the exact same network. Thanks!

Roon strongly advises against using Apple networking gear:

I don’t understand what happened in the new release of Roon that caused your issue to suddenly appear, nor why it is specific to your Macs, but it would certainly be worthwhile trying a more modern router in your setup. Also, I assume you’ve logged out of Tidal on all devices and signed in again through Roon? My core is on a headless 2018 Mac mini 3GHz i5 with 8 GB RAM, ethernet hardware set to Automatic and with an assigned IP address in my router, and no problems whatsoever. Also, on Energy Saver I have it set to Turn display off after Never (since there is no monitor connected).

I experience exactly the same problem with one of my iMacs. No problems with my Windows laptop. Nor with my MacBook Pro or any of the two other iMacs I have tried. All of the Macs have Monterey and identical configuration. The one that is not working is a just a few months old iMac. For me, its impossible to figure out why it behaves differently.

Thanks for sharing the link and reminding me of the Roon recommendation not to use Apple networking gear. I’ll look into getting more up to date setup… I’d like to get a mesh system to cover my whole house, but also understand that might cause some additional issues if not set up properly. Happy New Year!

1 Like

Thanks for sharing your experiences, Magnus… sorry to hear you’ve also had this Windows vs Mac issue, but relieved to know I’m not the only one! Happy New Year!

Hi Kevin, I haven’t heard back from you in awhile… In the meantime, I changed out my Apple network for a brand-new Linksys Velop AX4200 setup. Child node is connected to the main router via ethernet backhaul. My 2018 mini is connected directly to the main router via ethernet, the 2014 mini is connected directly to the child node. Speed tests on both machines are above 300 Mps, latency less than 20 ms. Internet page loads are near-instantaneous. Unfortunately, I’m experiencing the same Roon playback issues as I alternatively test the cores on both machines. If a single track is streaming when I attempt to search, I get the “Can’t connect to Roon Search, Library results only” message. When I pause the track, I can get all search results. As before, the Roon core on my Windows machine works perfectly, connected to the same router. Please let me know why this could be a network issue… everything was working fine for years before the most recent set of builds starting with 814. Thanks!

A post was split to a new topic: Roon Disconnecting from Tidal Account

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.