Tidal stop playing and Roon jumps to the next title (local and Qobuz are ok)

Hi @dylan,
I have about 21000 titles in my library (pictures are max 500x500).
24bit files are mostly FLAC, 16bit are mostly ALAC lossless.

Breaks occur when using Roon via Android tablet and PC Roon App.
Thanks.

Sorry, BluOS 3.14.5 of course.

Hi @dylan

Hopefully this link works - I have no clue.

Did you read my description?

Thanks.

Hi @dylan, @rebeka, @noris
is there any workaround to fix that skipping issue.
In the last hour April 23, 2021, 11:30 MESZ I had 12 stops, jumps during streaming.
This is really frustrating. I also see a lack of communication between router and my PC Win 10 (not MAC) but what’s the root cause for that?
My PC has enough power, built up in 2021 with Ryzen 5 4650, 32GB RAM, SSD, 1GB LAN connection (which doesn’t seem to be working well with/without roon).
Thanks.

Hi @support,
a link for several log files. 23rd (11:30 MESZ) and 19th (8:30 MESZ) of April was really bad - just as an example. But it happens every day in different frequencies.

.
Please give me at least a feedback if you have access to the log file link and files.

Thanks.

Hey @Peter_Kuehnel,

Thank you for not giving up on us and continuing to keep us updated on this issue. I’m very sorry it’s so frequent.

I’ve moved this thread to Dylan’s queue so he can get back to you directly. We appreciate all the information, the logs and your patience :pray:

Hey @rebeka, @dylan,
COULD YOU READ THE LOGs, do they open - please give me a feedback - I’ve never tried this before.

I made the BIOS-Update MSI B550 Motar MB 7c94v163 beta to 7c94v16
and I made LAN Driver Update from 1.0.0.62 to 1.0.0.64 for this motherboard.

It all seems like minor changes.

Windows 2,5 PCIe Family Controller Driver remains still the same.
Windows by the way always says everything is fine.

I’ve no clue what that means but at the MOMENT everything runs like hell (fast).

Speedtest WITH a running and playing roon always above 900Mbit/s between Router and PC/Roon core.

But maybe it’s just because of the sun, humidity, great temperature, smile in my face,… :smiley:

And yes, I know in general also the bad bandwiths are also not that bad but that’s the only relationship I can see.
Thanks for your support :+1:
But with the speed of hell - just got another skip (ran speed test shortly after with 1035 and 1007Mbit/s). Meassage “Tidal slow…” :cry: :cry:

So because of advice of user wklie I also changed the DNS Server in Windows to 8.8.8.8. and I’m running some more trials.
Thanks.

Hey @rebeka, @dylan,
even with the changes I get skipps and jumps (Tidal streaming; LAN connection >1000Mbit/s; no communication lacks between router and core - as far as I can see). :cry:

No differences when I use the PC/Core as an endpoint - this sucks.
Maybe 13th of May or latest 13th of June will be good times to cancel that roon experience.
Even if it is in general quite good. :cry:

To isolate whether it’s Tidal problem or a local network problem, you should logout from Tidal in Roon, and do a repeat playback only from local music files in the Roon Core. If you need some music files, get them from:

See if the problem appears with local playback.

Check is running already since a longer time and I got no failures from local high res albums.

The Imelda May album from Tidal is/was a MQA96 album.
Thanks
PS: I have lots of 24bit music… :smiley:

Sorry, 11 Past the hour from Imelda May is a 16bit 44kHz album.
Maybe I see ghosts after all that skipping. :wink:

No issues at all at streaming from my local library (even not with 176kHz and 192kHz music; after LAN and BIOS Update as mentioned).

Hi @Peter_Kuehnel

Looking at the logs you shared:

04/23 10:38:04 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [100% buf] [PLAYING @ 3:07/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:09 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [92% buf] [PLAYING @ 3:12/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:14 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [52% buf] [PLAYING @ 3:17/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:17 Info: [stats] 6093mb Virtual, 824mb Physical, 284mb Managed, 2232 Handles, 112 Threads
04/23 10:38:19 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [4% buf] [PLAYING @ 3:22/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:20 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:23 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:24 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [PLAYING @ 3:27/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:24 Trace: [Bluesound NODE 2i @ 192.168.178.31:35071] [raatclient] GOT [3452] {"samples":13580,"status":"Dropout"}
04/23 10:38:25 Trace: [Bluesound NODE 2i @ 192.168.178.31:35071] [raatclient] GOT [3452] {"samples":22264,"status":"Dropout"}
04/23 10:38:25 Trace: [Bluesound NODE 2i @ 192.168.178.31:35071] [raatclient] GOT [3452] {"samples":22022,"status":"Dropout"}
04/23 10:38:26 Trace: [Bluesound NODE 2i @ 192.168.178.31:35071] [raatclient] GOT [3452] {"samples":22022,"status":"Dropout"}
04/23 10:38:26 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:26 Trace: [Bluesound NODE 2i @ 192.168.178.31:35071] [raatclient] GOT [3452] {"samples":22022,"status":"Dropout"}
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Trace: [Bluesound NODE 2i @ 192.168.178.31:35071] [raatclient] GOT [3452] {"samples":22022,"status":"Dropout"}
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:27 Trace: [Bluesound NODE 2i @ 192.168.178.31:35071] [raatclient] GOT [3452] {"samples":5808,"status":"Dropout"}
04/23 10:38:29 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [100% buf] [PLAYING @ 3:32/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:29 Trace: [Buero] [zoneplayer/raat] sync Bluesound NODE 2i: realtime=305796975657 rtt=1500us offset=-3520591024us delta=-497us drift=-4151us in 212,739s (-19,512ppm, -70,244ms/hr)
04/23 10:38:32 Info: [stats] 6085mb Virtual, 824mb Physical, 285mb Managed, 2218 Handles, 110 Threads
04/23 10:38:34 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [72% buf] [PLAYING @ 3:37/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:39 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [16% buf] [PLAYING @ 3:42/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:43 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:44 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:44 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:44 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:44 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [PLAYING @ 3:47/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:44 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:44 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:45 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:45 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:45 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:45 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:46 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:46 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:46 Debug: [prebuffer] sleeping in read -- this isn't good
04/23 10:38:47 Info: [stats] 6085mb Virtual, 824mb Physical, 286mb Managed, 2222 Handles, 110 Threads
04/23 10:38:49 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [52% buf] [PLAYING @ 3:52/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:54 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [100% buf] [PLAYING @ 3:57/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:59 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [100% buf] [PLAYING @ 4:02/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:38:59 Trace: [Buero] [zoneplayer/raat] sync Bluesound NODE 2i: realtime=336120986553 rtt=1500us offset=-3520591013us delta=461us drift=-4140us in 243,063s (-17,033ppm, -61,320ms/hr)
04/23 10:39:02 Info: [stats] 6081mb Virtual, 824mb Physical, 286mb Managed, 2224 Handles, 109 Threads
04/23 10:39:04 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [100% buf] [PLAYING @ 4:07/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:39:07 Trace: [prebuffer] short read: 0 / 8820 fill=435990
04/23 10:39:09 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [82% buf] [PLAYING @ 4:12/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:39:14 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [28% buf] [PLAYING @ 4:17/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:39:17 Info: [stats] 6081mb Virtual, 824mb Physical, 284mb Managed, 2233 Handles, 109 Threads
04/23 10:39:19 Trace: [Buero] [Enhanced, 24/44 MQA TIDAL FLAC => 24/44 MQA] [PLAYING @ 4:22/4:26] Awake My Soul (live from Denver) - The Milk Carton Kids / Mumford & Sons
04/23 10:39:23 Trace: [Buero] [zoneplayer/raat] Endpoint Bluesound NODE 2i State Changed: Playing => Prepared
04/23 10:39:23 Trace: [Bluesound NODE 2i @ 192.168.178.31:35071] [raatclient] SENT [3720]{"request":"end_stream"}
04/23 10:39:23 Info: [library] recorded play for profile 9a790504-7f04-4c79-a594-6c6f9e1241f3: mediaid=168:0:162115219 metadataid= contentid=168:0:162115219 libraryid= isfromswim=True
04/23 10:39:23 Info: 

Basically what this shows is Roon playing to the Bluesound, then dropouts stop happening, and then playback stops.

This could be playing into things. So we can narrow things down, can you try playing just to System Output of the Core machine? This will help us understand if the issue is from Internet Stream > Core or Core > Endpoint.

Hello @dylan,
good to hear from you - to be honest I was really frustrated not to hear something from a support person.
But I read somewhere you didn’t feel well. I hope you feel better now.
Now to my nice roon topic. Yes, I knew I got sometimes a very bad connection between the roon core (pc) and the router. Therefore I tried and searched a lot and was able to fix that.
LAN and BIOS Update as I stated in message 9 here. I guess I posted it somewhere else before but…
This issue is fixed. I always have a gorgeous speed now (>900Mbps) as stated above.
I also wrote in message 10 that there is no difference between using the core as an endpoint or the Bluesound Node 2i.
Skipping of local music content is gone since I fixed the speed problem between PC and the router.
Skipping of TIDAL content is sometimes still the case.
But also during these moments I made a quick vodafone speedtest and the Internet connection to the router was always very good >1000Mbit/s and >900Mbit/s Internet to the PC (Core).
What I don’t know is the connection to TIDAL. But if I try Blouesound or TIDAL connect - everything works fine - no interrups. Of course it’s not exactly the same time but close to it.
As stated also “deaktivation of Packet Acceleration” does not work (feedback from AVM Fritzbox support). I also moved the Windows PC from automatic DNS Server to 8.8.8.8 DNS Server.
I can create/send new log files because these skipping issues occurs almost every day.
But very differently. Sometimes 1-3 a day and today morning 7-8 in half an hour.
Do you want my log file from this morning and thank you for following up with me.
Thanks.

Log files with fixed issue between PC and router but still issues during Tidal streaming.
Time is still MESZ! I guess before 10:30 o’clock were the problems.

Okay, I guess I do not see ghosts. When I got the problems is was marked as a MQA986 file.
Then later on as a 16bit 44kHz album. :roll_eyes:
And today tata… MQA96 again. Don’t know whats going on.

Have Layer 2 from FritzOS switched off, no differences.
Several skips - startet at 16:30 o’clock. More or less almost no skips before.
Internet speed like hell. Tidal speed??? :cry:

Hi @dylan ,
At some days there are almost no or just a few skips and I always try to do speed tests at the same time. General internet speed at my connection is always very good (>900Mbps). But today for example I compared 2 skips (around 12:50o’clock) from Tidal with a diagramm about Tidal down times from the internet (People report issues there).


These 2 recognized issues were at the same time as other poeple reported issues with Tidal.
I guess you also find more skips if you stream higher volume files like MQA 96kHz from Tidal.
I never realized these skips with other Apps, but they also don’t show it quite clear.

Roon seem to me very sensitive at these bandwith variations. :cry:
I guess this has to be optimized from roon - otherwise people get mad.

If there is any possibility to check the speed to the TIDAL server, then please let me know. :wink:
Thanks.

Maybe this helps.

Hi @dylan, @noris,
maybe I’m writing to myself, but at least it is a documentation.

Here is some feedback from a trial I did with qobuz. I made a monthly contract with qobuz to make a comparison to Tidal. With Tidal I do not have one day without any skips.
Today (May, 4th 2021) I ran a test of about 12,5 hours with qobuz titles, albums (most in higher 24bit quality up to 192kHz) and within that timeframe I got NO skipped titles with Qobuz.
Are there different Qobuz server within Europe?
When do we get feedback, measurements from roon support?
Thanks.

1 Like

Hi @Peter_Kuehnel

Thanks for the updates here, and apologies for the delay while our team’s queue is longer than typical.

If you can reproduce this behavior when playing to System Output of a remote, can you make a note of the time that it happens, the track that it occurs with, and then share another set of logs? We’ll take a look at this instance and see if the behavior is any different without the endpoint in play.

Hi @dylan,
Thanks for giving a feedback.
I just have a problem to understand your request.
What do you mean by

At April 27th I delivered log files with the time (before 10:30) of the skips.
The output was delivered to a Bluesound Node 2i.

Do you need now failures with the System Output (Core PC) and the Log files.
Did I understand this right?

Or do just wanted to know the title from April 27th for example?
Please give me a brief feedback?
Thanks.