Tidal stops playing tracks

Using a Macbook air 2020 as the core and a raspberry pi 4 as a roon endpoint. Most of the times it works fine but now and then, when playing tidal files, the playback stops and I get the message Tidal is loading slowly and that there may be a network issue.

If i change the output to the macbook or my Marantz the problem remains so the roopie is not the problem.

Tried to restart my computer but it doesn´t help. And sometimes it works without any problems.


Your topic has been moved to the support section of the forum.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hi @Stefan_Berg — Can you provide some details on your network setup? Is your MacBook connected via WiFi or Ethernet?

If you play directly to System Output do you experience the same issue?

My macbook is connected via WiFi and the problem remain when I change from the roopie to system output.

My connection is 100Mbit up and down and I don´t experience any problems with my network elsewhere.

I suggest hardwiring the MacBook to your LAN (it’s not recommended to have the Roon Core on a WiFi connected device) and then retest to see what affect it has.

1 Like

Hi @Stefan_Berg,

Testing the behavior on Ethernet is a good test, as streaming audio heavily relies on a stable internet connection and WiFi is prone to interferance.

One other suggestion here, ISP DNS server are sometimes less than reliable, you can also try changing the DNS on your router to Cloudflare DNS, Quad9 or Google DNS and that may help as well.

Tried a wired connection but that did not help. Don`t know how to change the DNS, could it help changing it?

  • Networking details:
    Archer C9 router
  • Audio devices in use:
    Hegel H90 and a raspberry pi 4 with a digi+ and roonpie.
  • Library details:
    Streaming from Tidal and have a medium sized library. Not adding anything new that often.

Hi @Stefan_Berg,

Yes, please give the DNS change a try, you can use these instructions:

Thank you for the help. Changed it to Google´s DNS and seems to work better now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.