Tidal stops playing

Core Machine (Operating system/System info/Roon build number)
ROCK latest release 528 on a i3 series 8 NUC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
LAN connected cubox bridge.
NUC connected to the internet router.
Swisscom internet box 3.
Download speed > 400mbps.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Tidal stops playing from time to time. I get the warning message Tidal is loading slow.

Playing from Qobuz and hard disk works fine.

Thanks for your support

Hi @Martin_Kogel,

Is it always the same TIDAL content that gives you this issue?

Does the same error occur for all endpoints?

Hi Dylan,

it is different TIDAL content MQA and non MQA. While QOBUZ 24 bit content is playing without problems.

I haven’t tested other endpoints yet, as they are Bluesound 2i and have anyway issues.

I will test an let you know.


as always when you wan to re-create. No problems at the moment with the cubox end Bluesound endpoints.

Did more users experience issues with Tidal? Is it a Tidal eprformance issue?

Try a fresh reinstall and see if that helps.

Hi @Martin_Kogel,

Just to verify, you’re not experiencing this issue currently?

Have you noticed any patterns in when it does seem to occur? When other apps are running or certain times of day or anything?

Today I tested the bluesound 2i and the cubox I endpoints. Both without issues.

As I’m running on Rock nothing else is running. Also no other zones.

If the issue occured it is repeatedly there. Switching to qobuz, no problem there. Switching back to tidal, again frequently interruptions and drop offs.

No specific times.

Thanks for the update, @Martin_Kogel.

If the issue occurs again let us know what time you notice the issue occur as well as what track was playing / you were trying to play. We can then enable diagnostics and take a closer look.

Hi Dylan,

the issue re-occured yesterday on the ugly clementine album and on all of my endpoints.


Hi @Martin_Kogel,

Do you know what time this occurred yesterday?

At around 8pm

8pm CET timezone

Just now again. The new Bombay bicycle Club plays gone in 24bits from qobuz. Tidal has frequent interruptions

Thanks, @Martin_Kogel.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Today shortly before 1pm CET you will find a good example to diagnose

Hi @Martin_Kogel,

We reviewed the diagnostics report and we are seeing some errors related to the Roon’s ability to buffer the TIDAL media on your Core machine. The error essentially says that Roon isn’t receiving data quickly enough and so playback is stopped:

03/23 18:33:41 Debug: [prebuffer] sleeping in read -- this isn't good
03/23 18:33:41 Trace: [AVM Class 2 Audio] [raatclient] GOT [12] {"samples":44100,"status":"Dropout"}
03/23 18:33:41 Debug: [prebuffer] sleeping in read -- this isn't good
03/23 18:33:42 Trace: [Wohnzimmer] [Enhanced 15.2x, 24/44 MQA TIDAL FLAC => 24/88 MQA] [PLAYING @ 0:13/4:48] Let You Go - Bombay Bicycle Club
03/23 18:33:42 Debug: [prebuffer] sleeping in read -- this isn't good
03/23 18:33:42 Trace: [AVM Class 2 Audio] [raatclient] GOT [12] {"samples":44100,"status":"Dropout"}
03/23 18:33:42 Warn: [Wohnzimmer] [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
03/23 18:33:42 Trace: [Wohnzimmer] [zoneplayer/raat] too many dropouts. stopping stream
03/23 18:33:42 Debug: [smc] [zoneplayer:99] Removing ordinal 7
03/23 18:33:42 Debug: [smc] [zoneplayer:99] Waiting for ordinal 7 (> 6)
03/23 18:33:42 Trace: [Wohnzimmer] [zoneplayer/raat] Endpoint AVM Class 2 Audio State Changed: Playing => Prepared
03/23 18:33:42 Trace: [AVM Class 2 Audio] [raatclient] SENT [14]{"request":"end_stream"}
03/23 18:33:42 Warn: Track Stopped Due to Slow Media

Based on this, we can be fairly sure that the issue is stemming from Roon’s ability to receive information quickly enough to properly buffer, which is most likely stemming from networking-related issues.

This isn’t happening all of the time based on your report, and is fairly intermittent, so it’s hard to say for sure what is happening during these times just yet. Have you noticed any patterns? Does it happen during certain times of day, or when other devices are active on your network?

If you go to Settings > Services, choose TIDAL, and then set streaming quality to Normal does this issue still occur?

Hi Dylan,

Thanks for the the first look. But the result seems a little strange. As said, at the same time Tidal stops, qobuz streams 24bit content just fine. We also are able to stream 4kvideo content.

And if I stream Tidal via blueos directly to my pulse, I have no issues.

For me it looks like a over sensitivity of roon combined with some fluctuations in my connection.

But I definitely like to find a solution, as currently Tidal basically stopped working.

Any ideas?


With settings to normal, the stream doesn’t even start, while mqa at least starts and then stops.

Today 1515 CET.

Thanks for giving that a try, @Martin_Kogel.

Just to confirm, was this the case with all zones when using Normal streaming quality? If you play Normal to System Output does the same issue occur? If so can you make a note of the time and track you’re playing and we’ll see if there is any change in the diagnostics report?


I tested twice on different zones, same result. I can’t play to system output, nothing is connected, ROCK runs in a patch cabinet.

Timing was last Sunday 1515CET. The media was from the latest foals album first song.