Tidal Streaming Issues - BluOS

Core Machine (Operating system/System info/Roon build number)

Mac Mini (early 2009, Yosemite), Roon Version 1.7 (Build 571).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hitron Router to Orbi RBK12 Mesh to Mac Mini.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mac Mini via WiFi to MDC BluOS 2.1 Card in NAD C388 amp.

Description Of Issue

For the past few days, I have been trying to troubleshoot a new issue I have streaming Tidal music to my NAD amp via the installed BluOs card (“Tidal Media is Loading Too Slowly…”). There are frequent network drops, although I haven’t been able to determine any consistency as to when it will have issues. It does not seem to be based on the sample rate of the recording and/or whether it is MQA. I don’t have Qoboz, so I can’t see if that makes a difference.

I do not have similar issues when streaming directly from the Tidal app (or anything else) to the BluOS card. I also do not have these steaming issues when the Mac Mini is connected directly to the amp. If I run Speedtest, I am getting 300Mbops upload speeds. I typically run Roon using both heavy upsampling, room correction and volume levelling.

Having reviewed the community and the KB on this issue, here is what I have tried so far (none of which resolved the issue):

  • Power cycled all of my components
  • Unchecked “Disable IGMP Processing” in the Orbi’s settings (per the Networking Best Practices KB)
  • Changed my router DNS setting to both Google and Cloudflare
  • Changed my network channel to 3 (that was per the Bluesound website)
  • Connected the Mac Mini directly to my router via ethernet (since moved back to allow direct connection)
  • Turned off all of the various DSP. etc.
  • Deleted my Roon caches
  • Reinstalled Roon

Given it appears to be a network issue, I see three possible solutions: (1) upgrade the ancient Mac Mini, (2) upgrade my home internet connection, or (3) replace the BluOS card with a different streamer.

However, each of these is going to be a pain and/or costly and so, before I embark on any of those routes, I would appreciate it if there is anything else that I should try.

Thank you!


What the processing speed when playing. Have you tried turning off all DSP to see if it improves. If your core is on wireless this is likely the primary cause. Wireless is not full duplex and can suffer as a result. Streaming Tidal from Roon and Bluos are very differnet load on your WiFi. Roon will pull wirelessly then push wirelessly all at the same time. This will greatly reduce available bandwidth and is also at the mercy of every other wireless device on your network or neighbouring for airtime. On BluOS it’s just pulling no pushing involved so it’s less demanding on the network. Wireless for any server that is having regular io requests is not ideal.

1 Like

Thanks for that suggestion. The processing speed doesn’t seem to matter. There have been issues at speeds of well over 10x (and sometimes over 50x in the past). Turning off all of the DSP hasn’t helped to resolve the issue. The Mac is operating as a dedicated, headless server. So other than running Roon, it doesn’t have much else to do.

Hi. It is a known problem that Roon has when connected by WiFi to BluOS devices. There are number of threads on this. Roon have managed to mimic the problem and are working with BluOS to resolve the issues. I had similar problems with a NAD M10 and a Bluesound Node 2i until I changed from Wifi connections to wired…

1 Like

BlueOS 3.10 released today and promises more robust WiFi


Thanks for that. I had tried to review the past threads and I know there were issues with other machines, but then some also seemed to have been resolved. I just wanted to check and make sure I wasn’t missing anything.

Well, that’s certainly timely then! Thanks for that news, Chris. I will update it now and report back if it helps.

1 Like

Good grief!

I would love to provide an update on the Tidal issues, but with the latest BluOS firmware update, I can no longer play anything at all from Roon via the MDC BluOS card (the direct connection to the amp still works).

It is still listed as an audio zone and can be selected. However, if I go to play something to that zone, it simply says that Roon has lost control of the device. When I go to the zone settings, selecting Private or Exclusive are no longer options, which I am assuming has something to do with it.

Hello @GKern,

Our in-house NAD C 368 with the BluOS MDC card is working as expected running BluOS firmware 3.10.0. I would try doing a full power cycle on your audio device as well as your computer running the Roon Core (remove power cord from unit for 60s) and try streaming to the device again.


1 Like

Thanks very much, John. I think I may have it resolved. I think the issue is that I had the same Tidal album queued up under both the BluOS and the direct connection to the same endpoint. When I switched to another album, it was fine. Thanks for your help.

I will now see if the streaming issues from Tidal have been rectified with this update.


Could I possibly ask whether, in the advanced settings for the C368, you have enabled Roon’s MQA decoder? If I have that enabled, I cannot play MQA songs. I have to let my C388 do everything or else it says that Roon has lost control of the audio device. I can play non-MQA songs without issue and also play MQA songs without issues so long as Roon doesn’t touch it. That’s why my problem was resolved when I switched to another (non-MQA) album. This was not an issue before the recent update.

Also, I can no longer select the C388 as either a private or exclusive zone within Roon, which I could do before the latest BluOS update. Are you able to do this on the C368?

Many thanks in advance.

Hello @GKern,

The “Private” or “Exclusive” zone feature in Roon has never been an option for Roon Ready devices. It should only appear for “local” zones such as iOS/Android device outputs + audio devices attached to Mac/PC running Roon.

We’re investigating reports of issues with MQA on C 3xx devices.


Thanks, John. I must have been confusing it with when I had the amp connected directly to my server. Apologies for the confusion. In any event, the streaming seems better after the latest BluOS update, and Noris is working on the MQA “issue”, so I will close out this thread as resolved.

Thanks for your help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.