Tidal Streams will not play

Roon Core Machine

VMWare ESXi 7 fully patched
Ubuntu 22.04 LTS fully patched VM
AMD Threadripper 1900 with 4cores allocated
4GB ram

Networking Gear & Setup Details

Core on Ethernet
Unifi Edgeswitch 48-500 Cat6
Unifi AP Lite mesh
I have a VPN but it is not being used for Core. VPN is used for all endpoints

Connected Audio Devices

Desktop on Ethernet
Android and Apple on 5Ghz Wifi
Two Hifiberry (Raspberry Pi 4) and one Roopie (Rasperry Pi Zero 2) endpoint on 2.4Ghz

Number of Tracks in Library

50,000+ but not relevant as this affects Tidal only

Description of Issue

Roon on the whole is working fine. I am able to play locally held music from a local share and using ARC I can access both local AND Tidal music without issue. However when I play any Tidal track from my Core, it does not play.

  • There is no problem with searching for tracks on Tidal through Roon
  • There is no problem with playing Tidal tracks using the same account through the Tidal application on Android or Desktop
  • When I press play on a track in Roon the “track length” bar updates and shows the correct track length
  • The track does not and never does start to play instead a fast moving blue line goes left to right and back along the play bar
  • The Play button changes to a Pause

In order to rectify this and based on how other people have “solved” this issue previously I have

  • Moved the Cache on the Roon Server (/var/Roon/RoonServer/Cache/ to /Cache-old and restarted the server
  • Tried from desktop, Android and Apple devices with the same result
  • Gone Settings > Services > Tidal and clicked Logout. Rebooted the Core and then logged back into my Tidal account.
  • Changed the DNS servers on my Core from my local resolver to and (as well as leaving them as they were to resolve locally)

None of this has changed the result.

I have a log that covers the “Play” event and the “Pause” or “Stop” event on Tidal but I’m not posting it publicly as I don’t know what is sensitive, if anything

I’ve rebooted the Core multiple times. It’s patched and fully up to date.

This was not always the case. It used to work previously but as I do most of my listening on local files I can’t identify exactly when it stopped playing from Tidal.

A couple of changes that may be related worth noting

  • I changed my Tidal account within the past 6 weeks however I can’t say whether this was a cause or a coincidence. However as mentioned this new Tidal account plays without issues through the Tidal app.
  • I also made some network changes to get ARC to work. This only relates directly to the ARC port and not the other ports. As I mentioned above, interestingly ARC DOES play Tidal tracks without an issue.

I’m pretty sure I’ve done something stupid but right now I can’t see what. Any thoughts or ideas on what next to try is appreciated.


Daft Question - Have you logged out of Tidal and back in

Try Logout Tidal, Reboot Core then Login Tidal, maybe the “saved credentials” are dodgy, just rebooting the core won’t clear the credentials. They may still be the 6w old ones

Yep - I said so in point 3 of things I tried in my post

Gone Settings > Services > Tidal and clicked Logout. Rebooted the Core and then logged back into my Tidal account.



This is still an issue


Hi @Gary_Hopkins,

Thank you for your patience in awaiting a response from Roon.

I’ve requested diagnostics from your core to look into these issues. Will you please bring your core online? I will check back in with you once I receive your response, check out the diagnostics, and see if I can reach a conclusion as to what the problem may be.


Thanks for getting back to me.

The Core is never offline but it’s very heavily firewalled so you may not be able to get anywhere near it depending on how you request that diagnosis.

At around 12.30 I was setting up some playlists and for some reason 3 tracks from Tidal played. I wasn’t really paying much attention and didn’t realise they were Tidal based tracks until later on when I tried them again and they wouldn’t play. They’ve not played before and nothing has played since. I have NO idea why it suddenly worked for that short period but it’s now stopped again.

I saved off the two log files that have those specific time frames in them (the one where it plays and the one where I tested it a few hours later and it didn’t. I’m guessing those will have everything you need and, luckily, a “working” and “nonworking” reference point.

Just advise me on what you need me to do.



Hi @Gary_Hopkins,

You can provide the log files via this link.

I have to ask though, is the issue still present in the absence of a firewall? Our software sends requests to your core for diagnostics, device verification, and account authentication (this includes Tidal).

Firewall exceptions also need to be created:

Please let me know if the issue persists without the firewalls being active. I will also be happy to review the logs if you upload them.


Hi Wes this all gets very complicated…

The firewall is a pfSense firewall which sits protecting my Internet links. There is no firewall internally, my network is flat. I have no problems or issues connecting remotes or any of the other devices to the Core, this only relates to Tidal playback.

One of the changes I made when I enabled ARC was to stop the Tidal server speaking out through the VPN and so I have a VPN bypass on the firewall for the Roon server. There are no outbound rules blocking the Core outbound and I see no blocked connections from the Roon Core. I have never allowed inbound connection to the Roon Core (and I would be mad to do so). I do now allow the ARC port inbound to the server and as I mentioned that works.

So here’s a slight update and amendment before I go upload the logs. I’ve just worked out this is time bound. I had assumed that the files will never play however I’ve just been experimenting briefly and if I leave it long enough the files do eventually start playing.

I’ve only had a chance to test it once but the files took (I think exactly) 15 minutes to start playing. Once it starts playing I then seem able to stop and start it on that track for a certain period of time (I assume I have an open connection) with no delays. It ALSO carries on playing to the next track on the list without delay if I just let it play. However if I then click BACK to the previous track (the one that first played after waiting) it will NOT play again (though I assume it would if I waited 15 mins). Also if I go forward to the next track that it already played without delay when it was playing contiguously will also not play.

For what it’s worth (and you’ll see in the logs) the server can connect to Roon’s servers and it can connect to Tidal to get track details without an issue.

Incidentally feel free to get as technical as you like with your requests I’m an IT professional so should be able to do anything you ask or provide anything you need with little fuss.


Some notes about the files.

One is called RoonServer_log.txt.nonworking the other RoonServer_log.02.txt.working

If you search for “Pop/Stars” in both files this was the file I was using to test.

There’s only a single entry for it in the “working” file but there may be multiple entries in non-working as I kept on trying to get it to play.

I have not included logs from my recent testing which was for a different track “Take me Home Country Roads”.

If you need any other info or logs just ask.




Any updates?



@support @Wes


2 weeks since your last post.

Any updates?



Hi @Gary_Hopkins,

My apologies for the slow response. I was out of the office last week and will be again this week due to unforeseen circumstances.

In revisiting logging and our prior discussion, I feel the need to speak about the need to eliminate firewall, VM, and VPN elements from the equation. There are no current known issues affecting users with your scenario so it is in the best interest of the process of elimination to remove these elements and try again.

While we have a KB article that outlines exceptions that should be made for firewalls, both VM’s and VPN’s fall under the category of tinkering and are not supported. While firewalls are not in this category, part of our troubleshooting process is to disable them to see if it changes the situation. If you are unable or unwilling to follow these suggestions, it’s possible that users within the tinkering topic may have something to offer in the way of next steps.


Hi Wes,

This is not solved at all.

  • There’s no firewalls on the clients or the server. The firewall protecting the Internet is no different to 1000’s of other users. The firewall provides the exact same function as almost every ISP internet router does. That “Adding Roon as a firewall Exception” doesn’t apply as there are no firewalls between the client and server. I have no problems connecting clients to the server. Is there another link you’ve not posted?

  • There is no VPN on the server connection or between the client and the server.

  • I’ve been using a VM without issue on Roon for 3 years. This isn’t anything I can easily change as I simply don’t have the money to buy new hardware. That said I do find it incredibly difficult to accept that the VM is suddenly to blame.

I’m not quite sure why I’ve had two very bad experiences with Roon support. Responses take weeks and countless chases. When I do get responses it’s either to fob me off or to suddenly tell me something based on information support has known about for weeks or even months.

In my very first post I was very clear that I was running a VM on ESXi. It’s not new information but suddenly it’s turned into an issue 3 weeks later to the point you’ve just walked away and thrown me to the wolves. Why didn’t you just politely reply in the first response and say “sorry you’re running in a VM we can’t help you”. It is beyond frustrating to be treated like this in every interaction.

All I’m looking for is some support from Roon to fix an issue which I think can only be fixed by understanding where the delay is. If you’ve looked at the logs as you claim then it should be obvious to you where the delay is happening. You know what should be happening you know what should be responding so how about giving me that information? I’ve provided 2 lots of logs which must show a difference as one of them plays Tidal, the other doesn’t on the same server with the exact same configuration. Why?

What is Roon expecting that it’s not getting that’s causing a 15 minute delay in the Tidal stream? This doesn’t affect the Tidal app. This doesn’t affect the server contacting Tidal for album and track information? It doesn’t affect track searches. It’s not a connectivity issue, you can see Roonserver contacting Tidal and getting responses in the logs.

Please give me some hints as to where the problem lies because I can’t see how it being in a VM has anything to do with this and there’s no VPN or firewall in the path.



Hi Gary,

The firewall is in fact blocking our requests to see your diagnostics info. It’s not unrealistic to believe that other forms of outside communication would be impacted as well. Given that your issues are specific to music coming from an outside source, it sure seems relevant. Even if it turns out to not be relevant, the process of elimination applies.

This is irrelevant if all of the endpoints you play to are in fact VPN’d as stated in your initial post.

We need to eliminate this as a potential source of your issues. At the very least, disable VPN on one unit to test. With regard to your endpoints, I also recommend hard-wiring endpoints where possible but at the very least, utilize the 5ghz network as opposed to the interference laden 2.4ghz band. VPN configurations are considered tinkering in all instances. Asking that it be temporarily simplified in an attempt to narrow down your issue would be considered standard practice in troubleshooting.

I am not blaming your VM. I am looking at 3 factors that are likely relevant to your issues. VPN, VM, and firewall. Part of troubleshooting is to eliminate variables, test, re-enable the variables, and see where it breaks. Two out of the three variables involved fall outside of the scope of support that we provide. If moving away from a VM is not a possibility for you, the other two potential factors I cited should be. Setting Windows or Mac box as a temporary core to test VM relevance is another possibility.

I’m sorry you feel like this. In the last two weeks, I’ve been on bereavement leave and that’s the reason for my slow response.

Regarding this. In your case, I took the information to our development group to see if they could shed some light on your issue. We looked at the logs and all concurred that it was best to eliminate the three previously mentioned items from the equation and slowly add them back to find the culprit. You were not thrown to the wolves, you were asked to follow specific steps and provided with the tinkering group as an additional option to address your issue. Thus far, I see no posts in tinkering and have only received pushback on the suggestions I’ve offered.

The best advice I can give is to temporarily set up a non-VM core on any computer, disable the VPN for a testing endpoint, disable the firewall, and reboot your network to test. If you can’t omit the VM from the equation, at least try disabling the firewall and VPN’d endpoints to test. If you are unwilling or unable to try these things, please post in tinkering and see what our user base might have to offer based on their own experiences.