Tidal sync does not sync

Even if Roon has synced with Tidal, my playlists is not up to date … Tried resync, but stil missing the last 6-7 tracks in my playlist from Tidal …

Be happy you are only missing six tracks. I’m missing almost 30 playlists.

No matter what I do, all my tidal playlists are not showing up. I have re-installed, cleared preferences and done the tricks about signing out and clearing cache files and signing in again. Only 36 of my 60+ playlists are appearing.

Hey @Thomas_Ball – thanks for the report and sorry for the trouble.

Couple quick questions so we can see if there’s an easy way for us to reproduce what you’re seeing. If we can’t reproduce the issue, we’ll gather some more information and go from there.

Can you let me know:

  • What platform you’re running Roon on, and some of the other setup information described here?
  • What country your Tidal account is from?
  • What type of Tidal account you have (Premium vs HiFi)
  • Whether these are public/editorial playlists from Tidal you’ve added, or playlists you’ve created yourself? If it’s the former, can you post a link here?
  • Regarding the content of the missing playlists – can you provide a link to a song or two on Tidal’s website? Are you able to search for this content in Roon and play it?

And just to make sure I’m understanding what you’ve tried so far: you’ve cleared your Tidal cache as described here, and you’re seeing a completed “Library Sync Time” on the Services tab of Settings, right?

Thanks in advance for your patience Thomas!

I am running room on a Mac Mini with Yosemite 10.10.5. I’m running the mac headless. I’m using the latest edition of Roon and I have my music stored on an external drive. All the music on that drive has shown up. It is syncing with Tidal that is the problem. I have a Premium account and what is missing is half of the playlists I have created myself or have found from other subscribers. It is a U.S. Account. Link to a playlist not showing up is here:

Have cleared the cache, and all the other things I could find on this forum

I can access almost all the songs on Tidal. I’ve never seen a “completed Library Sync Time.” It never syncs.


Correction: my Tidal account is a HIFI account.

Thanks Thomas – that playlist syncs fine for me, and if you’re able to play the content in the playlists but the sync never actually completes, I think something else must be going on here.

I’m going to follow up via PM and we’ll get some logs from you so we can get a better idea of what’s going on here. Stand by.

Thanks very much for the generous attention Mike. I’m sure with your help we will be able to figure this out. I should also mention I have a MacBook Pro and a Mac Pro that are “remotes” for this main library on the MacMini. I’ll send logs and hopefully we can get to the bottom of this.