TIDAL Syncing Issues - NUC Core

Hi Eric

I have this problem also. It happened as soon as I updated my NUC core last night with your update.
No sync with Tidal.

Just give me a shout as and when you have fixed it.
Until then I will just plug my phone in through my Amp for Tidal playback.


Hi @noris,

Sorry about getting the name incorrect.
I only paid for my subscription two days ago so very new to this, not good timing by me I suppose.

Anyway as and when you have updated the fix just give me a shout and I will try it out.


Hi @Simon_Huxtable,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Is there any change in behavior if you log out and back in to TIDAL via the Roon Settings -> Services tab? Have you tried rebooting the Core machine?

Hi, tried emailing back to Norris but it keeps getting sent back?

I have the following set up. All connected via Ethernet Cat 6 (Min) cables.

The NUC core is connected direct to my Modem. I set this up three weeks ago while still on a Trial Subscription from Justboom.

All Bridges are Raspberry Pi3B with Justboom AmpHat running Ropiee. The only exception is the Living Room which is a Raspberry Pi3B Justboom Dac Hat to NAD Amp (Over 15 years old).


Intel BOXNUC8I3BEK3 NUC Mini PC - (Black) (Intel Core i3 8109U

Crucial CT8G4SFS824A 8 GB (DDR4, 2400 MT/s, PC4-19200, Single Rank x8, SODIMM, 260-Pin) Memory

Transcend 128GB NVMe Pcle Gen3 x4 MTE110S M.2 Solid State Drive


Manufacturer [RASPBERRY-PI (https://cpc.Farrell.com/raspberry-pi) RASPBERRYPI3-MODB-1GB. Raspberry Pi 3 Model B Board

Hi Norris,

Thanks for getting back to me.

The only thing that has changed since the update is my Roon isn’t linking to my Tidal account, all is running and I can still listen to my collection, just the link to the streaming system is not working.

I tried the usual restarting-no luck. Switched everything of at the plugs for an hour and then back on-no luck. I restored from an old back up file on a Samsung USB 256GB Stick (that stores my 90 Gb of collection) in the NUC USB slot-no luck.

The Tidal account still runs on my iPhone and MAC so I can play via my old NAD amp 3.5 Jack but obviously without all the bells and whistles that your software supplies. I am not going to get too worried as there are more important things to be concerned about at present but if you have time, any help would be much appreciated.

All the best and stay safe.

Hi @Simon_Huxtable,

Thank you for the additional information.

The only way you can respond to our messages is on the Community site, here is a link to your thread in case you’re seeing this in your email: TIDAL Syncing Issues - NUC Core.

As for this issue in particular, is there any change in behavior if you try logging out and clearing out your TIDAL cache?

  • Go to Roon Settings -> Services and log out of TIDAL
  • Stop RoonServer from running in the NUC Web UI
  • Find and open your Roon database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting RoonServer via the WebUI
  • Log back into TIDAL
  • Verify if the issue still occurs

Hi Norris,

Problem still occurs.

It is loading the Album art but says “this track is currently not available from tidal, too many failures. Stopping playback.”



Hi @Simon_Huxtable,

Where are you searching for this track from? Is it part of a playlist?
If you try to manually search for this track, does it play as expected?
Do other tracks work fine and it’s just this one track?

Hi Norris,

In the Album section of Roon. Albums I have added to my library are pictured but if I try to play them from the Library i get the above message.

was all working fine until the update a couple of days ago.

Hi Norris,

Tracks from my USB in the NUC are fine. All tracks in the library from Tidal get the same message and don’t play Audio.

Old playlist play as long as long as the tracks on the playlists are on the USB. I a playlist track is a Tidal track it just skips it.

Hi @Simon_Huxtable,

Can you please check to see if the TIDAL web player works as expected with this account?

Hi Norris,

Yeah it’s fine. I am playing it on my iPhone and my Mac. Since Roon keeps kicking it out it’s the only way I have of listening to it.

Shall I just wipe the NUC and set up from the image file again?

Or perhaps go back to the old Roon version somehow.

Hi @Simon_Huxtable,

Downgrading versions of Roon is not supported, so unfortunately this option is not possible.

If you want, you can try an OS Reinstall via the Web UI, I would however make a Backup of your current database before doing this.

Thanks Norris,

I was thinking I would have to strip the NUC and burn the image file to a micro SD again but using your suggestion with the web UI was very simple.

I also got rid of the Chrome Browser (that has taken over my Mac) and went back to Safari to log into Tidal as I did originally and everything linked in ok. I think the Tidal log in email address was different and was causing the problem so all down to me and not Roon update so apologies for that.

I am very new to this as I only paid up a week ago so thanks for guiding me in the right direction.

I think your data and layout on display screen is excellent. It’s really interesting to be able to read about artists and albums as I used to when buying albums in the before CD days. Also I am able to replace a few of my “played to death” albums from my youth via Tidal giving scratch less versions which is an added bonus.

All the best and stay safe in the coming months.


1 Like

Hi @Simon_Huxtable,

Thanks for the additional info here. Just to confirm - since logging in with the correct TIDAL email address, are you able to properly sync though Roon and TIDAL playback works as expected? It does sound like the issue is resolved, but I wanted to double check before closing this thread out, thanks!

Yes, thanks again Norris.

All working well.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.