Tidal Syncing Issues [Ticket Open]

I am having the same problem (Washington DC if that matters). Since Dec 14 2018 it won’t sync.

1 Like

I’m finding all of my Tidal accessing through Roon to be very slow. Access through the Tidal app is very snappy. It leads me to think Tidal has been messing with their backend APIs that Roon uses, putting some sort of limiter on them? (@support)

Thanks, I am glad to know that it is not just me. Still the same this morning.

1 Like

Same here (also in DC, doubt that matters). Now that I think on it, this has been happening for a couple days at least.

I’ve logged out of Tidal in Roon, removed the Tidal cache folders (indeed the whole Roon/Cache folder) and power cycled Roon - all several times.

After re-logging into Tidal in Roon, some version of my Tidal collection is brought back in quickly, but not the latest, as I’m still seeing albums in Roon that I’ve removed in Tidal.

If I try to delete a Tidal album in Roon, I get “File Not Found” errors. I can add albums to Tidal from Roon.

Like others, it just says “Syncing Library Now” but never stops or gives me the “Sync Now” button.

1 Like

Hello All,

Thanks for the reports and bringing this to our attention. Can everyone affected by this issue try seeing if changing the DNS for your router has any impact on the sync progress?

Changing it to Google DNS or Cloudflare has had improvements in the past with similar issues and I just want to make sure that it’s not your ISP’s DNS causing issues here.

Please let me know your findings when possible.

Thanks,
Noris

1 Like

I have the same issue for a week now and the suggestions here dont help. @support please enable diagnostics on my account and have a look. After i renamed the roon folder into roon_old and logged in with my roon account and my tidal account, roon only synced 116 albums out of 2500 tidal albums and stopped. The Syncing library now text is constant. Never changes. Please help. I need this fixed because now i cant sync anything between tidal and roon. I reverted back to my old roon folder.

Hello @Dusty,

I have moved you post over to this thread where we are tracking the issue. Please give my suggestion a try and let me know if it changes anything:

Thanks,
Noris

Hi Norris,

I cannot change DNS servers on my ATT gateway. They do not allow it. I would have to change it at the machine level but I cannot do that on the sonicTransporter machine where the Roon core resides. I have already changed to Cloudflare on every machine that I can change it on. I checked again this morning and Tidal is still showing “Syncing Library Now”. It has been stuck on that for days.

I am not at home, but my Tidal account now reflects the changes I made in Roon last night, so my sync happened.

When you get home, check to see if changes you made in Tidal have synced to Roon. That direction is still not working for me and I still have the syncing now message on all the time.

Hello @bobflood/@RobOK/@Dusty,

We did some testing on our end and syncing is working as expected for both TIDAL -> Roon and Roon -> TIDAL. I can go ahead and enable diagnostics mode for your account but I kindly request some timestamps of when the issue occurs, as in please let me know the exact local time in your country (ex 7:04PM) that you have:

  1. Added a track to TIDAL or Roon
  2. Performed a sync in Roon
  3. Checked and the track/album did not show up

Please let me know this info and then we can take a closer look to see if the diagnostics reveal any strange behavior.

Thanks,
Noris

Hi Norris,

8:06 PM EST added “Bitter Sweet/Brian Ferry” to Tidal from Tidal desktop. It shows in Albums on Tidal but is not in Roon library.

8:08 PM EST added “The Dance/Dave Koz” to Roon library from Roon. It shows in Overview on Roon and in Albums on Tidal.

8:10 PM EST attempted sync but still getting constant “Syncing Library Now” message.

8:12 - 8:14 PM EST signed out and back in to Tidal and re-booted core.

8:15 PM EST retry sync but still constant "Syncing Library Now’ message.

8:25 PM EST attempted to delete “An Oscar Petersen Christmas” from Roon library. Unsuccessful getting “File not Found” message next to each track to be deleted.

There is no change in behavior. I hope you can find the problem.

Thanks,

Bob

Changed DNS (from Cloudflare to Google), even tried a different Ethernet port, and a reboot of the machine Core is on.

I also logged out of Tidal in Services and quit RoonServer, then deleted Cache folder, then started RoonSever and re-logged into Tidal.

No change in behavior.

Thanks for letting me know those timestamps @bobflood, I can confirm that we have received the diagnostics from your machine and it is being reviewed.

@jtnt - Would it be possible for you to let me know some timestamps as @bobflood has done on his post to see if there is a correlation in the reports here? After receiving those timestamps I can go ahead and enable diagnostics mode for your account as well.

Thanks,
Noris

Don’t know if it’s specific enough, but I did all of the above right before I submitted the post above, so ~8:40-8:45pm eastern on December 17th.

If you need specific timestamps for particular actions, I can do that tonight when I’m back home.

Hi @jtnt ---- Thank you for the follow up and insight here!

Continuing forward, I went ahead and enabled diagnostics on your account so we can have a closer look into the mentioned time frames. However, specific timestamps would be a huge help, so if you are able to send those over when you are home tonight it would be appreciated!

Many thanks!
-Eric

1 Like

Today, 18th of December:
11:10 PM - Favorited the album Evanescene - Synthetis Live in the TIDAL app.
11:12 PM - Synced TIDAL in Roon using the TIDAL screen since in the settings it keeps saying that its syncing and there is no button to sync.
11:13 PM - Checked to see if the album has been added to Roon. It has not.

The time is in my local time which is Eastern Europe. UTC + 2.

Please let me know when you have looked at the logs because i want to add some new albums and i dont want to clog the logs with that. Thank you.

Hi @noris. I’ve tried changing the dns for my router and it hasn’t fixed anything.

@Dusty - Thanks for providing those timestamps and trying the DNS change, I can confirm that we have received the current logs from your system so you can go ahead and start adding new albums.

Thanks,
Noris

(or as better said from one Romanian to another - Mulțumesc! :slight_smile: )

1 Like

8:11pm - Add Tidal album to collection in Roon (shows up in Tidal and Roon)
8:11 - Add Tidal album to collection in Tidal app (does not show up in Roon)
8:11 - Log out of Tidal in Roon
8:12 - Quit Roon Core
8:12 - Remove Tidal cache on Core machine
8:13 - Start Roon Core
8:13 - Login in to Tidal in Roon

Tidal collection is loaded, but album I added in Tidal app above is not listed.

Still says “Syncing library now” as I type this at 8:16

Edit: 9:19 - Try to remove a Tidal album in Roon, get “File not found” error.

1 Like