Tidal: This track is currently unavailable: Stopped playing too many errors

Core Machine (Operating system/System info/Roon build number)

Innuos Zen Mk.3; innuOS v 1.4.5; Roon Version 1.7 (build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Zen -> ethernet -> Genexis DRG 7820 v1.2 FTTH home gateway & switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Zen -> USB -> Audio-Audio Technica AT-HA5050H

Description Of Issue

About 2 weeks ago my Roon stopped being able to play music from Tidal. I can see and search for music on Tidal via the Roon app but when I try to play anything I get the message:

This track is currently not available from TIDAL.
Too many failures. Stopping playback.

If I use the Tidal app on my phone I can play the same tracks with no problems.

I have tried disconnecting Tidal from the Roon and reconnecting but this makes no difference.

Kind regards


2 posts were merged into an existing topic: Stopped Playing Too Many Errors - Euphony OS

Hello @TomK, does this happen to a specific endpoint or any endpoint you try? Have you tried playing to system output of one of your remotes?

Hi @nuwriy

This happens with all of the endpoints - the Audio-Technica DAC/headphone amp, my Naim Mu-so 2 and Naim Mu-so Qb2 as well as the outputs on both my tablet and mobile phone. No matter which output I use I get the same errors.

BTW, Tidal plays fine on each endpoint using the native Tidal app (or Naim Tidal app for the Mu-so)


4 posts were split to a new topic: Stopped Playing Too Many Errors - Euphony OS

Hello @TomK, and thanks for the update! I agree with rugby’s recommendation. Are you able to temporarily test this issue with another core and let us know if you reach the same result?

Hi @nuwriy, I am not sure how to do that. Where would I buy another core? Or is there an app that I can download to my mac that will act as a core?

Roon will work as core on a Mac if it has sufficient performance.

@Henry_McLeod Thanks - I am guessing that it doesn’t really matter about the performance too much just for testing the ability to play Tidal tracks?

It should be OK. I don’t know how old it is but for testing purposes it should be OK so long as Roon loads up.

Hello @TomK, you can follow this guide to make a backup and move it to the new temporary core, but you don’t have to move your storage. Our main goal here is to test TIDAL on a separate core.

Hi @nuwriy, I installed Roon on my Mac. Firstly I connected to the existing core, running on the Zen, and I got the same “Track unavailable” error. I then disconnected from the Zen core, unauthorised it and created a new core running on the Mac. I logged into Tidal and had no problems playing any tracks. So, it looks like a problem with the Zen core?

Hello @TomK, is there any difference in how the Zen and the Mac are connected to the network? Also, have you tried switching to Google or Cloudflare DNS with the Zen as the core?

Hi @nuwriy

The Zen is connected via TP-LINK AV1200 powerline connectors to the switch in the main router. The Mac is connected by WiFi through a BT WholeHome mesh network, again into the switch in the main router.

By switching DNS, do you mean manually changing the DNS settings on the Roon controllers (mobile phone, tablet, Mac etc) to or or do you mean manually configuring the DNS on the Zen to those IP addresses? If you mean the latter, then I am not sure that the Zen Mk3 has the facility to manually set the IP address.

Have you rebooted the powerline adapters?
Roon generally advises against their use as they have seen multiple issues.

1 Like

Hello @TomK, ged has the right info here! If you swap out the powerline adapters do you still see this issue?

Hi @nuwriy @ged_hickman1, thanks for the suggestion.

I finally managed to rearrange the furniture so that I could get to the main internet router/switch and ran a cable from it to the Zen. It made no difference. I still get the “Track Unavailable” error.

I am beginning to tear my hair out!

Thanks for trying that, @TomK.

It’s definitely strange that this is working okay on the Mac but not the Zen. Have you spoke to Innuos about this yet?

You can set DNS on your router, typically. While macOS may be working okay with the current DNS setup, the OS on the Zen is different enough that a DNS change could potentially help, and we’ve seen it clear up TIDAL issues in the past, so I’d recommend giving this a try if possible.

Hi @dylan

So, I tried changing the DNS on the router and no improvement.

I called Innuos and they logged into the Zen via my laptop. They changed a configuration file, via command line interface :scream: , updating the DNS. Rebooted the Zen. Logged me out and back into Roon and then out and back into Tidal.

The bottom line is that it now works :grinning:

TL:DR If you have an Innuos Zen and Tidal stops working you might need to get Innuos support to change the configuration file on the Zen and then log out and back into Tidal.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.