Tidal tracks & albums load slowly on new NUC running Ubuntu

Greetings. I purchased an Intel NUC11, initially planned to load ROCK OS but the BIOS on this series of NUC’s isn’t compatible with the current version of ROCK. I opted to load a minimal installation of Ubuntu and install the Linux version of Roon Server. I de-authorised Roon Core on my Windows 10 Pro PC & restored a backup to the NUC. I use an Ethernet network to connect to my endpoints. I’ve connected my personal library of ripped CDs via a USB 3.0 external drive to the NUC. My Windows Roon Core streamed my collection of Tidal albums & ripped CDs flawlessly & almost instantaneously to my endpoints. However, the Roon Server on the NUC takes up to 20 seconds to stream a newly selected track or album from Tidal. Tracks & albums on my USB disk stream immediately. Once a Tidal album has been queued, after an initial wait of 15 to 20 seconds, it plays perfectly with no gaps between tracks. But, if I skip to the next track or select another track off that album, it takes 20 seconds to play that new track. Likewise, when I change albums, Roon takes 20 seconds to play them unless they’re off my drive. Tidal playlists comprised of various artists take 20 seconds between tracks to play. Any advice to fix this frustrating issue would be much appreciated, thank you.

What version of Ubuntu have you installed? Was this the Desktop image or the live Server, e.g., ubuntu-20.04.3-live-server-amd64.iso? Did you install all the dependencies? Do you have UFW enabled?

Furthermore, please describe your network and how you’ve connected each Roon component.

How long ago did you set it up?

Hi Martin. The NUC arrived yesterday and the latest version 20.04.3 LTS was downloaded and a minimal install of Ubuntu loaded. All the dependencies as listed on Roon’s website were installed (my son is in IT and helped me download and install these: I’m useless with Linux!). I don’t know if UFW is enabled: I’m not at home at the moment, but will check this if you tell me how to do so :slight_smile: Thanks for your speedy reply.

Hi Ged. Installed yesterday, all up and running (except for this issue) last night. Has been running since, and I’m able to hear my music on my endpoints

Has it finished analysing your library?

Network is hardwired throughout my house, Gigabit Ethernet, cabled all the way to each component. Not using wi-fi at all. Using a Draytek router and multiport switch as I did with my Windows setup which has worked flawlessly for 18 months.

Yes it has

UFW wasn’t enabled. Have done so, applied rule allow 192.168.0.0/16. No difference to Tidal library, still super slow. Tracks/albums in local library load instantaneously to all endpoints on the wired network.

Hopefully some more feedback that’ll help: If I play a Tidal album/track over the same network but using my Lumin app, the album/track loads in 3 seconds. Using Roon Server on the NUC, the same album on Tidal, same network, etc., takes between 16 and 20 seconds to load. As I’ve mentioned earlier, albums/tracks in my local library (4TB USB 3 external HDD) play instantly from the Roon Server on the NUC. I thought that this could be a Tidal issue but it’s not.

There is another thread describing similar problems. You may want to look at this.

Thanks for the suggestion, Martin. I did change this BIOS to make the NUC run at maximum performance but it made no difference, unfortunately.

Does Roon support read these posts or should I be using another thread for them to be aware of my issue? I’m a lifetime subscriber and love the software, I’d really like to get it running on the NUC like it used to on my Windows PC.

Yes, @support do read posts in the #support category. However, they deal with post in order, and do not work the weekend, so don’t expect a reply until the beginning of the working week.

Did you install the minimal desktop or just server? I’m happy to help you check a few things. For starters, can you run the following?

ip a

This will show, among other things, your Ethernet connection…

2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether d8:9e:f3:1f:09:21 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.10/24 brd 192.168.1.255 scope global noprefixroute enp0s31f6

Now run this, taking the interface name from above (substitute for your system.)

nmcli device show enp0s31f6 | grep IP4.DNS

The output should be similar to this.

IP4.DNS[1]:                             1.1.1.1
IP4.DNS[2]:                             1.0.0.1

This is the result I get: 2: enp89s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> MTU 1500… When I run the ‘nmcli device show’ for this, there’s no result. 3: enp89s0 gives me the IP4 address, gateway, route, DNS, etc. There are two LAN ports on the NUC, one is gigabit, the other is 2.5 GHz. I’m using the former. I tried both ports, no difference in the speed of loading Tidal tracks. I’m using the minimal desktop version of Ubuntu

nmcli device show enp89s0 | grep IP

IP4.ADDRESS[1]: 192.168.0.38/24

IP4.GATEWAY: 192.168.0.2

IP4.ROUTE[1]: dst = 0.0.0.0/0, nh= 192.168.0.2, mt = 100

IP4.ROUTE[2]: dst 192.168.0.0/24, nh = 0.0.0.0, mt = 100

IP4.ROUTE[3]: dst = 169.254.0.0/16, nh= 0.0.0.0, mt = 1000

IP4.DNS[1]: 9.9.9.9

IP4.DNS[2]: 8.8.8.8

IP6.ADDRESS[1]: fe80::6bdd:60c6:6b5f:e9f5/64

IP6.GATEWAY: - -

P6.ROUTE[1]: dst = fe80::/64, nh = ::, mt = 100

Your DNS looks wrong. I’m pretty sure Google is 8.8.8.8 and 8.8.4.4.

1 Like

9.9.9.9 is a public non profit dns. Might try making 8.8.8.8 as number 1 and see if it improves things.

2 Likes

Thank you guys, I’ll give this a try

You guys are geniuses!!! Thank you, streaming beautifully! Now for a great weekend of music. Have a good one.

4 Likes