Tidal tracks not available in Roon but they are in Tidal

Hi Noris, will You have the Chance to look into my Tidal problem again, as Tidal is my prime source for Roon. Thank You very much Thomas
PS. Did You receive my support Package?

1 Like

Hi @Thomas_Unger,

Thanks for sending those logs over! These appear to be from the Mac controller, but no worries, I’ve also activated diagnostics mode for your Nucleus, and what this does is upload a system log from it.

I’m looking over the log report now and I’m noticing a few Name Resolution Errors. Can you change your DNS servers on the FritzBox? If so, I would suggest changing it to Cloudflare DNS, Quad9 or Google DNS.

You could also try a TIDAL cache clear as well:

  • Stop Roon Server from running in the Web UI
  • Find and open your RoonServer database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon Server via the WebUI and verify if the issue still occurs

Hi Noris, Ive changed the DNS to Google and moved the Cache folder again. Roon Still does not work😩2020-07-04_16-37-42
I still get the error:
The title is currently not available on TIDAL. Too many errors. Playback is stopped.
What else can I do?

Hi @Thomas_Unger,

Can you please share a screenshot of your Nucleus Web UI? It should look similar to this for reference:

Here You go…

A post was split to a new topic: TIDAL Playback Issues - Mac Mini / Node 2i

Hi @Thomas_Unger,

Thanks for sharing that screenshot, it looks as expected. This is strange, because I’m still seeing Name Resolution Failures in your logs at the present time.

Can you please try to perform a full reboot (power off, wait 30 seconds, power back on) of your networking gear and Nucleus following the DNS change?

As a reminder, to ensure the clean power off of the Nucleus, please use the Web UI or press the power button only once.

Hi John, I just dit a full reboot (power off, wait 30 seconds, power back on) of my networking gear and Nucleus following the DNS change. The the error remains.
the sensor is independent of the zone. I’ve added two images: 1. The zone of my speakers. 2. My iPhone as zone.

Hi @Thomas_Unger,

Thanks for giving the full reboot a try. As for the next step, I’d like to know if a fresh database also exhibits this issue. Can you please use these instructions to perform this test?

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Hi Noris, I don´t find the File “Roon Server” on my Mac. I I found is what You see on the attached screenshot.

I don’t know if this helps. I ran into a problem a while back where Tidal changed the internal IDs of albums/tracks. The music played fine on Tidal but my Roon server had the items under the old IDs and was unable to play any of it.

To fix it, what I did was remove the items from my Roon collection and then re-add them.

Hello @Thomas_Unger,

The Roon database which I am asking you to try setting aside is the one on your Core, the Nucleus.
Since you have a Mac, I would locate the Nucleus from the side-bar or use the Connect to Server Feature (Method 2) to connect to your Nucleus:

Nucleus Core

  • Using a Windows machine, open File Explorer and navigate to \\NUCLEUS\Data . You should then see the RoonServer folder.
  • Using a Mac, open Finder and navigate to smb://NUCLEUS/Data . You should then see the RoonServer folder.

Be sure to replace NUCLEUS with NUCLEUSPLUS if you have a Nucleus+

Once you are in the Data directory of the Nucleus, you should see a RoonServer folder. It should look similar to below:

Hi Noris,
I renamed the RoonServer File, see p

2020-07-08_17-30-21 icture. The the error messages remain :frowning:

Hi @Thomas_Unger,

Thanks for giving the fresh database a try, this confirms that the issue is not related to the old database, and we can focus on what the other causes can be, the TIDAL account itself and the network.

Let’s test the TIDAL account first to ensure there are no issues here, you can do this by opening up the TIDAL web player (listen.tidal.com) from a web browser and logging in with the same TIDAL account from Roon, if playback of a full track works from there, the account is in good standing and we can move on to the network below.

As for the network - I was previously seeing some Name Resolution Errors in your logs, so as a test, I suggest we first create a Backup of your database and then, on your Nucleus WebUI try a manual DNS option, bypassing the router DNS:

Can you please try clicking on “Static IP” and inputting these manual fields? Basically we are changing the DNS server from pointing to the router to pointing to Google directly.

IP Address:
DNS Server:

Please note, when you assign a Static IP, the Nucleus will always try to use the same IP address, so it is a good practice to also set up a Reserved IP Address in your router configuration to ensure no other device gets automatically assigned the same IP address as the Nucleus (and thus losing communication with both).

Hi Noris, the TIDAL web player test (listen.tidal.com) worked. I did the input into "Static IP” and set up a resaved IP Adress in my router (Thank You for the link!!!) in your router. Now I can’t log into my Tidal account anymore out go Roon.

I remain in a log in circle:

Hi @Thomas_Unger,

Thanks for making those changes. I would like to take another look at the logs, but it seems that your Nucleus stopped communicating with our diagnostics servers.

Can you please manually send logs again? As a reminder, you can use these instructions and the logs would be under RoonServer/Logs (similar directory to how you performed the RoonServer_old rename).

Once I have these logs, I’ll loop in QA as well, perhaps they are able to see something I missed. Thanks again for your patience here through this troubleshooting process.

Hi Noris, I can’t send the logs:

Hi @Thomas_Unger,

You can only upload images to the forum, sending logs must be done through another method, typically a file sharing service. I created an account for you on our diagnostics upload servers and PM’d you the link, you can upload there if you wish.