Tidal tracks not playing correctly on Roon

Core Machine (Operating system/System info/Roon build number)
Nucleus Firmware 1Ver 1.7
Mac Mini.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Router Netgear Orbi mesh system

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Orbi Router > Orbi satellite > Ethernet cable > Nucleus Int HDD > Chord Hugo Dac > Amp

Description Of Issue

  1. Roon loses wifi connection frequently - sometimes reconnect by itself, sometimes manually
  2. Roon Core disconnects by itself and has to be manually reconnected.
  3. Tidal files on a playlist does not connect correctly. Sometimes, it takes 5 or more seconds to play - can be up to 2 mins before it plays. Sometimes, it skips a track and plays next track. Sometimes, it doesn’t play at all.

Error message. “Track is NOT available on Tidal”
Those tracks can be play on Tidal app but not in Roon

Playlist with Tidal streaming tracks has the above problems. TRacks stored in my Nucleus internal storage plays perfectly.

It is either:

  1. Tidal issue on Roon
  2. Network Issue
  3. Wi Fi issue
  4. Roon problem

This problem only started 2 days ago.
Have tried clearing cache on Tidal app. Doesn’t help


Hi @Corey_Tai,

Welcome to the forum. It sounds like there are two issues here, one with the remotes connecting to the Nucleus and one with TIDAL playback, let’s take a look at them individually.

  • When this behavior occurs, do multiple Roon Remotes experience it at the same time?
  • How is the Mac Mini connected, is it using WiFi or Ethernet?
  • Is there any change if you plug in the Mac Mini via Ethernet?
  • Is your Orbi system up-to-date on latest firmware?
  • Is there any specific problematic album displaying this behavior or does it occur for multiple albums?
  • Have you tried rebooting the Nucleus + Networking Gear + Hugo DAC yet? I would give this a try.
  • Do other zone experience this issue or is it limited to the Hugo zone?


Issue 1 - Wi Fi

I might have “fixed” the problem. Time will tell.

Issue 2 - Roon not playing any Tidal tracks correctly. Have rebooted everything many times. Every zone has the same Tidal track problems. From my Mac Mini or Smartphone or Tablet running Roon.

So issue 2 is NOT resolved.

Tidal Files in Roon is NOT resolved with your suggestions.

Playing TIDAL files on TIDAL works 100%

Up to last night:

  1. Every Tidal track on any Playlists created in Roon has problems. These Tidal tracks are from Multiple albums.

  2. All my playlists have stored files (on HDD internally on the Nucleus) and Tidal tracks. Only Tidal tracks have problems.

  3. Stored files have NO problems and load/plays

  4. Will not load 1st Tidal track at all - either just sit there or skips to next track.

5 Next track sometimes plays after a few seconds but more like after 15 secs. OR skips to next track OR Does NOT Play at all.

Summing up. Every Tidal track on Roon playlists has the same issues.

Everything on my systems works - my router, my network, all computers, all smartphones, all Tablets, My Synology NAS, etc etc. EXCEPT Tidal files on ROON

See a typical playlist

Hope you can provide a solution.


Hi @Corey_Tai,

  • If you manually search for a TIDAL track that’s not in your playlist, does this work as expected?

  • Have you tried logging out and back into TIDAL? I would try this.

  • What is your reported download/upload speed? Can you run a speedtest.net test?

In order of your suggestion/questions:

  • If you manually search for a TIDAL track that’s not in your playlist, does this work as expected?

  • Any and ALL Tidal tracks played within Roon DOES NOT work correctly. Faults have been outlined many times.

  • Tidal tracks within Tidal app works perfectly!!!

  • Have you tried logging out and back into TIDAL? I would try this.

  • Many times. Even uninstall Tidal and downloaded again.

  • What is your reported download/upload speed? Can you run a speedtest.net test?

  • “Decent” 73.33 downloads in Speedtest.

FULL description of faults: - AGAIN:


It is a Tidal with Roon problem

*Playing Tidal tracks in Roon was working perfectly up to this week

*It does not matter whether Tidal tracks are in a playlist or a full Tidal Albums. Just have issues when played in Roon.

*Playing Tidal within Tidal app - WORKS PERFECTLY

*The faults outlined below are random

*In any playlist in Roon, ONLY Tidal tracks have the faults. Tracks stored in my Nucleus internal HDD works PERFECTLY.



All Tidal Tracks has random faults and they are:

  1. Don’t play that track - just sits there

  2. or plays after 5 secs and up to 30 plus secs

  3. or skip to next track or the track after

  4. If next track is a non Tidal track, it plays immediately

  5. It is not a particular track issue. all faults occur with ANY Tidal tracks

  6. Most frustration, on the rare occasion, Tidal tracks play immediately.

Attached SS of one playlist showing Tidal tracks (have problems) and stored tracks (plays perfectly and immediately).

Hi @Corey_Tai,

Thanks for sharing the above info. I want to clarify one aspect you mention here:

The TIDAL app on your PC won’t have anything to do with the Roon functionality, clearing the TIDAL cache for the TIDAL app does not clear the Roon cache. As a follow-up step though, I suggest that we clear out the Nucleus Roon cache. Can you give this instructions a try and let me know how it goes?

  • Open the Nucleus Web UI and stop RoonServer (Right-hand side -> RoonServer Software -> Drop-down -> Stop

  • Find and open your Roon database via Mac Connect to Server

  • Navigate to Data/RoonServer/Cache

  • Move the contents of the /Cache folder elsewhere, like your desktop

  • Try restarting RoonServer from the WebUI and verify if the same issue occurs

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.