TIDAL tracks not playing [resolved: 790 improved]

@noris Here is the second part of the tests you asked for.

Playing local content from MacMini Core via wifi to Node 2 (with the latest firmware installed)

Started playing on April 24 at 9am. First track: “You’ll Have to Swing It” by Ella Fitzgerald. During this two-day test, local content played almost flawlessly. I noticed stopping/skipping two times.

After 323 tracks (approximately 24 hours playback time), the first glitch: playing stopped during “Blop Down” by Cozy Cole Orchestra (after 65%).
On April 25 at 11:55 am local time, I restarted the next track in the queue (“Songs (5) of Ophelia, for voice & piano, WoO posth. 22”).
Twenty tracks further, “'81” by Joanna Newsom, skipped completely (April 25, around 13:20 local time).
After that, playback continued without issues for almost 22 hours. I stopped the test on April 26 at 10:48 am (during the track “Night in Tunesia” by Yusef Lateef Quintet).

There seems to have been nothing wrong with the two tracks during which the stopping/skipping occurred. On April 25 around 2 pm, I “added next” to the queue both tracks. They played flawlessly.

Please let me know if you need further testing or information from my side. I would be happy to help. As you can see in the first two tests, this is not just about an occasional glitch. And as you can also see, it is clearly neither caused by wifi, nor by the Node 2. I hope that solving this problem will get the full attention of the support crew. Especially since, over the weekend, I again saw several new posts and comments of users experiencing similar problems.

Results of a third part of my test (with Qobuz content) is here: Playback Skipped - #24 by Francois_De_Heel

1 Like

A post was merged into an existing topic: No appropriate error-messages from Roon

Hello @Francois_De_Heel ,

Thank you for performing the tests and letting us know those timestamps!

I can confirm that a new log set from your Core has reached our servers and I have requested QA to review the log set along these timestamps.

Once I have QA’s feedback here, we will update you accordingly, thanks in advance for your patience while your case is reviewed!

I have the same issue as Francios. Tidal songs skipped in the middle and the error log looks very similar to his:

04/27 15:19:18 Trace: [MacOutput] [HighQuality, 16/44 TIDAL FLAC => 24/44] [100% buf] [PLAYING @ 1:32/4:41] No Time to Kill - Ruts D.C.
04/27 15:19:23 Trace: [MacOutput] [HighQuality, 16/44 TIDAL FLAC => 24/44] [100% buf] [PLAYING @ 1:37/4:41] No Time to Kill - Ruts D.C.
04/27 15:19:24 Error: [cachingseekableurimediafile] while reading: System.ArgumentException: Offset and length were out of bounds for the array or count is greater than the number of elements from index to the end of the source collection.
at System.Buffer.BlockCopy (System.Array src, System.Int32 srcOffset, System.Array dst, System.Int32 dstOffset, System.Int32 count) [0x0007e] in <49e2691b1d1a45389d419b3a01a2b89a>:0
at Sooloos.Media.StreamingMediaFileImpl._Read (System.Int64 file_off, System.Byte[] buf, System.Int32 off, System.Int32 count) [0x00066] in <5abb1b80dcb740a8ad01eafa66840c2b>:0
at Sooloos.Media.StreamingMediaFileImpl.Read (System.Int64 file_off, System.Byte[] buf, System.Int32 off, System.Int32 count) [0x0005e] in <5abb1b80dcb740a8ad01eafa66840c2b>:0
at Sooloos.Media.StreamingMediaFile.Read (System.Int64 file_off, System.Byte[] buf, System.Int32 off, System.Int32 count) [0x00000] in <5abb1b80dcb740a8ad01eafa66840c2b>:0
at Sooloos.Media.CachingSeekableUriMediaFile.ReadCallback (System.IntPtr userdata, System.IntPtr buf, System.IntPtr count, System.IntPtr& out_bytesread) [0x00055] in <5abb1b80dcb740a8ad01eafa66840c2b>:0
04/27 15:19:24 Warn: [prebuffer] in buffer threadSystem.Exception: Read failure: IoFailure
at Sooloos.Audio.MediaDecoderAudioSignal.Read (System.Byte[] buffer, System.Int32 offset, System.Int32 frames) [0x0024a] in <39f49420e2684935a4e2a0cbcc8fff8b>:0
at Sooloos.Broker.Transport.FormatDetectAudioSignal.Read (System.Byte[] buffer, System.Int32 offset, System.Int32 frames) [0x000ca] in <4946aaca5e13461cb96ea6a5459ace7a>:0
at Sooloos.Audio.SeekableBufferedAudioSignal._Buffer (System.Int32 buffer_seq) [0x0003e] in <39f49420e2684935a4e2a0cbcc8fff8b>:0
at Sooloos.Audio.SeekableBufferedAudioSignal+<>c__DisplayClass31_0.<_StartBuffering>b__0 () [0x00000] in <39f49420e2684935a4e2a0cbcc8fff8b>:0
04/27 15:19:24 Info: [MacOutput] [zoneplayer] Track ended unexpectedly: Sooloos.Audio.BufferedReadException: error during buffered read —> System.Exception: Read failure: IoFailure
at Sooloos.Audio.MediaDecoderAudioSignal.Read (System.Byte[] buffer, System.Int32 offset, System.Int32 frames) [0x0024a] in <39f49420e2684935a4e2a0cbcc8fff8b>:0
at Sooloos.Broker.Transport.FormatDetectAudioSignal.Read (System.Byte[] buffer, System.Int32 offset, System.Int32 frames) [0x000ca] in <4946aaca5e13461cb96ea6a5459ace7a>:0
at Sooloos.Audio.SeekableBufferedAudioSignal._Buffer (System.Int32 buffer_seq) [0x0003e] in <39f49420e2684935a4e2a0cbcc8fff8b>:0
at Sooloos.Audio.SeekableBufferedAudioSignal+<>c__DisplayClass31_0.<_StartBuffering>b__0 () [0x00000] in <39f49420e2684935a4e2a0cbcc8fff8b>:0
— End of inner exception stack trace —
at Sooloos.Audio.SeekableBufferedAudioSignal.Read (System.Byte[] buffer, System.Int32 offset, System.Int32 frames) [0x0004f] in <39f49420e2684935a4e2a0cbcc8fff8b>:0
at Sooloos.Broker.Transport.ZonePlayerTrack._ReadBacking (System.Byte[] buffer, System.Int32 offset, System.Int32 frames) [0x00041] in <4946aaca5e13461cb96ea6a5459ace7a>:0
at Sooloos.Broker.Transport.ZonePlayerTrack+_Stream.ReadImp (Sooloos.Audio.AudioBuffer buf, System.Int32 nsamples) [0x00041] in <4946aaca5e13461cb96ea6a5459ace7a>:0
at Sooloos.Audio.AudioStream.Read (Sooloos.Audio.AudioBuffer buf, System.Int32 nsamples) [0x0005e] in :0
at Sooloos.Broker.Transport.ZonePlayerBase.ReadImp (Sooloos.Audio.AudioBuffer buf, System.Int32 nsamples) [0x00207] in <4946aaca5e13461cb96ea6a5459ace7a>:0
04/27 15:19:24 Warn: [zone MacOutput] Track Stopped Due to Error
04/27 15:19:24 Info: [library] recorded play for profile aedb201d-e179-48a7-bbcf-ee176920a45c: mediaid=168:0:3258634 metadataid= contentid=168:0:3258634 libraryid= isfromswim=True
04/27 15:19:24 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:
04/27 15:19:24 Info: [zone MacOutput] OnPlayFeedback StoppedEndOfMediaUnnatural
04/27 15:19:24 Debug: [zone MacOutput] _Advance

My environment is wired, and playing tidal songs on the system output (MacOS). Roon core is on NUC10.

@noris Hi Noris. In order to further narrow down the possible causes of the skipping issue, I decided to perform a fourth test with Qobuz tracks. (For this test, I installed Qobuz, which I did not use before.)

Playing Qobuz content via wifi to the Node 2 with the latest firmware installed

I did a ca. 21 hours test. Qobuz content played almost flawlessly. I noticed skipping two times.

Details:
The first session: started April 28 at 13:17 (first track: “Cherry Blossom Girl” by Air)
First skip: April 28, ca. 15:00 “Missing” by Everything but the Girl (after 35%)
Second skip: April 28, ca. 15:50 “Sensuality” by Ibrahim Maalouf (after 50%)
I stopped the session on April 28, ca. 18:35 during “Flamenco Sketches” by Miles Davis.

The second session: started April 28 at 22:16 (first track: “Night of the Iguana” by The Cinematic Orchestra)
Played for almost 16 hours until now (April 29, 14:12) without any skipping.

FYI: the two skips during the second session on April 29 around 22:20 were caused because I was fiddling around with the BluOS app. So not a Roon issue.

EDIT: My posts mentioned March everywhere, which should of course be April.

Hi @Francois_De_Heel, @noris,
because of my trials I have a similar picture. At some days there are almost no or just a few skips and I always try to do speed tests at the same time. General internet speed at my connection is always very good (>900Mbps). But today for example I compared 2 skips (around 12:50o’clock) from Tidal with a diagramm about Tidal down times from the internet (People report issues there).


These 2 recognized issues were at the same time as other poeple reported issues with Tidal.
I guess you also find more skips if you stream higher volume files like MQA 96kHz from Tidal.
I never realized these skips with other Apps, but they also don’t show it quite clear.
Roon seem to me very sensitive at these bandwith variations. :cry:
Maybe this helps.

@noris Hi Noris! Any news yet? I reported the skipping issue more than a month ago. You enabled diagnostics mode ten days ago. Can I expect any help/solution anytime soon?
In case it might help: here are some more data points. In the last few days, I have mainly been playing Qobuz tracks. So far, skipping appears to happen less often than with Tidal, but it does happen.

Details:
Started a Qobuz playlist on the 1st of May at 9:45am (first track: “Happy House” by The Housemartins).
First skip after 48 tracks: “Time & Space” by The Cinematic Orchestra (played 10%)
Second skip: 66 tracks later: “Kissy Kissy” by The Monochrome Set (played 70%)
Third skip: 45 tracks later (May 1 at 20:40): “Samson” by Regina Spektor (played 80%)
Fourth skip: next track: “Father & Son” by Cat Stevens (played 25%)
Fifth skip: 284 tracks later (May 2 around 17:10): “I Want you Back” by The Jackson 5 (skipped completely)
After that Roon kept playing Qobuz tracks from the playlist for another 103 tracks without skipping (last track: “'75 aka Stay With You” by Lemon Jelly.

3 Likes

Hi @Francois_De_Heel, @noris, @dylan,

I also got no further feedback - I guess we are all in the same boat.
Within the 15 days I saw 42 people which might have the same or similar issue and almost no solution, very, very late feedback or no feedback… It’s so sad. :cry:
A feed back like: we are working on it - would be really great. Nothing is nothing! Sorry.

Here is some feedback from a trial I did with qobuz. I made a monthly contract with qobuz to make a comparison to Tidal. With Tidal I do not have one day without any skips.
Today (May, 4th 2021) I run a test of about 12,5 hours with qobuz titles, albums (most in higher 24bit quality up to 192kHz) and within that timeframe I got NO skipped titles with Qobuz.
Do you also have some of these really good days?
Maybe Belgium and Munich, Germany are connected to different Qobuz servers?
The bad thing is that I don’t like Qobuz as much as Tidal. I’ll make some more tests.

1 Like

Hi @Peter_Kuehnel. Same experience here in Antwerp (Belgium). Skips using Qobuz are rare. I did the same as you: take a one-month Qobuz subscription just to test. Unfortunately, Qobuz has some rather big gaps in its music library, especially in the “alternative” genre (e.g. some albums are missing of Zero 7, Beth Jeans Houghton, Angel Deradoorian, Elsiane, Röyskopp, Dillon, My Brightest Diamond, Emily Wells, Ebony Bones, The Soul Snatchers, 8mm etc etc).
More and more, I get the impression that Roon does not really feel the need to give priority to solving the problem of all those experiencing skipping during playback. I suppose one of these days we will get another message with a copy-paste of some of the standard responses: sorry for the delay, the queue is longer than usual, can you please provide this or that, please bear with us a little longer…
What’s worse is that skipping during playback is a recurrent problem that has been reported many times over the last couple of years. I would expect Roon to either have tackled the root cause by now, or to have become efficient in trouble shooting and helping users who experience the issue.
The current situation is a long way from what is advertised: “Roon manages the music from all of your digital sources: TIDAL, Qobuz (…).” “Roon brings all your music together, so you don’t have to worry about where (…) you stream it from.”

Hi @Francois_De_Heel
Same here. Playback skipped on tidal songs (mostly). Roon support not yet responded.
Not sure if I want to renew my subscription if this is not resolved …
E

I’m looking at those logs from @Francois_De_Heel and @Esad_Brnicanin , and both point to “short reads”. Either TIDAL can’t deliver to you fast enough / reliably, or your network setup is interfering.

Just today, we’ve found yet another user who had a similar issue due to a VPN setup. I’m not saying that is your specific situation, but these errors in the log continue to point to network issues.

Unfortunately, there is nothing to do here in Roon.

That’s a valid option, but if you are streaming the same quality content from the same machine/setup, I’d be surprised if you didn’t have the same situation there.

A post was merged into an existing topic: Roon cutting out and changing through songs rapidly

Hi @danny ,

VPN is not used in my setup. I understand your reasoning that it is a network setup related, but the same setup was used since September last year, yet the issue only started recently since I upgraded to Roon 1.8.

… but if you are streaming the same quality content from the same machine/setup, I’d be surprised if you didn’t have the same situation there.

I have a dedicated NUC (ubuntu) with Roon core on it. I cannot stream Tidal from it outside of the Roon, it only has the Roon core on it. However, I used Audirvana for streaming from the same network (using my Mac) and I never had this kind of issues. I have other Tidal enabled clients in the same network and they never had this issue, they all happilly play HiRes content from Tidal.

1 Like

Then why can I play the exact same songs directly on Tidal when it happens on Tidal through Roon?

1 Like

And I didn’t have skipping issues playing Tidal through Sonos. I borrowed my girlfriend Sonos Port and set it up on a separate input to my audio system in the same room, same router and it never skipped in 2 weeks.

1 Like

Hello @danny,
from my point of view - sorry, for my direct speech - your answer and maybe the thinking behind it is exactly part of the problem! And maybe I’m wrong, but all the feedbacks we get here are…

In summary: issues with our network, our equipment, our whatever…

And I agree with you - I guess you are experiencing a lot which is not roons fault. Point taken.

But all the other Apps (because of this skipping title issue) do NOT have a problem and only your roon software causing trouble (my exierience and from many others too).
I really like your software, I’m a fan of it, I’ll try to be helpful, I like all the features and the idea of roon but I really have a problem with your roon support and that way of thinking.
I counted 42 people which are having an issue with that title skipping within 15days.
I’ll go through a whole month of threads and will provide the monthly figure. The first 42 names I have already noted.
I really think it is worth it to fight for a good solution and your programm is good (if it works).
All I want it is some commitment from roon for these issues. I don’t want to have it fixed in days, if there is a future. All I read so far is NO commitment, answers and feedback are by far not enough.
That’s at least my opinion.
And if it won’t help to address that here I’ll write to all German HiFi Magazines and people like Raphael Voigt which do a lot of for advertising for roon and I’ll ask them if they are aware of the situation.
Maybe letters to the editor sharpens your point of view.
Otherwise I’ll cancel this experiment - but it is NOT really my intention.
So, please help and tell your guys it’s an important issue, try to get Tidal involved because my point of view is also that there must be a reason for less issues with Qobuz (than Tidal). But roon has to be more robust. Sorry, I’m p…d, frustrated,…
Thanks.

Every time we actually dig into this, it’s always a misconfigured DNS, or bad router, or funny VPN/VLAN/setup issue. Always. It’s never once been an actionable change on our end.

For example, one recent user’s issue that was resolved by removing the VPN, was exactly as you describe. He has no problems before, he had zero configuration changes on his end, all he did was upgrade to Roon 1.8, and the TIDAL app works just fine for him, whereas Roon has networking issues.

Turns out he forgot he added a VPN and when he said the TIDAL app works, it was on a different device (mobile), and was that device was configured to stream lower quality streams.

Another person was sure it was 1.8 as well, but it turns out he was fiddling with DNS settings around the same time, and when he put back his DNS settings to default, all worked out. Again, it worked on his phone, because he was streaming over the cellular network using the ISP’s DNS, and not his local router.

This story repeats itself over and over. I wish I could fix something here, but I have no actionable information to do so.

Let’s try something:

Do any of you have a situation where you have a computer that is running a Roon Core and also the exact same computer is running TIDAL, and when you use either Roon or TIDAL to play to the exact same endpoint (via USB or built-in audio), Roon fails but TIDAL succeeds? If so, I’d be interested in seeing TIDAL app configuration screenshots and Roon signal path screenshots – I’d also like to see Roon Core logs from that failure.

You need to be playing the exact same content, and I want to make sure you have no networking funny business, which would include any firewalls, VPNs, VLANs, virtual machines, emulators, etc… Even apps like Little Snitch could be interfering (we had a user that once was throttling Roon traffic accidentally), so I want them out of the equation.

See above, too many variables. For all I know, your port was not streaming FLAC. Let’s get to the bottom of this by creating an apples to apples comparison.

Run your Roon Core on the same Mac and play the same music to the same outputs. Does it work?

The code for handing TIDAL and Qobuz streaming is identical. The only difference is how the stream is authenticated. The fact that more complain about TIDAL tells me that either this is a problem on TIDAL’s end, or than more people use TIDAL.

You also have to understand the extreme frustration when I pay my employees or take my own time to resolve these issues, only to find out that a user has been fiddling with settings they don’t understand or has left out an important detail about their setup, and that detail is the one causing the error. Or, when the problem is about a setting in a router, modem, or some additional gear / setup / configuration they’ve chosen.

Example:

I can go on and on…

but yah, read my post above and try to give me actionable information – do an apples to apples comparison, and give me screenshots and logs to help diagnose the issue.

Thank you @danny I really appreciate your feedback.
And I understand your point of view. But please understand also our issues as well!

As I stated I will really support and hope we’ll come to an positive output.

One point of course is that I cannot deliver a Tidal connect and roon results at the exact same time.
What I figured out is that Tidal server issues are sometimes happens for a longer period.
At least what I found out on German Tidal server outages webpages.
So when I discover issues with roon I’ll switch over to Tidal connect, I can always use the Roon Core PC also as an output for both Apps because a very nice highend stereo system is connected to the PC. I also have a friend which only uses Tidal connect to play music and never got these nice issues.

I’ll promise I’ll deliver everything.
What do you mean by Tidal connect App configuration - Could you please give me an hint what do you want to see - you’ll get it. Is it okay if the screenshots will be in German - shall I try to translate?
What do you mean by roon signal path screenshot?
Thanks for your attention.

Oh I see I’ve to follow up…

I agree, my thoughts as well. But why don’t you get in touch with Tidal, I thought you have a strong relationship. Or tell me how I can kick their ass. What I did so far is that I created a ticket Tidal outages and always if I experience outages from Tidal I create reports on an Downtime web page.
Trust me I’m not just in contact with roon.

I agree and I do understand.
If I made something completely wrong and I’ll or you’ll find out I’ll deliver a package of beer to you - hopefully this will be possible by internet. You can bet on it - even if I know beer is much more expensive in UK or US than in Bavaria.

[quote=“Titles Skipping constantly [resolved - deselected the Package Accelerator in Fritz Box], post:28, topic:150826”]
Guys, I did deselect the Package Accelerator in the Fritz Box and can confirm:
[/quote]

I doubt that and as you may have read I was personally in contact with AVM Fritzbox.
Fritzbox options only work for that session and will be reseted at the next router start.
Maybe a good day from Tidal server made that conclusion or AVM told me the wrong information.

I’ll try to do so and if I cannot deliver something I’ll get in touch with you.
Thanks for your support from a big music fan. :wink:

@danny

I installed the Tidal app on my MacMini core… but I can’t play both Tidal and Roon on the Macmini at the same time because Tidal will stop as soon as I start Roon (“Playback has been paused because you are playing to Roon”) What I can do is:
(1) launch a Tidal playlist from within Roon on my Macmini core (modem/router > eternet > Macmini system output)
(2) launch the exact same Tidal playlist using Tidal Connect on my smartphone (modem/router > wifi > Bluesound Node 2)
Would that be close enough to a ceteris paribus situation to be helpful?