TIDAL tracks not playing [resolved: 790 improved]

This is a good explanation, a simplified view is to think about an API as a contract between different pieces of software or online services. a made up Tidal example might be:

If you deliver this data (some precise form of user id and secret credentials plus track details) to Tidal, Tidal will offer you the track to stream/download.

That’s still possibly not that great/helpful on my part.

1 Like

Or if you think of software in an abstract way - UI (User Interface) is how it interacts with the user sitting in front of it (mouse, keyboard, display). The API is how it talks to fellow programs :wink:

2 Likes

This is the clearest simplification IMHO

@danny I double-checked. The “Regular Pleasures” track by Patricia Barber that skipped actually was a Qobuz track. It skipped almost immediately. While the next song, “Sweet Darling Pain [Alternate Take]” by Melanie de Biasio, was already playing, I moved “Regular Pleasures” to next in the queue and played it again… flawlessly.
As I have mentioned before, skipping in Qobuz also occurs sometimes, although very rarely (see test: Playback Skipped - #24 by Francois_De_Heel)
Maybe this complicates things even further, but I thought you should know.

PS: Today, May 8, around 12:00 at noon, I had another skip in a Qobuz track (“Ain’t No Sunshine [Live in Paris]” by Melody Gardot - played 25%). I am not sure this occasional Qobuz skipping has to be taken into account while analyzing the issue. So far, at least for me, skipping in Qobuz remains so rare that I consider it to be within the limits of what is acceptable.

1 Like

I can confirm that. I only have Qobuz and still experience tracks skipping from time to time.

[NUC8i7BEH 8GB RAM and Rock connected to Router Asus RT-ac88u, all 3 Raat endpoints wired to the router, no switches, Roon audio analysis disabled, small local files library. All software up to date]

My observations:
I have a Huawei modem in bridge mode (Telekom API internet.t-d1) through which I can track traffic in real time with HuaCtrl Pro.
For days everything goes fine, tracks are completely loaded right at the beginning with the usual speed around 100 Mbit/s and after that everything stays idle, download 0 until the next track starts.
(I set up this network just for Roon Rock, 3 wired Roon Raat endpoints and 2 remotes. For everything else I have a second DSL network with a different modem and router).

But then suddenly:

The download starts normally at the beginning of the track, but this time only with a maximum of 6 - 7 Mbit/s and then it stops. The track plays until the downloaded data is used up and then jumps to the next track. With this track, the same thing repeats, and so on, for about half to three quarters of an hour.
And that, although a speed test regularly checked for each track, results in a download rate of at least 70 up to 120 Mbps.
Which, however, are simply not requested/loaded by Roon.
Streaming via Qobuz directly at the same time works without problems.

So now my question @danny, @support:

What can cause such a continuous data consumption around 2 to 3 Mbit/s without peaks during these skipping times, almost consistently all the time?
As long as this behavior lasts, the tracks are not fully loaded but only a fraction.
Although the possible download rate would be far high enough and another player as well as the Qobuz app works and pulls the normal amounts of data.
As long as the continuous low data consumption around 3 Mbit continues, half to three quarters of an hour, Roon does not work without skipping.
As I said, audio analysis is off and there are no other consumers on this network.
Only Roon.
When I turn off my NUC Rock, data consumption stops immediately and drops to 0.

Same behavior, when I use my iPad not only as remote, but also as endpoint, all other raat endpoints switched off.

The Qobuz data point is useful information.

The data rates are a red herring.

I have a question about Roon and Tidal CDNs, since I’ve been experiencing strange Tidal behaviour in Brazil–but with Roon only, not the Tidal app. Does using Roon with Tidal change the Tidal CDN that is being used for the connection? For example, if the Tidal app is connecting me to a CDN in Brasil or a neighbouring country, is there any chance that when I am logged in through Roon that I might be connected to a more distant Tidal CDN–say in the U.S. or Europe?. I have no idea how this works.

The logs show that this happened because your Bluesound device fell off your local network. There is a known issue with this Bluesound device’s WiFi. I’d be interested if Qobuz failed while playing to system output. Until I see that, there is nothing to look into here. You can also try to use ethernet on your Bluesound for better reliability.

It’s all up to TIDAL, we don’t pick the URL to stream from, they do.

We may have identified an issue with their CDN (we are given a different mechanism to access TIDAL content that their app does not use), and are looking into a workaround while we work it out with them.

Hang on a bit…

1 Like

Thanks for the info. For what it’s worth, Tidal with Roon has been behaving better for me in Brasil over the past few days. As I noted in earlier messages, using a VPN resolved serious track skipping over a month or so for me. However, testing without the VPN again over the last three days has resulted in no skipping.

yah my guess is something funny is going on with the CDN down in Brazil… I have something in the works to deal with that failure case more aggressively.

Interesting. If I can help with tests or info, let me know. I’m in Salvador. I also have two ISPs in the house, so I can test with both.

@danny I hope you are making progress dealing with the Tidal skipping (CDN) issue. For your information, I would like to add the following. I have mainly been playing from Qobuz lately. As you know, skipping in Qobuz is rare (in my case), and, as you pointed out, is (sometimes) caused by the Bluesound Node 2 and its wifi-connection. However, there seems to be another problem too. I just had 5 Qobuz tracks in a row skipping (May 12, around 3 pm). I stopped Roon and rebooted the core/Mac mini. And everything is working fine again. There seems to be a pattern in this. After (many) hours of playing, Qobuz tracks will start skipping. After rebooting, the skipping stops. I guess there is no relation to the Tidal-problem. And I can understand if investigating this, is not a priority. It’s not really a big deal to have to restart the core regularly. But since you are working on the skipping issue, I thought I’d mention it.

See screenshot for the skipped tracks. The fourth and fifth tracks that skipped were “Koyaanisqatsi” & “Barry Lyndon”. I moved them to next in queue after the reboot. They played flawlessly.

Checked your logs, and for example, “The Rose” failed because the Bluesound dropped the connection with us. Before it did so, it reported that it was not getting data fast enough to play the stream reliably. That tells me that the network was doing just fine and the problem is inside the Bluesound itself.

We’ve seen this issue when streaming from Roon to the Bluesound “2” line. The “2i” line is a lot more reliable in this regard.

3 Likes

Roon ‘endpoints’’ vary in quality.

Some work seamlessly. Others don’t.

Maybe it’s a case of ‘You pays your money, you takes your choice’?

Shouldn’t be, “Roon Ready” means a device has passed rigorous testing, nothing of cost.

2 Likes

Roon Ready is not an exhaustive QA process of every aspect of the device. It just means the streaming quality has no compromises and things like UI/UX are the best they can be. Also, we get the signal path to be as transparent as possible and the settings optimized for bit perfect transmission/reception.

If WiFi is limited to 2.4ghz, or the implementation is flakey in some circumstances, that is not something Roon Ready covers. There are thousands of other cases that Roon Ready does not cover.

It seems that indeed, when Qobuz tracks skip, in my case it is related to the Bluesound Node 2 over wifi. I played a 44-hour Qobuz playlist to the system output of my core. I had one skip on 632 tracks. Hardly worth mentioning. Since I can’t connect the Node by ethernet and I don’t use its DAC anyway (I have an external one), I will probably replace the Node with a Raspberry Pi to improve my Roon/Qobuz experience.
And I hope your efforts to find a solution for Tidal skipping will be successful and improve my Roon/Tidal experience too.

I wonder if something changed in the interface between Roon’s ops and Tidal, based on what @danny said, as I have not had any Tidal skips for several days now.

(I wish I hadn’t said that… :man_facepalming:)

Seems to me that the Roon team has done a great job solving the Tidal skipping issue (I was one of the beta testers of the new release and tested it extensively: at least for my setup and location: no more skipping). Thanks & Congratulations to @danny, @dylan, @noris, and all the others that were involved!

6 Likes

A post was merged into an existing topic: No appropriate error-messages from Roon