TIDAL tracks skipping and not importing any local media[Solved]


I used to be able to play both TIDAL and local tracks, but after a recent upgrade of Roon - I no longer can play either TIDAL or local media files. I cannot pinpoint this necessarily to the Roon upgrade, in the meantime there were some Windows 10 upgrades on the computer.

At this point I have Win 10 with the latest 64bit Roon 1.1 (build 88). All TIDAL albums and tracks are imported and visible, but when I try to play any album or playlist - it just skips quickly through the tracks.

TIDAL plays OK through teh native TIDAL browser interface on the same computer.

In addition - it does not seem to show any local media files. I have for example FLAC files in all Roon monitored locations (Music Folder, additional custom folder, Roon folder). They do not appear in the focus search inside Roon and there is no other way to know if they were really detected. This also used to work before.

I have a second computer, also Win 10 that connects to the server as a remote PC. It shows the same issues as the server.

Any help will be appreciated.


OK, after some investigation I think I figured out the issue. I have Windows “N” version, so I installed the [Media Feature Pack for N and KN versions of Windows 10][1].

This solved both the TIDAL play issue and the local media import issues.

Interestingly, this was working with previous versions without the need for the “media feature pack”.

[1]: https://www.microsoft.com/en-us/download/details.aspx?id=48231

Hello @George_Emilov, glad you was able to sort out this issue, I’ll mark this thread as Solved. So, it may help other users who use identical OS.

Best regards,