Tidal transport failure

Hi. I have an issue with Tidal transport now. Since build 1.5, I cannot play tidal anymore. When I click on any song from tidal, I can see the length of the song from the bar but the music won’t progress, I can just see the blue bar moving left and right for about 3 cycles and the playback will simply jump to next song. After several jumps, I got the system message: Transport: too many failures stopping playback. I have rebooted my router and restart my tranport device several times. I also checked tidal connectivity on my computer and it works well. I am sure in Roon build 1.3 tidal worked well for my transport. My transport device is Rockna Wavedream NET.

Everything else of Tidal works well including the merge of the library and other functions. The problem is just the basic playback.

When playing local files, the Roon Advanced Audio Transport functions well.

Hello @Kaiwen_Zhao — Thanks for sharing this report with us, it’s always appreciated!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

May I also ask that you verify the following:

  • Does this happen for all zones, or just one? If you play to system output, do you experience the same behavior?
  • Have you power cycled your Core machine?


Both my roon core device and win10 roon remote are
Version 1.5 (build 233) 64bit
My roon core device is Rockna Wavedream NET, My PC is Win10 64bit (which is unrelated to this problem I Believe).
I have power cycled all the electronic device involved. Also, this problem happened in all zone. I have tried system output and other zones.
In build 1.3, the tidal playback functioned well. Since the message is transport: xxxx,I guess the problem is caused by new build of roon core software.
Thank you.

Thanks for the update, @Kaiwen_Zhao.

May I also ask that you please describe your networking setup? What kind of router are you using? Are there any switches involved? Is your Core machine connected via WiFi or a wired connection? Have you also rebooted networking hardware?


The network setting is A TPLINK AC1200 router connected with NetGear GS105 switcher. And my PC and Roon core device are connected to the switcher. The setup is the same as when I was using Roon version 1.3 last year at the playback of tidal was functioning.

I have tried software of Tidal on my PC and it works well.

Thanks, @Kaiwen_Zhao.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you check to see if you have any antivirus or firewall running, and if so, try disabling them?

If the above does not yield positive results, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


I just checked that Roon is allowed to communicate through firewall of Windows. So the technical diagnostics should be feasible.

I have exactly the same problem like describe Kaiwen_Zhao. I’am suppose that this is problem rather with roon-tidal interaction than my firewall/router issue.

That must be the problem with the Roon core software. I believe the connection is OK since I can see the duration of the songs. Perhaps it is the problem of buffer or something else. The firewall has nothing to do with the core part because it can only affect roon remote in my PC. I guess they asked me to turn off it because they may want to check the logs of error which may store in my PC.

Hey @Kaiwen_Zhao — Thanks for confirming that for me.

As mentioned above, may I kindly as that you please reproduce the issue once more and note the time at which the error occurs. Having a timestamp will help isolate when the behavior happened so the technical team can review the diagnostics report for that time frame. Please respond back with a timestamp and I’ll send the diagnostics report over to the technical team for analysis.


Oh, I thought that I just have to turned off my firewall so that you can make diagnoses on my account.
So I am using a win10 pc running room remote 64bit version 1.5 build 233. My transport device is Rockna Wavedream NET running ronn core 64bit version 1.5 build 233.
The problem starts after roon version 1.4. I can log in tidal on roon, check tidal musics and add musics to my library. When I try to play a tidal music, I can see the duration. However, after a short blue bar moving left and right for 3 times in the progress bar of music, it will jump to next song and after several jumps, I will get system message “Transport: too many failures, stopping playback”.
I have rebooted all my devices including router and switcher. I believe it has something to do with the roon core software after version 1.4 because everything worked well before, and the system message told me it is the problem with the transport meaning it happens locally inside the roon core software running in my transport (definitely not the problem of internet connection).
Thank you.

If you mean the exact time of error message, that will be in these two days for several times I tried. It did occur at version 1.4 but I didn’t care about that at that time. I just triggered the error message again at 7:43 pm May 22nd so that you can have the technical team look upon it.

I have reproduced the issue and given a timestamp above.
Is the technical diagnose available now?

Thanks, @Kaiwen_Zhao!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

It is active right now. Do I have to turn it off at once?

Hey @Kaiwen_Zhao

No, that won’t be necessary. I just wanted to confirm that I have verified that the diagnostics report has been received on our server. I am passing it along to the technical team for analysis. I will update this thread as soon as I hear back from them.


Thank you so much.

1 Like