Tidal via Roon ready Auralic Vega G2 working slowly

Core Machine (Operating system/System info/Roon build number)

Asus mini desktop 2018, Windows 10 last version, Roon last version. Roon for Ipad app.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

High speed ethernet network (500 mbps), same high quality ethernet cables from Roon core and from Auralic Streamer Vega G2 both computer and streamer directly connected to the same ZTE router 2019 model.

**Audio Devices Auralic Vega G2 Roon ready. Ethernet only.

Description Of Issue

TIDAL (MQA and normal TIDAL records) is working slowly all the time and jumping to the following song inside Auralic Roon ready.

This problem doesn’t happen with QOBUZ within Auralic Roon ready and with local files (including DSD 512 and less). And TIDAL works perfectly at Roon core and in Auralic Lightning DS last version (outside Roon ready Auralic).

Many thanks. Kind Regards. Diego

Hello @Diego, and welcome to the community! Do you have issues playing TIDAL from system output of your core machine?

Hello Nuwriy, thanks for your kind answer. I am listening now to Tidal and Roon from Roon Core via USB to Auralic Vega 2. No problems for the moment. Tidal running slowly connectivity problem, and a few times Qobuz today, happens only by Auralic Roon ready directly connected by Ethernet. The problem is more notorious in the evenings than in the mornings.



Well the problem is also happening via Roon Core. The streaming from Tidal cuts and goes to the next song. Cheers

Hello @Diego, and thanks for the information! Do you still have issues if you lower the streaming quality under “Settings>Services>TIDAL”? Have you switched to Google or Cloudflare DNS to see if this helps? Please let me know!

Well, lowering the streaming quality is never an option for an audiophile…!! :slight_smile:

I installed yesterday Google DNS (Cloudflare still not available for Windows) and it seems to improve, almost no interruptions, I will continue listening today. Thanks a lot for the suggestion! kind regards.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.