Tidal won't configure on Roon | Settings | Services [Solved: Power cycle]

I have a Tidal subscription I bought from Best Buy. It worked or a while, but now it will not configure in ROON. I can log in to it on the Tidal site with no issues. When I click LOGIN for Tidal in Settings | Services it takes me to a dialog box that offers LOGIN or START NEW TRIAL. I click LOGIN and it takes me to www.login.tidal.com which offers up my correct login email address and offers YES, CONTINUE or NO, SWITCH ACCOUNT. When I select YES, CONTINUE, it takes me back to the the prior screen with a notice that THERE WAS AN ERROR AUTHORIZING WITH TIDAL. UNEXPECTED ERROR. PLEASE TRY AGAIN.

I can try again as many times as I want with no change. I went to Tidal.com and changed my password to a simpler one and logged in fine with it at tidal.com. I came back to Roon and tried to log in with the new simpler password, and same error message.

Have you checked you can stream from tidal itself, rather than just logging in.

Yrs, I can stream any titles that I choose. Just finished listening to Bob Dylan’s double album Springtime in New York.

Hello @Lee_Dickinson,

Sorry to hear about the trouble :sweat:

Could you please reboot your Roon Core?

  • quit Roon
  • turn off your Roon Core
  • unplug it for a few minutes
  • plug it back in
  • turn it on
  • launch Roon
  • try to enable TIDAL in Settings → Services

Thanks a lot :pray:

1 Like

I would also remove the service from Roon before doing what Rebeka suggested.

Well the power off cycle did the trick. Thx @RBO and @beka

Reminds me of the joke “What does Bill Gates do when his car won’t start? - He gets out and gets back in.”



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.