Tidal won't play at all

Core Machine (Operating system/System info/Roon build number)

QNAP NAS, LATEST ROON

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ALL ETHERNET

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

APPPLE TV - TV - BENCHMARK DAC

Description Of Issue

I have just paid for Tidal and extremely frustratingly its not working. I am logged in, and I can search the catalogue, but if I press play, it looks like its playing because there is the little graphic moving by the relevant track name, but no sound comes out and the little cursors showing the elapsed time does not move at the bottom which shows its not moving. I was super excited about this integration, and I am coming back to Roon after some years because I got so angry with its handling of classical meta data and now I can’t believe its still so buggy… Tidal works fine streaming to Apple TV from either my phone or from its website… come on Roon

I have cleaned the cache and it makes no difference. I have had two previous instances of tidal trials installed on this build (assume irrelevant if I have cleared the cache).

In my database there are three folders overall, RoonServer, RaatServer and Roongoer. Is that normal? What are these folders?

Since I wrote the above I completely uninstalled the core and reinstalled and the problem remains. I am so annoyed… and now if I log into Roon remote on my phone it logs me out of Roon on my MacBook and vice versa. Its a damn mess. What the hell is going on

Hello @DelPrado,

Sorry about the frustrations… let’s get this fixed.

A. I have seen some reports of issues with the AppleTV having issues verifying AirPlay cleints. Try going to AppleTV settings > AirPlay & Homekit > Allow Access and set it to “Anyone on the Same Network” and “Require Password” set to “Off”.

If this doesn’t resolve the issue, try setting “Require Password” to “On”, setting a password, and then enabling the zone in Roon. Roon should prompt you for a password when this occurs.

B. If you’re still unable to get playback to work, I would be interested to know if you can play to the “System Output” of a Mac or PC. This will tell us if the issue is between Tidal and Roon or Roon and the AppleTV.

-John

Hi John I already tested that, it won’t work playing to the Mac either. Like you I quickly thought of ways to narrow down trying to understand where the problem lies. Its a very peculiar error. Can I upload a video which shows it?

Is this the support I have paid for? Its still not working. Is this all the support there is!?!?!?!

Hi @DelPrado,

Thanks for confirming that the Mac output does not work either. I suspect that there is something specific to the QNAP preventing playback from starting.

As a test, can I please ask that you try to temporarily host your Roon Core on the Mac and verify if you have any issues starting playback with the Mac as the Core?

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Thanks!

Finally, thanks for responding Noris. This appears to have been the problem. Tidal now works if the Mac is the core.

Is it possible to investigate what the issue is with QNAP? Has this problem occurred with others cores from users reporting?

From now on I won’t use the NAS however. How does database (not the files themselves, I mean the database which is backed up) work now I have moved the core? Is it in the same place?

How do I properly remove the NAS from the whole set up?

Same question to some sort of weird auto log in on TIDAL too through Roon, I made the mistake of signing up for an account via apple initially and although tidal told me it got deleted I still get one of those weird apple emails trying to log in when I manually log out as I did a moment ago to refresh it after changing the core.

Hi @DelPrado,

Thanks for getting the QNAP out of the equation and for confirming that the Mac works as expected!

The person best suited to troubleshoot QNAP specific issues is @crieke, but I would start off with taking a look at the firewall and/or re-installing RoonServer on the QNAP (after making a Backup).

I’m not sure I understand this aspect, can you please clarify?

You can follow our Migration Knowledge Base Article for instructions on how to transfer the database over, once you restore the database, you’l also need to add your NAS as a network share, instructions on this can be found here:

Hope this helps!