Timeline problem

Hello…,

Recently, the red line on the timeline is no longer in sync with the music.
My setup consists of a sonicTranspot 7i from Small Green Computer with the Roon Core and the HQPlayer Embedded on it. From there it goes to the La Rosita Gamma with on board the Micro Rendu and the DAC of La Rosita. For PCM I use the L-filter of the HQPlayerd configuration and it gives a delay of about 5 seconds. This means that the red line is on its way for 5 seconds before music is heard. But now it is suddenly different. It takes at least 10 seconds before the music starts and after this the red line starts after 5 seconds. This only happens when I select the track. When the next song starts there isn’t that long time gap but the red line is still 5 seconds behind.
This event is not due to a change in setting.
What have I tried:
I have rebooted both the Micro Rendu and the sT with HQPlrd and had the sT update the HQPlayerd as well. None of that helped.
Has anyone experienced this before and perhaps found a solution for this?

Greetings, Bert Dijkstra.

Depending on you HQP settings, HQP can introduce delays. Once Roon has handed it off to HQP, it is no longer in control, HQP is.

Try removing HQP from the playback chain, is the issue still there?

Hello Daniel,

Thanks for your quick reply.
I had already seen your solution on my own because I have an other setup with Roon but without HQPlayerd. This setup is not affected.
I am aware of delays due to selected filters in HQPlayerd and certainly the L-fiter gives a delay of more than 5 seconds. The red stripe moves 5 seconds before the music is heard. I was used to that. But now the red line starts only 5 seconds after the music starts. So it must be a malfunction related to the HQPlayerd. This disturbance came on suddenly.

Hello…,

Help…
Am I the only one with this problem or worse: is there no solution for it?
Yesterday the following happened: The music was played but the timeline remained at zero throughout the song. Is this the beginning of a completely useless timeline?
What did I do right next: An update of the sonicTransporter which also updated HQPlayerd to 4.20.1. That did not solve the problem but the red stripe runs again 4 seconds after the music has started.

Greetings, Bert Dijkstra

Hello @Bert_Dijkstra, and my apologies for missing this thread. Have you reinstalled Roon since this happened? Are you seeing it on other devices with HQPlayer disabled?

Hello Newriy,

Thanks for reacting, and maybe we find a solution.

I’ve two audiosystems served by Roon. The small one is without HQPlayerd on the same network as where the main set is connected also served by Roon but together with HQPlayer.
The small setup works without the problems of a delay with the little red bar on the timeline. The main set has this problem with the little red bar. I start the music and have to wait for 5 seconds before the music really starts (because of the L-filter I use in HQPlayer configuration and which is normal) and then I have to wait 4 seconds before the little red bar starts, and that was not what it was used to do. So, no I don’t see it on the other device without HQPlayer.

Greetings, Bert Dijkstra.

Hello @Bert_Dijkstra, could you please elaborate on your network setup for me including how your core is connected to the network and the model number of your router, and any switches in between? Also, does this issue happen with any type of content you play? Streamed and local?

Lastly, I’d like to have you reproduce the issue one more time, and please reply here with a timestamp when you do (the date and time you encounter the issue) as well as the track name you experienced the issue on so I can enable diagnostics for your account?

Hello Nuwriy,

First my network setup:
Core machine:
sonicTransporter i7 server, OS Linux, with Roon Core and HQPlayer Embedded installed
SSD-disk 2T connected to sonicTransporter
Streaming device with dac:
La Rosita Gamma HD with NAA microRendu
Connections are LAN from modem/router Arris TG2492LG-ZG and router Fritzbox! 4040 (for WiFi to iPad) using switch from D-link via server to streaming device
This issue happens only when I transport music to the streamer with the NAA microrendu. This is the line from HQPlayer and it’s only with local content. I’ve got two other setups working with Roon without HQPlayer but they’ve got no problems with it.
But in the beginning of this week it’s getting much worse: Roon can’t connect to HQPlayer anymore and the sonicTransport don’t want hardly to mount my usb drive with music (last time I needed 5 minutes to mount (what will it be next time, a day?) and from the beginning of 2019 the sonicTransport tries to reboot from this usb drive so I have to remove it every time I have to reboot. But with this mounting problems I don’t dare to update, reinstall and reboot. Andrew from Little Green Computer and Jussi from Signalyst/HQPlayer give vague and evasive answers.
At the end I can’t play music with my top setup to my audioset.

Thanks for reading my lamentation, Bert Dijkstra

Hello…,

Thanks all for helping me. I just got my HQPlayerd working. Hopefully for a long time. I did write a manual how to reinstall HQPlayerd on a sonicTransporter. You can find it in the Topics from HQPlayer. The reinstalling also ensures that you don’t have to reboot, you will automatically get the latest update version.
Unfortunately the music is still not in sync with the timeline with the red bar and the timer. Jussi says that’s normal but I don’t think so.
How is that with you?

Greetings, Bert

Hello Nuwriy,

Now I can make a timestamp but not sure what that is. When I start playing a track I must notice on what time and write it here: album name, track number and the exact time?

Hello Nuwriy,

I couldn’t find information about the meaning of a timestamp so I hope the next information will help you.
Last evening (19 January) I played the next tracks with all the same issue:

  1. 21:15:25> Regina Bastarda/ Paolo Pandolfo track 1
  2. 21:18:20> The String Quintets/ Klinke Quartet with Harald Schonewege disk 1 track 1

Hopefully you can work with this.

Bert Dijkstra