Timing of a zone I created is off. Can I adjust?

I noticed today that while creating a zone with my Bluesound Node 2i and my Denon receiver in living room using Airplay on both because the Denon isn’t Roon ready that the timing was off. Is there a way to adjust this so get them to match up?

It depends on why they may be off.

What’s the signal path of each. There are certain things in timing Roon cannot account for (like room correction in your Denon?) and when that happens there is this setting…
Look for “Zone Grouping Delay”

Or you can turn off the things that Roon doesn’t know about (like room correction)