Titan can't find my NAS/Backups won't restore

I recently bought into the Titan-Nuc+ swap. The new Titan won’t recognize my NAS and I cannot restore any back ups. I have submitted tickets to Roon, but they ain’t in a helpin’ mood.

Set up: Router is ethernet connected to Nuc+/now Titan and QNAP NAS. Nuc+/now Titan is USB connected to 16 GB external hard drive. I have music stored on both the NAS and the hard drive. WiFi connects my router to my three endpoints: Eversolo DMP Master, NAD700C, BluSound iNode 2. I use the Nuc+/Titan as the core, but do set up on a MacBook Pro. I keep backups on both the hard drive and on the NAS.

Problems: Following instructions, I just substituted the Titan for the Nuc+ in the set up. Titan recognized the hard drive, but not the NAS. I then tried to restore the latest backup on the hard drive, and this failed. I tried several older backups on the HD, and these all failed. So I went to “storage” and rescanned the entire HD (this took a day because I have 17k albums and 400k music files). The files are now on Roon, but not organized as I want them (I expected this). I have tried since to restore various backups, and they still will not. I am now trying hard reboots.

Can someone tell me what I need to do to get Titan to recognize the NAS? This may simply be that I don’t know how to do this. Is the problem with restoring backups just me, or is it widespread? Does anyone have a solution?

Thanks

Have you followed the steps given in this help article about using a NAS?

2 Likes

Hey @Geoffrey_Braswell,

Great to see you on community again, and congrats on the new Titan! Following up on @Geoff_Coupe’s note, I’d also be curious to review the list of IPs within your local network. Can you confirm all Roon devices - your Titan and your Nas, are on the same local subnet within your network?

You can typically review all your devices by accessing your router settings. Let me know!

Hi Benjamin – I am not sure if they are on the same “subnet” because I am not sure what that is. But when I login to my router, the Titan and the NAS are both listed as “Wired Clients” on the router, and when I open the Finder on my Mac and click on “Network” it lists “nucleustitan” right below the NAS, not in some different subdirectory of the network. Moreover, I can open both of them from the same Finder window in Mac, but the Titan just doesn’t recognize the NAS in Roon. I can play music in the HD attached to the Titan using Roon on my computer, so clearly it is on my network. Does this answer your question?

I am not sure if this matters, but the IP addresses for the Titan and NAS differ only after the final period. My router also lists “Wireless Clients” and my three endpoints are there, too. So the router sees everything on my network, including the Titan (of course it does, or I wouldn’t be able to connect to it from my computer or play music on the external HD).

Also – Do you have any idea why none of the backups will restore for the music on the HD? Half the time, it gets to 1% before crashing, but most of the time it simply says “Backup Restore Failed” or words to that effect. Actually, this is the bigger issue because most of my music is on the HD ethernet connected to the Titan.

I am close to sending the Titan back and asking for a refund.

Benjamin – I see you were in contact with someone named BostonX four days ago with one of my problems; it wouldn’t restore the backups. He tried several times to do hard boots and finally got it to work. I have tried hard boots about 5 times with no luck.

Is this a common problem? I am thinking there is something wrong with the Titan.

Hi Geoff – Thanks, but isn’t this for a new NAS setup? Mine has been up and running with a Nucleus+ for nearly four years. So my NAS is configured for Roon. The Nuc+ worked with it. The problem is the Titan.

Yes, but you will have added the network path to the NAS on your Nucleus a long time ago, and now you need to do the same for your Titan - have you actually done this?

Hi Geoff C – I think I have tried this. On my Mac, I have enabled File Share. Then I go to Roon: “Storage > +Add folder > Add network share.” Is this correct?

I put in my Network share location “smb://NASxyz/MUSIC” and then my Username (for the NAS), and then the Password (for the NAS). I click “Add network” and then click “Add network share.”

After a pause, I get a red bar that says “UnexpectedError.”

Am I missing something in this process? Thanks --Geoff B.

Hi Benjamin – This is a followup and I am hoping for some technical support before I send the Titan back because it is defective.

(1) Failure to recognize NAS: I have made sure on my MacOS that file share is on. I go to Roon, Storage > +Add folder > +Add network share. Then I type in the network share location in either format, i.e., “\NAS39DFE5\MUSIC” or “smb://NAS39DFE5/MUSIC.” Then I add the user name for the NAS and the password. After a few seconds, I get a red banner “There was an Unexpected error.”

(2) Failure to restore backups: I have an external HD ethernet connected to the Titan. My backup files are stored there (as well as on the NAS which is not recognized). I go to Backups > Find backups [browse]. This opens a window to the correct folder on the HD, which is called RoonBackups. I click on “Select this folder” and my last 10 backups to the HD appear. I click on ANY of the “Restore” buttons for the backups, and I get “Restore failed. Please check your backup folder and try again,” although sometimes it gets to 1% before it fails. I have tried reloading the Roon OS, rebooting, and even hard reboots. Always the same results.

I wish there was some sort of ACTUAL technical support for Roon, especially when a hugely expensive piece of equipment is purchased. I see that others (BostonX) have had the same problem with backups. Can you please let me know what is going on?

I really need help in trouble shooting this. If you can’t help me, could you please at least tell me who I need to write to in order to get this hunk o’ junk replaced?

Hey @Geoffrey_Braswell,

Thanks for the follow up and I’m sorry to hear you’re still having issues! It sounds like your Roon devices are all on the same local subnet, so that’s good news.

We were able to review a fresh diagnostic report form the Titan, and don’t see any immediate Titan related issues, so I’m confident we can get things sorted out for you. I’ll break down more of the errors we’re finding below:

  1. Failing backups on your External HD. What is the HD formatted to? From the report, we see the following error:
Warn: [broker/backups] restore first half failed on FileBrowser.Entry:  Roon Drive, WD Elements 25A3 : /RoonBackups: NotAvailable
Debug: [broker/backups] on done, auto: False, result: Result[Status=NotAvailable]

Are you able to hook up the HD to a Mac/PC and check the format? I’d also potentially make a copy of your backups folder and save it to your desktop just to be safe. Any reformatting of external drives typically wipes the contents, and we certainly don’t want that!

Let me know the format - Nucleus tends to work best with ExFat formatted external drives.

  1. Failure to recognize your NAS - seeing the error log below:
Warn: [roon/cifs] failed to connect to CIFS storage: Operation now in progress
Debug: [roon/cifs] tryremount, path: \\NAS39DFE5\MUSIC,

It seems your Titan is getting stuck in other operations while it’s heavily analyzing tracks. Likely from:

If you head into Roon Settings>Library> and turn off all analysis, stopping all other processes occurring with your Titan, do you run into the same issue?

With that, what happens if you attempt to connect to your NAS one subdirectory earlier? So rather than \\NAS39DFE5\MUSIC you would try \\NAS39DFE5\

Overall, I would triple-check to confirm you have all the proper shared settings applied to the NAS as well.

If you’d like to return the Titan, we can ping @accounts to get this process started.

Hi Benjamin – I started with the second issue, the NAS.

I went to Settings > Library and turned off the analyses. I then tried to connect to the NAS one subdirectory earlier. I tried both the \ and smb method. It still doesn’t work. SO WHAT NEXT?

Again, It all worked worked with my Nuc+, why not with the Titan?

I am working now on the HD issue; it is 16TB, so every time I move it, it takes some time to check itself and become visible. Meanwhile, please solve the connecting to the NAS problem. It wasn’t analysis.

Hi Benjamin – The external HD is ExFat. So that is not the issue with that problem, either.

WHAT NEXT?

I have copied the Backup files to my computer desktop. Is there a way to access this and conduct a back restoration while still using the Titan as the Roon core?

Both of these issues were not a problem with the Nuc+, so it is something about the Titan that isn’t working.

Hi @Geoffrey_Braswell,

Thanks for the update, our team is taking a closer look into things and I should have more information to share soon.

In the meantime, are you able to access the webUI of your Titan? Here’s more info on this:

If you could share a screenshot, that would be helpful as well. Thanks for your patience while our team takes a closer look. :raised_hands:

Hi @Geoffrey_Braswell,

Our team took another look, and saw additional errors in relation to the failed backup:

Error: [backup] failed to restore: getfile by hash, dirs: AttachedDir:/roon/sys/storage/mounts/Roon_Drive_WD_Elements_25A3_334847575636364E_64CC-2A8A-p1/RoonBackups/4c284947-288a-ee46-ba0a-163c8668df57/13/3f

So it looks like a file is missing from 3f folder specifically. Can you confirm the current health of your external drive?

Yes, absolutely, and this is something we’d like to test next. You can add the backup folder to your Titan using a network share. Here’s all you need to know:

Follow the steps to ensure the folder on your desktop is set up with the proper share access. Once you do that - don’t add it as a watched folder, head to: Roon Settings>Backups>Find Backups - Browse> + Add Network Share

Another option to test: If possible, could you boot up your old Nucleus+, and create a fresh backup to a separate location, not tied to the external HD, and attempt to restore the backup to your Titan from the new location?

Let me know how the restore process goes for either of the above. :+1:

Hi Benjamin – I copied the backup from my (unrecognized by Titan) NAS to my external HDD in order to deal with the missing file from 3f on the HDD backup. (Apparently, that same problem exists in all 10 backups–so it isn’t an issue with a single dead spot on the HDD. Is the backup process only partial, ie completely new files are not produced each time?) I then reattached the HDD to the Titan and restored the backup that had been on the NAS – Voila! My files were restored the way they should be. Problem #1 solved.

But that is not ALL that happened. Suddenly my NAS is visible and connected, too! The backup process not only restored file structure/appearance, but also network connectivity–I had no idea a backup also saved those settings. Even my backups are automatically re-setup. However, Roon no longer thinks I am using a Titan, and instead is labelling the core as the old Nuc+. Whatever, as long as everything works and it does!

So I eat my words–there is nothing defective about the new Titan. I won’t pretend to understand how backups and restoring work, but clearly there is more going on than simply copying the library data in its entirety each time a backup is made.

Thanks for your help and patience! --Geoff B

1 Like

Hi @Geoffrey_Braswell,

New files are indeed produced each time, which leads me to think the issue could be related to the health of the external drive.

Great news! I’m glad to hear it.

What if you head into Roon Settings>Setup and change the name of your Roon Server name?