Too many failures. restarting server doesn't work

Roon Core Machine

synology nas 1621+

Networking Gear & Setup Details

10g network

Connected Audio Devices

windows pc

Number of Tracks in Library

150k

Description of Issue

Roon all of a sudden can’t play any music. I’ve tried restarting the server twice, and disabled and reenabled the audio device and that didn’t help. I don’t think roon server is generating any logs either so I can’t even look into why it’s happening, but then again I’m a customer and not a dev. I should be listening to music, not trying to debug this stuff.
here’s some logs that may help

07/09 10:27:50 Trace: [System Output] [raatclient] SENT [7]{“request”:“setup”,“format”:{“sample_type”:“pcm”,“sample_rate”:44100,“bits_per_sample”:16,“channels”:2,“sample_subtype”:“none”}}
07/09 10:27:50 Trace: [System Output] [raatclient] GOT [7] {“status”:“UnexpectedError”,“message”:“RAAT__OUTPUT_PLUGIN_STATUS_FORMAT_NOT_SUPPORTED”}
07/09 10:27:50 Info: [zone Office PC] OnPlayFeedback Playing
07/09 10:27:50 Trace: [Office PC] [Inactive] [PLAYING @ 0:00] Sanctuary - Arca / Ryuichi Sakamoto
[zoneplayer/raat] failed to setup any endpoints…giving up
07/09 10:27:50 Info: sleep 0ms after flush
07/09 10:27:50 Info: [audio/env] [zoneplayer → stream → endpoint] All streams were disposed
07/09 10:27:50 Info: [audio/env] [zoneplayer → stream] All streams were disposed
07/09 10:27:50 Warn: [zone Office PC] Track Stopped Due to Error
07/09 10:27:50 Info: [zone Office PC] OnPlayFeedback StoppedEndOfMediaUnnatural

I’ve restored from a backup and the same error is happening.

More logs captured right a time I tried got the error again:

07/09 10:54:15 Warn: [analysis] failed with exception for trackid=28908594: Sequence contains no elements
07/09 10:54:15 Warn: [analysis] failed with exception for trackid=28917298: Sequence contains no elements
07/09 10:54:15 Warn: [analysis] failed with exception for trackid=28916530: Sequence contains no elements
07/09 10:54:15 Trace: [Office PC] [Inactive] [PAUSED @ 1:24/3:21] Castration - Arca
07/09 10:54:15 Warn: [analysis] failed with exception for trackid=28917554: Sequence contains no elements

07/09 10:54:31 Info: [Office PC] [zoneplayer] Playing: /var/packages/RoonServer/target/roonmnt/data/media/music/Organized/Arca/Arca/06 Castration.flac
07/09 10:54:31 Warn: [analysis] failed with exception for trackid=30084146: Sequence contains no elements

It seems the “Sequence contains no elements” error is the cause of all of this. Why is this happening? It should be streaming it from qobuz btw

And what is that audio device that doesn’t support 2-channel CD format? Please check your Windows audio settings too.

Doesn’t look like that to me.

I’m using the default windows playback device. I switched to a direct wasapi connection to my grace m9xx and made sure to select an album directly from qobuz. It’s still happening. here’s some more logs, thanks for helping.

07/09 11:08:59 Trace: [HD 800s] [Inactive] [LOADING @ 0:00] Part I - Keith Jarrett
07/09 11:08:59 Warn: [analysis] failed with exception for trackid=16874290: Sequence contains no elements
07/09 11:09:07 Trace: [XMOS USB Audio] [raatclient] GOT [13] {“status”:“UnexpectedError”,“message”:“RAAT__OUTPUT_PLUGIN_STATUS_FORMAT_NOT_SUPPORTED”}

got any ideas?

For what it’s worth, using that same connection - wasapi to grace dac, using qobuz gives me no trouble whatsoever. It just plays immediately. Using foobar to play directly from smb works without a hitch either

Another interesting thing - I just tried using the ASIO connection on my dac and that actually works.

So what is it now that doesn’t work? The default output device (in Roon) or the direct connection?
Note: Using a direct connection (in Roon) to the default audio device of Windows sounds like a bad idea to me. Please avoid that.

Your Windows is obviously configured to not accept the format Roon tries to use.

Configure Roon/Windows to match capabilities.

Also please post screenshots (Roon audio device settings, Windows audio device and format settings).

Most-likely just get auto-converted by Windows.

thanks for the help

neither work

what do you mean?

Posted the screenshots. What do you mean configure roon/windows? I’ve done that and it was working fine yesterday. Today when I try to play some music, it’s telling me too many failures. That’s why I made this tech support request.

Yes it seems that there’s some issue between my pc and the core. I just tried on my macbook and it’s playing from there.

latest driver settings;



roon audio zones

windows sound settings

btw, nothing has changed, it just randomly stopped working. I haven’t had any updates to windows, I haven’t made any changes to my drivers, I haven’t made any changes to my network switch settings, I haven’t made any changes to my router’s configuration.

Your Windows Mixer seems to be configured to accept 192kHz audio but from the first example you can see, that Roon tries to send 44.1kHz. That’s why you can’t play. You may have to activate Roon’s sample rate conversion to make it work.

Maybe another playback program did? IDK but IIRC 48kHz is the default for the Windows mixer (not 192kHz).

I actually tried toggling sample rate conversion on and off - like i’ve said before, this same exact setup was working before with no errors.

I’ve fixed the problem on my own: I reinstalled the grace driver twice. Same version 4.11.0. same revision v2.0.4. So the question is, why would other software have no problem playing, but Roon begins having problems seemingly out of the blue? Why does a driver reinstall help? I guess we’ll have to wait to hear from tech support to dive deeper. This was a total waste of time that I wanted to spend checking out new music. I don’t want to repeat it

@BlackJack Thanks so much for the comments

huh, it happened again. Why has no one from supported bothered to even comment on this thread?

By the way this time reinstalling the drivers didn’t work. Some help would be very welcome.

I;'m still getting errors like the following

07/18 22:20:54 Trace: [Office PC] [Inactive] [PLAYING @ 0:00] Six Sonatas for Violin Solo Op. 27: Sonata No. 5 in G major: 2. Danse rustique. Allegro giocoso molto moderato - Moderato amabile - Tempo primo - Poco più mosso - Eugène Ysaÿe
07/18 22:20:54 Trace: [System Output] [raatclient] GOT [7] {“status”:“UnexpectedError”,“message”:“RAAT__OUTPUT_PLUGIN_STATUS_FORMAT_NOT_SUPPORTED”}
07/18 22:20:54 Warn: [Office PC] [zoneplayer/raat] failed to setup any endpoints…giving up
07/18 22:20:54 Info: [audio/env] [zoneplayer → stream] All streams were disposed
07/18 22:20:54 Info: [audio/env] [zoneplayer → stream → endpoint] All streams were disposed
07/18 22:20:54 Info: sleep 0ms after flush
07/18 22:20:54 Warn: [zone Office PC] Track Stopped Due to Error
07/18 22:20:54 Info: [zone Office PC] OnPlayFeedback StoppedEndOfMediaUnnatural
07/18 22:20:54 Debug: [zone Office PC] _Advance (Track)
07/18 22:20:54 Trace: [library] endmutation in 12ms
07/18 22:20:54 Warn: [analysis] failed with exception for trackid=30086706: Sequence contains no elements

Hey @name_here,

Ben with the support team here, thanks for taking the time to write in, and sorry for the delay.

If possible, could you please share a screenshot of your Start > Settings > Sounds and Audio Devices settings from the affected PC?

Would you be able to share the full logset from the PC to our File Uploader?

I’ll be on standby for your reply. :+1:

Thanks for replying. I’ve uploaded the latest logs and here’s the screen of my audio settings

It only is working on m9xx asio. The office pc and xmos wasapi don’t work - the others I don’t use at all.

Hey @name_here,

Thanks for sending those over. Our team will take a closer look and follow up with more information soon.

In the meantime, I’d be curious to see if you fully remove your Asio devices from Roon, and see if you’re able to play from your Wasapi endpoints.

On the flipside, if you remove your Wasapi endpoints, are you able to fully enable the rest of your Asio endpoints?

And, is all firmware is up to date across your Wasapi endpoints?

Thanks! :pray:

How do I fully remove a device from Roon? I have disabled them but I am not sure how I would take it further and remove them. As for firmware - I only have the m9xx and the firmware is up to date.

I’ve tried all combination and disabling and reenabling the audio endpoints and it’s not made a difference at all.

hello, still not working. I restored from a backup and that didn’t make any change either. This is getting really frustrating.

I tried this and that didn’t work either. But there’s no RaatServer folder, only RoonServer, which is what I used. I then had to restore from a backup and it was the same. I am able to play off my macbook so I don’t think it’s an issue with streaming services either. I’ve also tested and seen that the issue happens regardless of whether it’s local or from qobuz.

I’ve also restarted my usb dac by letting it unplugged for a few minutes and restarting it. Nothing is helping.

Well to anyone trying to fix this issue, I have a fix though it might cost you. I decided to test out HQPlayer and see if I can get that working with Roon. At first it didn’t work, but when I set HQPlayer output to the ASIO connection to my DAC, it worked, and it sounds great. So that’s a step in the right direction.

One other upside is that HQPlayer releases ASIO connected devices immediately when closing. That resolves an issue Roon kills windows audio and requires hard driver reset and audio device reset. It takes over the audio and doesn't let anything else work until reseetting drivers - #2 by Robert_F

They closed that issue so I can’t add this tip to that thread.

Seeing that I was able to properly route sound from roon → hqplayer → DAC using ASIO, I thought I’d troubleshoot a little bit to find why WASAPI wasn’t working. I found this thread HQ Player - Page 879 - Software - Audiophile Style and decided to test setting my default audio device to my screen to see if HQPlayer would take access to the DAC over WASAPI and lo and behold, it worked! And no discernable change to audio quality. Now when I pause Roon, hqplayer releases control of the device and I’m able to listen to other audio sources from windows. Magic.

Now I’d like to use hqplayer without exclusive mode, and use eapo to bypass windows APOs for bit perfect playback without relying on exclusive mode. Doesn’t appear to be an option though

Hey @name_here,

Thanks for sharing your update. I was able to chat with the team a bit more about your issue, and still have a few follow up things to test if you’re interested:

  1. Are you able to test out modifying the Roon Device Setup on you issue devices, and see if changing the channel layout to 5.1 or 7 may help?
  2. Try plugging the DAC into a remote device and not your core device. It would be god to see what driver update may pop up, this would also be a good USB test for the core audio within another device.
  3. Try temporarily moving your Roon core to your Win 11 PC to eliminate any standout issues correlated to the NAS.

I’ll be on standby for your reply. Thanks! :pray:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.