Too many failures RETURNS

This is an epidemic on the forum… My first post is from 6 months ago

and now it’s clearly not about one topology.

Can Room clarify what’s going on and why it seems to be spreading.

In my case, on my Nucleus.

You show that the track is available on both Qobuz and Tidal:

But when I go to play it, both services crap out:

And yet there it is, on Tidal:

I’ve seen this submitted at least ten times, but I can’t find a definitive explanation or solution.

Please advise.


I imagine you are aware that you don’t have the latest Roon version installed. Also, the current mac version is 10.14.4.

I didn’t find the history behind your problems, so I can’t comment on your network, other than to say that it doesn’t necessarily follow that if TIDAL works, then Roon should.

Flagging @support, and I wish you well.

thanks @John_V

I appreciate your insights. Here’s what it says about my mac and my nucleus:

It seems that I do have the latest stable version installed, right?

And I understand that there’s a gap between Tidal working and Roon working, but the error message isn’t particularly robust and the fact that this has been going on for various posters since last year is troubling.

Thanks again.

Ah, the 1.5 reference was from your initial post six months ago. My apologies.

Support has a process that they follow to troubleshoot. So I’ll beg off now.

Try to stay patient, but know that we all are aware that these snags are frustrating, particularly over a long period of time.

I read you.

I’m also frustrated by the seemingly ongoing buggy behavior of streaming. When it effects Roon Radio, it completely destroys the whole purpose of Radio.

I don’t believe the fault is completely that of the streaming services.

Hi @seth_Godin1 — Apologies for the troubles here!

I looked into this album and it appears that this album is only available to stream from TIDAL, not Qobuz. In most cases, if an album is not able to stream from Qobuz, it doesn’t appear in Roon. We are aware that in some cases, however, that unavailable albums do show in Roon and we are currently working with Qobuz on a solution to this.

I just tried out the TIDAL album on my end and confirmed that things seem to be playing okay. Just to verify, even if you choose the TIDAL version from the Versions tab, you’re still seeing this error?

Are other TIDAL albums giving you the same error currently in Roon or just this album?

that’s good news… the VERSIONS subtab shows me both versions, and if I switch to Tidal, it works.

so it sounds like Roon has two problems:

  1. it’s showing albums as being part of a service when they’re not, and defaulting to that service
  2. it’s not smart enough, when it fails, to go check the other version.

Of course, having to do this often is a pain, particularly with Roon Radio.

I haven’t poked deeply enough in the last day to have other examples for you, but if these are the problems, it seems likely that you’re on the cusp of fixing them.


I also see this problem from time to time, restarting the Roon Server fixes it.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.