Took out my microRendu to get it updated trying to setup usb via xmos driver but i get devioce failed to initialize [Resolved]

I power cycled my Vinnie Rossi dac, power cycled my windows 10 pc and it still wont initialize. I have been successfully running through my Rendu but am now direct usb.

Hi Ted,

When you refer to updating the mR, do you mean the software update or a hardware update ?

Does the mR boot up ? Do you see the Ethernet lights activate on the mR ? Can you access it via the web interface ?

I meant the hardware. Yes the Rendu does boot up fine and while the Rendu is being sent to Sonore for updating I need to listen to music.

Ah, I see. You’re trying to set up a direct USB connection to your DAC. Is the DAC set to the USB input ?

Yes it is set up to USB. Problem is I cannot get Roon to initialize the device (xmos driver). So Roon never sees the dac.

Notice that there are no gears next to the xmos driver in the pic I posted.

There won’t be any gears until you set it up by first clicking the blue enable button…

I did try to enable but that is my problem I get a ‘device failed to initialize’ error message. I tried re powering the dac, the pc and no luck.

I don’t understand your screenshot - why is the mR being shown on the System Output channel? It’s a networked device, surely? What happens if you disable this, and then try to enable the XMOS USB channel?

So I tried that (disabling the other Rendu device) and it still won’t initialize. Even went to the xmos control panel and it shows no connected device while it is clearly connected physically.

Hi @ted_betley ----- Thank you for the report and sharing your observations with us. The feedback is appreciated!

Moving forward, my assumption is that the DAC cannot be used outside of Roon via another application or media player since you mentioned that the xmos control panel shows “no connected device”. Please confirm.

Furthermore, during your troubleshooting have you tired…

  • Another USB cable.

  • Another USB port on the Win10 PC.

  • Reinstalling the XMOS driver.

-Eric

Tried another cable into a different slot and that worked. Thanks

1 Like

Thanks for sharing the resolve here, @ted_betley.

Happy listening!
-Eric