Touch buttons (play/forward/back) not working

I have 3 RPi 4 setups all working fine except for one where the touchscreen control buttons don’t work. All the other touchscreen functions work (settings etc). I’m using the latest version and tried rebooting and resetting extensions in ROON.

There’s no indication of low-power on the screen and I’m using separate power supplies for the pi and the screen.

Any ideas for me to try?

Thanks, Rick

Is the screen showing the correct metadata? So song/artist/title/track and cover art?

Can you send me feedback? So restart the unit, start playing some audio, press a few control buttons and then send me feedback so I can have a look. You can find this on the ‘advanced’ tab in the web interface.


Hi Harry - as ever, I’m blown away by how quickly you reply!

The metadata is fine and the only buttons that don’t work are the large play/back/forward ones. The feedback is f52722c1e9322c85.

Could it be a faulty screen?

Best regards, Rick

I’ve never heard of a faulty screen, but on the other hand I also don’t see the touches being registered in the logs (as they should).

So … that’s weird. I suggest you do a reinstall from scratch just to be sure…


Hi Harry. Thank you so much - will do a reinstall on Sunday and let you know…

Hi Harry. Still a mystery - complete reinstall and a new power supply for the screen, but still no working buttons. Feedback is 6279761bef35ab79. all I can think now is a faulty screeen

I’ve just send feedback 2284e4a7a2f48d7c. I have limited response touch; I can get the volume control to come up, and slide the slider, but the changes don’t stick. If I touch on the left hand edge, the screen refreshes. One thing is that I’m set up rotated due to the way my stand orients the screen. By a bizarre chain of circumstances, I have a spare display I could try swapping to, but I’d appreciate knowing what you see in the feedback. And by magic it just started working. Go figure.

The logs show that the play/pause are being registered.
Is the extension running? and does the zone name match exactly?