Touch screen not operational?

Continuing the discussion from Stable release 3.004 (2020/12/05):

Last week my RopieeeXL lost connection with Roon. The only way how I was able to restore operation, was a fresh reflash of my Pi (3B) - now with Ropieee.

The module is now fully operational, exept for several touch screen functions. For example, the “buttons” for reverse, pause and forward are not working. Also, I can not control the touch screen (pressing right bottom corner), but volume control works as usual.

Any suggestions what may cause this problem?


Did you renable the extension…name of ropieee and endpoint also must be identical

Thanks for your response - Yes, I did enable the extension.
In fact, everything except the touch screen seems to be working fine. (Display of the song playing, streaming to the DAC that is attached to my Pi).

Perhaps it is a hardware problem with the bottom part of my touch screen? I just realise that the controls in the top half of the screen (volume control, display off button on the top right) are functional…

Maybe try to reseat the screen’s flat cable on the RPi?

I have one unit that only works down the right hand edge I can power off the display and that’s about it can’t save anything settings wise or use any controls so it’s up out of reach just as a display and that’s it…and mostly a clock otherwise.

Problem solved - indeed the problem was caused by the touch screen. The bottom half was not operating as it should.
I tried reinserting the flatband cables, but the problem remained. Luckily, I had a spare screen that I could try and this one operated flawlessly.

Thanks for your suggestions!