Touchscreen Does Not Display Currently Playing Selection

Hi all,

I now have Ropieeexl running on a Pi 2B with the official Raspberry Pi 7" touchscreen.

Unfortunately, I’m running into two issues that might be related.

First, if I reboot the Pi, I get the message on the Touchscreen that Ropieeexl is still waiting for the Roon Zone to be configured, even though it is configured.

Secondly, the Touchscreen does not show the currently playing album/track. It is stuck on whatever the first song was when it started. Even if I use the Touchscreen Next or Previous track buttons, the song changes as expected to the appropriate track so that’s working correctly, but the display never shows the new track or new artwork. It is just permanently stuck on the very first track/artwork.

If I go to Advanced tab at Ropieeexl.local and reset the Roon Remote Extension, then the display becomes active after a reboot, but again gets stuck on whatever song happened to be playing.

Each time I reset the Roon Remote Extension via Ropieeexl.local, the display
updates to the currently playing track but when the next track or album comes up, the display doesn’t get updated. It keeps displaying whatever was playing when I restarted the Roon Ropieee extension.

Finally, after the 10 minute idle timeout, the clock is displayed even though there is still music playing.

Is the extension enabled in Roon?

Hi Harry,

Yes. That’s the odd thing. It is enabled but I have to restart it after I reboot the Pi and then whatever song has played first when I restart the extension, that’s the song and artwork that’s displayed on the Touchscreen. It never changes with the music.

After that, if I restart the extension again, it syncs with the current song, but then its stuck on that song.


Hi all,

I solved the problem. It apparently was something with the state of Roon Core. I restarted Roon Core and it solved both problems. Now after a reboot the touchscreen immediately resumes the Zone and now updates with each new song/album.

I’m brand new to Ropieee but I guess that is a best practice… remember to try restarting the Core too :slight_smile:



The first step in solving any problem is to reboot everything.

1 Like