Track Grouping Issue

I think this is the metadata for this album, but the track grouping for the Roon metadata merges the first two and last two movements of the Quintet into single tracks. Is there any way to get the metadata and tracks to match ?

Hi, @andybob, sorry for the late reply. I looked the our metadata for this album and it looks ok to me, work and part are written in a proper way. Have you already checked Track Grouping Settings for this album?



Hi Ivan,

The problem is that the Roon metadata I am seeing on the Identify Album screens above groups two tracks (Prelude and Fugue) into Track 5 and two further tracks (Intermezzo and Finale) into Track 7. Are you seeing the same ? I can’t think why the metadata would be different.

The file metadata correctly separates the seven tracks of the Quintet.

Nothing changes whether I set Album Editor/Metadata Preference/Multi-Composition Grouping to Roon or File. I haven’t, however, identified the Album because that would mismatch tracks as set out above.

Hi, @andybob , the thing here is that the release of this album, which we have in our database contains 7 tracks that’s why two last tracks are not grouped. So, when you identify the album, last two tracks are not grouped into a multipart composition. Furthermore, your files don’t contain WORK/PART file tags, so when your choose Prefer File Data in Metadata Preferences, Roon doesn’t group tracks the way you want to, as it doesn’t have info for Track/Part Grouping.

My suggestion here might be the following:

If you want to have this album identified:

  1. Set WORK/PART tags for all the tracks
  2. Set Part Grouping to use Prefer Files

If you do not want to have this album identified:

  1. Rename files which represent Britten’s compositions the way Shostakovich’s composition parts are named
  2. Or add WORK/PART tags like in the previous case.

Thanks and sorry for inconveniences!


Thanks Ivan, I’ll do the first.