Tracks don't start playing from Tidal without pressing pause and play (Chromecast Audio) [Resolved - B778]

Hi Roar!

Inside player at right bottom there is a volume icon. On top of volume bar that pops up you find some buttons and one of them is DSP. You need to activate it for every device if you have more than one CCA.


Thx. Found it! Have not tested much, but first impression is that it seems to have fixed the issue.


Any official update on this issue. Noticed the problem is on 1.8 also

It doesn’t happen as often as before in my system. But I was hoping for a total fix.

Having this same issue with CCA. If I try to set Sample rate conversion to Max PCM rate (power of 2), I only hear random clicks coming out from the speakers. Any idea why this happens?

Hi Simo,

What is your CCA connected to? One though is that your connected device doesn’t like higher sample rate. Another is if there is some kind of problem in your network since a higher sample rate also need more bandwidth. Or in worst case your CCA is defect.


It’s connected to Dspeaker Anti-mode 2.0 DAC / room correction device through Toslink. Right, I’d need to check the possible input rate of that device.

Edit. Manual says: Toslink S/PDIF -input 24-bit 32 / 44.1 / 48 kHz and 88.2 / 96 kHz -compatible.


I would have tested to download a free 24bit 96 khz track and stream it to your CCA with either bubbleupnp or mconnect (for Android). If that work it’s proberbly a Roon thing, if not it can be a hardware problem with your DAC or CCA.


1 Like

Thanks, I’ll try that.

Yup, CCA works with 24BIT/96kHz track (found from this site 2L High Resolution Music .:. free TEST BENCH) and so does the DAC (I learned that I can connect Toslink directly to my 2015 MBP to get such high sample rates).

Roon @support, what do you say?

4 posts were merged into an existing topic: Chromecast not gapless on NAD C338 (again)

I’m not sure why Roon Support merged your topic (Chromecast not gapless on NAD C338 (again) into this topic (Tracks don’t start playing from Tidal without pressing pause and play (Chromecast Audio)). Both issues affect Chromecast Audio devices, but not playing at all (without pressing play for every song) and not playing gapless are different issues. Hopefully a solution for both is being worked on.

It seems like your post would fit better in either of these two active topics:

Core Machine (Operating system/System info/Roon build number)
Lenovo T460 Thinkpad Fedora F33 running Roon Core version 1.8 (build 764) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon Remote on Android Pixel 3 phone → Wired ethernet → Netgear WGR614v10 → WiFi → Chromecast Audio dongle

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chromecast Audio dongle

Description Of Issue

After upgrading to Roon 1.8, Roon Core found the Chromecast dongle and the Chromecast Audio “acknowledgement” sound plays, possibly truncated. But pressing the play triangle in Roon Remote doesn’t do anything beyong change to the pause || button. I can click the green dot and it shows the Signal path with no indicated errors, but I don’t hear anything and the playback bar doesn’t advance.

I waited over a minute then pressed play, and it works! It definitely wasn’t this slow with previous version. And when it gets to the next track or I press >| to advance to next track, it displays as paused; there is no music until I press Play/Pause three times.

In /var/roon/RoonServer/Logs/RoonServer_log.txt there are no errors when it gets to the new track:

02/27 16:07:38 Info: [CC Jambox] [zoneplayer] Starting playback
02/27 16:07:38 Info: [cast/httpresponder] [/2ceec72e53844d118aea3826ef124f4b] delete flac encoder
02/27 16:07:38 Trace: [cast] [Sooloos.Broker.Transport.CastEndpointIntegration] URL:
02/27 16:07:38 Info: [zone CC Jambox] OnPlayFeedback Playing
02/27 16:07:38 Trace: [CC Jambox] [HighQuality, 16/44 FLAC => 24/44] [100% buf] [PLAYING @ 0:00] Changing - John Mayer
02/27 16:07:38 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/213 sec
02/27 16:07:38 Info: [cast/httpresponder] [/f556965a7d22484bbc3cc7f57d3a29f4] GOT REQUEST Get /f556965a7d22484bbc3cc7f57d3a29f4
02/27 16:07:38 Info: [cast/httpresponder] [/f556965a7d22484bbc3cc7f57d3a29f4]   current path: /f556965a7d22484bbc3cc7f57d3a29f4
02/27 16:07:38 Trace: [cast/httpresponder] [/f556965a7d22484bbc3cc7f57d3a29f4] request matches current stream

and it continues to print a Trace message where it’s PLAYING the song but not advancing.

02/27 16:12:00 Trace: [CC Jambox] [HighQuality, 16/44 FLAC => 24/44] [100% buf] [PLAYING @ 0:00/3:33] Changing - John Mayer

Hmm. I also have an Orchard PecanPi Streamer and playback to that has no problems.

Not sure what happened, but had no issues with my Chromecast audio problem, I presume this is now resolved.

It was found that the music would pause when changing track.

@Craigio, you’re saying the pausing of songs issue is now resolved on Chromecast Audio? If so, I’ll re-enable my Chromecast Audios. I noticed the issue was less likely to happen when I played an album but when it tried to go out and grab songs from Roon Radio or especially when changing between different file formats, it would stall and only a Pause/Play would get it playing again. - The workaround to utilize DSP to force everything to the same bitrate/bitdepth did work but uses unnecessary bandwidth on my wifi.

If this issue is resolved, I would have expected a note pertaining to the issue in the release notes from the most recent Roon updates. Regardless, if it’s fixed that’s great news.

1 Like


Everything looks as it’s working correctly with Chromecast Audio now :slightly_smiling_face:


It looking good for me at the moment, i realised how much a pain was as its been great just to enjoy music more than wonder what happens when you get to the end of the track.

Fingers crossed:)

Thanks for the follow-up! This was addressed in Build 778:

Great news! I had seen in the release notes about fixing gapless playback on Chromecast Audio, I didn’t know the pause/start issue was wrapped up in that fix too. Thanks for the clarification and update.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.