Tracks dropping out when played via Raspberry Pi over wifi

Roon Core Machine

(Model, CPU, RAM) —>

Mac mini Late 2012
2.6 Ghz quad core Intel i7
16gb RAM
macOS Big SUR

Networking Gear & Setup Details

Amplifi Ubiquiti Afi-R

Connected Audio Devices

Wifi connection to Raspberry Pi 4 Model B Rev 1.4
Running RopiEEEE XL 4.002

Also USB connection to RME babyface pro direct from my roon core machine

Number of Tracks in Library

40,000 tracks

Description of Issue

My Raspberry pi (which I stream to via wifi) has started dropping out after a few seconds of every track I play. I am getting "network errors" and am unable to play any music at all. This is a new issue over the last week or so, I've had the pi running over wifi flawlessly for a few months before this happened My Mac mini is also connected to the same wifi network but is not dropping out at all,

Since you probably don’t have control of other peoples’ WLAN, things might be more or less problematic from day to day.

That said, I’d like to strongly encourage you to try a LAN cable for your Mac to see if things are more stable then - you probably know, that it’s a best practice recommendation by Roon, anyway…

1 Like

sorry I don’t know what this means?

Can you please explain. Are you suggesting I connect my mac to the network via ethernet cable?
My mac has never been connected this way and I’ve never had issues with it. Playback via the Rpi is the issue, playback via my mac is fine

Often times, things are not as straight forward as one might think…

Your WLAN is (negatively) influenced by other people’s WLAN, so transmission quality/speed is dependant on what changes take place around you - you’ve really got no control over that!
You might just have been lucky for a certain time…

There are other users like you, that only experience such problems with Roon, so it seems that it’s either very resource demanding or inadequately programmed for what it’s got to do.

Going all wireless, your Mac core has to pull music and metadata as well as do some housekeeping over WiFi while sending the music stream to the RPi over WiFi at the same time, trying to keep the end point buffer nicely filled.

As wireless isn’t full duplex like LAN, you would greatly lessen your network demands by using a LAN cable.
Do yourself a favor and try it just to verify if that’s where your problems originate.


Ok So I connected my Mac mini directly to my router.
RPi still wireless (that’s the only way I can connect it. It’s not close to a ethernet point)

Unfortunately it’s still dropping out

Are you using the built in WiFi of the Raspberry Pi ? I had the same issue and added a USB WiFi Dongle to solve the problem…

Yes I’m using the built in one.
But it’s a new issue, it’s been fine for months prior to now. Also I specifically bought the Pi model 4 as I read a discussion on this forum about it being good for wireless with Ropieee

The RPi WiFi implementation is not renown for its robustness , @Marin_Weigel is probably referring to interference from other wi fi networks in your location. I can see may neighbors routers so they must be strong enough to interfere. I once suffered the 6pm blues , wifi worked fine all day the come 6pm my neighbors came home and started using . Working from home has exacerbated this interference.

Can you lash up a cable just to test ?

If not do you have a WiFi repeater you can connect to the Pi with ethernet , hence by-passing the Pi’s WiFi

Roon is somewhat demanding of networking, several times the Pi WiFi has been found “wanting”

The best advice is run a cable :smiling_imp:

1 Like

So after connecting it up to an Ethernet cable, I now have a different problem.
I no longer get the “network’ or “hardware” error with the associated skipping of tracks after 15 seconds.
Now it plays a couple of songs and then just stops :frowning:

restart everting network and roon.

also what bit rates are you trying to play - basic rates or hires?

1 Like


I have a Pi 4 on WiFi and have experienced the dropouts mentioned in the OP a couple of times.

Each time a full network reboot settled everything down.

I have restarted Roon many times.

Will restart network and see if that helps :+1:

1 Like

Hey @Trevor_Nathan,

Thanks for choosing to post about this on the Roon community and for engaging with everyone who’s tried to help.

Resetting the network would be a great step when you can try it. Please, just like you did so far, keep us posted :nerd_face:

1 Like

Sorry for the delayed response.
The full reset seems to have done the trick. Pi is back happily streaming. Thanks all :+1:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.