Tracks immediately skip when the Roon Core pc is selected as the audio zone

Problem: Music doesn’t play on the pc that Roon is installed on, all tracks are skipped immediately.

I have Roon Core running on a Windows 10 desktop pc. I can play music, both from the local library and Tidal, (usually) without any problems on different devices/zones in my house, and transfer the music between zones. Some are Roon Ready, some via Chromecast or Airplay. I even got Roon ARC to work.

But when I select the Roon pc (called “Fractal PC”) itself as a zone, all tracks immediately skip, nothing is played. It doesn’t matter which audio output device I try, I have enabled and disabled them all.

By default I have the audio from the pc go to a Focusrite audio interface via USB, and then into a Yamaha receiver. Alternatively it can go via HDMI (“Nvidia”) into my monitor, or use the pc’s audio out (“Realtek”, not connected to anything right now). The pc plays other audio without any problems via the Focusrite or the Nvidia hdmi: YouTube, games, instruments plugged into the Focusrite, etc. As far as I know all audio drivers are up to date. The Windows device manager doesn’t show any problems, and sounds play when I click ‘Test’.

I vaguely remember reading something a long time ago about how audio devices (?) not being set up properly cause tracks to immediately skip, but I can’t find that information anymore. The ‘device setup’ options in Roon itself are set to default.

What could be the problem here? :thinking:



Screenshot 2023-02-19 113838
Screenshot 2023-02-19 114816

Enable the individual audio devices you see in audio, this pc then try.

The last bit from the Roon_log.txt showing, I think, what happens immediately after trying to play a track in this zone. Clock sync problems? :thinking:
It’s all set to default afaik, and the ‘zone’ is not in a group or something, what does it need to sync to?

02/19 12:44:10 Info: 
--[ SignalPath ]---------------------------------------------
SignalPath Quality = HighQuality
Elements:
    Source Format=Flac 44100/16/2 BitRate=495 Quality=Lossless
    UpgradeBitDepth FromBitsPerSample=16 ToBitsPerSample=64 Quality=Lossless
    VolumeNormaliation GainDb=0 Quality=Lossless
    Truncate FromBitsPerSample=64 ToBitsPerSample=16 Quality=HighQuality
    Raat Device=System Output
    Output OutputType=Local_SharedMode_Wasapi Quality=HighQuality SubType= Model=System Output
------------------------------------------------------------
02/19 12:44:11 Warn: [Fractal PC] [zoneplayer/raat] failed to sync sender clock to endpointSystem Output: Sooloos.Broker.Transport.ClockSyncResult
02/19 12:44:11 Warn: [Fractal PC] [zoneplayer/raat] failed to sync clocks with any endpoints..giving up
02/19 12:44:11 Info: [audio/env] [zoneplayer -> stream] All streams were disposed
02/19 12:44:11 Info: sleep 0ms after flush
02/19 12:44:11 Warn: [zone Fractal PC] Track Stopped Due to Error
02/19 12:44:11 Info: [audio/env] [zoneplayer -> stream -> endpoint] All streams were disposed
02/19 12:44:11 Info: [zone Fractal PC] OnPlayFeedback StoppedEndOfMediaUnnatural
02/19 12:44:11 Info: [zone Fractal PC] OnPlayFeedback Stopped
02/19 12:44:11 Info: [zone Fractal PC] Canceling Pending Sleep
02/19 12:44:11 Trace: [Fractal PC] [HighQuality, 16/44 FLAC => 16/44] [STOPPED @ 0:00] L'Ours Musicien - Vangelis
02/19 12:44:11 Info: [audio/env] [zoneplayer] All streams were disposed
02/19 12:44:11 Info: Alert: Transport: stopping_too_many_failures
02/19 12:44:11 Warn: AddTopLevel: win_alert(7009)
02/19 12:44:11 Info: Alert: Transport: stopping_too_many_failures
02/19 12:44:12 Info: [stats] 8861mb Virtual, 2035mb Physical, 1130mb Managed, 4253 Handles, 225 Threads

Googling this error “[zoneplayer/raat] failed to sync sender clock to endpointSystem” pointed me towards some forum topics about VPN software interfering, maybe blocking ‘clock signals’? :thinking:

Disabling my VPN didn’t help though, and Roon.exe was already in the VPN’s list of excluded apps. But… disabling the VPN and then also disabling and reenabling the audio device in Roon did work. So it did have something to do with the VPN… Then it dawned on me that Roon not only uses Roon.exe, but also RAATServer.exe :exploding_head:

Adding RAATServer.exe (in C:\Users\jp\AppData\Local\Roon\Application ) to the VPN’s list of excluded apps seems to have solved the problem! :partying_face:

Screenshot 2023-02-19 131311

Thanks, I already tried that. I enabled them all, the ASIO’s, the WASAPI’s… Focusrite, Nvidia and Realtek. When enabled they appear in the long list of audio zones of course, but none of them work, so I leave them disabled. Roon should use the Windows system device anyway, which usually is the Focusrite.

Unfortunately this stopped working… apparently it was not about the VPN :pensive:.

Hello? Any response from Roon Support?

This topic was automatically closed after 19 hours. New replies are no longer allowed.